summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-07-28 09:54:54 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-07-28 09:54:54 -0400
commit734427ad69fcf920f861ebfe4b1141c89496317b (patch)
treed49fd81a147f543237569152cae03aedb0dfa534 /dev-python
parentd241ee7943383a8ad8aacd70d5e301a6acf22c38 (diff)
downloadgentoo-overlay-734427ad69fcf920f861ebfe4b1141c89496317b.tar.xz
gentoo-overlay-734427ad69fcf920f861ebfe4b1141c89496317b.zip
import more packages
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/fonttools/Manifest1
-rw-r--r--dev-python/fonttools/fonttools-4.12.1.ebuild50
-rw-r--r--dev-python/fonttools/metadata.xml8
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/fonttools/Manifest b/dev-python/fonttools/Manifest
new file mode 100644
index 0000000..bd14b66
--- /dev/null
+++ b/dev-python/fonttools/Manifest
@@ -0,0 +1 @@
+DIST fonttools-4.12.1.tar.gz 2449008 BLAKE2B 11c08ee391c7306694538f602e68b95bc8c05aa6a227a1efa79e0f88cbe78a7d68eed6eaf371b36ebc84e691e360a16d2ba176a67b40b27dcf8ca0a33beb0a96 SHA512 4200214236dc2e8c0997223a95c1271b3d4c088b9c086e5f6481a311a80fdeb39d56f5aebd278434f84d3fb1c626c32bc5a3ebd7e05ebf5b1d338dcd42e8a92a
diff --git a/dev-python/fonttools/fonttools-4.12.1.ebuild b/dev-python/fonttools/fonttools-4.12.1.ebuild
new file mode 100644
index 0000000..f15fbef
--- /dev/null
+++ b/dev-python/fonttools/fonttools-4.12.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
+HOMEPAGE="https://github.com/fonttools/fonttools/"
+SRC_URI="https://github.com/fonttools/fonttools/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 sparc x86"
+RESTRICT="!test? ( test )"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+
+ >=dev-python/fs-2.4.9[${PYTHON_USEDEP}]
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ app-arch/zopfli
+ )"
+
+python_prepare_all() {
+ # When dev-python/pytest-shutil is installed, we get weird import errors.
+ # This is due to incomplete nesting in the Tests/ tree:
+ #
+ # Tests/feaLib/__init__.py
+ # Tests/ufoLib/__init__.py
+ # Tests/svgLib/path/__init__.py
+ # Tests/otlLib/__init__.py
+ # Tests/varLib/__init__.py
+ #
+ # This tree requires an __init__.py in Tests/svgLib/ too, bug #701148.
+ touch Tests/svgLib/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # virtualx used when matplotlib is installed causing plot module tests to run
+ virtx pytest -vv Tests fontTools
+}
diff --git a/dev-python/fonttools/metadata.xml b/dev-python/fonttools/metadata.xml
new file mode 100644
index 0000000..1073d2b
--- /dev/null
+++ b/dev-python/fonttools/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">fonttools/fonttools</remote-id>
+ </upstream>
+</pkgmetadata>