summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2022-06-04 18:24:53 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2022-06-04 18:24:53 -0400
commiteaea74c6564fa56927330cf4c70158f2c7acc325 (patch)
tree2b7ebf0f1d133b4a53b68b0af6da68ae8981020f /dev-qt
parent6cb2acb44b19d51072b401aba319ec34557e3c28 (diff)
downloadgentoo-overlay-eaea74c6564fa56927330cf4c70158f2c7acc325.tar.xz
gentoo-overlay-eaea74c6564fa56927330cf4c70158f2c7acc325.zip
dev-qt/qtgui: upgrade to 5.15.4, remove old patches
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtgui/Manifest3
-rw-r--r--dev-qt/qtgui/files/qtgui-5.14.1-cmake-macro-backward-compat.patch50
-rw-r--r--dev-qt/qtgui/files/qtgui-5.15.2-bogus-xcb-util-dep.patch72
-rw-r--r--dev-qt/qtgui/qtgui-5.15.4.ebuild (renamed from dev-qt/qtgui/qtgui-5.15.3.ebuild)4
4 files changed, 4 insertions, 125 deletions
diff --git a/dev-qt/qtgui/Manifest b/dev-qt/qtgui/Manifest
index c5696e6..29133ab 100644
--- a/dev-qt/qtgui/Manifest
+++ b/dev-qt/qtgui/Manifest
@@ -1 +1,2 @@
-DIST qtbase-5.15.2-c9fde86b.tar.gz 67960262 BLAKE2B d1a6a7dac78abce189a753c0a00185fbe03f9de97b226790535af73a9bc009b353fe1edeb754d2098a7beeb7cd1c6e7efb949797658269ef0d0f200f11909820 SHA512 99026537dd4da678bcb04214ebb717907422e373b44fd3b3716798565c330f8d492ec1fc67d936c5125292b30e44f23abe4bf6434b58b9fa76bada3680dfc9f8
+DIST qtbase-5.15.4-gentoo-kde-1.tar.xz 507288 BLAKE2B a22d3745d3c690e29f7726cc464e3721777768e6e4f937e84ee2d2e14a13bcf7724e0c30b2cf4277c9ac7dadc1078545e14fb5459fbc3acc7259fb3e39e2f417 SHA512 a52bdf189e4c0fe341c2db0a5923a3600503d8eaa0c3693923a02a0ab4fa6dfc1beb21067f4723fcf2e4d7c71e39a496bf34e109e1e1c8c42922ff53f6712373
+DIST qtbase-everywhere-opensource-src-5.15.4.tar.xz 50225468 BLAKE2B 3525126791ca168ea4227bc58bef0202f4cec68396c958b0e7f09e7b41ca9d70bbcf0e78b5e7997bc3e4a59e889128f93964b5d0a9db7d012403581cff3dc30b SHA512 91a1d95c2891939ae55134e8897cbc423142bd8eda954a1e65bb563b0932ed9e2da34db374fd86858b4a819e8abe824a967b31f4fb316528ec8aaf15016c6ad3
diff --git a/dev-qt/qtgui/files/qtgui-5.14.1-cmake-macro-backward-compat.patch b/dev-qt/qtgui/files/qtgui-5.14.1-cmake-macro-backward-compat.patch
deleted file mode 100644
index 30b5abc..0000000
--- a/dev-qt/qtgui/files/qtgui-5.14.1-cmake-macro-backward-compat.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-From: Andreas Sturmlechner <asturm@gentoo.org>
-Date: Sun, 9 Feb 2020 11:45:00 +0100
-Subject: [PATCH] qtcore: Fix cmake macro compat. for upgrade from <Qt-5.14
-
-In upstream commit:
-
-https://code.qt.io/cgit/qt/qtbase.git/commit/?h=5.14&id=63d9cd17
-
-_populate_$${CMAKE_MODULE_NAME}_plugin_properties in 5.14.0 gained an additional argument
-IsDebugAndRelease without providing backward compatibility. This macro is used (at least) for
-QtGui and QtDesigner plugins added by qtimageformats, qtsvg, qtvirtualkeyboard and qtwayland.
-During upgrade from <Qt-5.14 to >=Qt-5.14, as a consequence of slot upgrade rebuilds, some
-reverse dependencies are slated for rebuild before these Qt consumers have been rebuilt and their
-cmake files regenerated, leading to cmake errors like:
-
-https://bugs.gentoo.org/703306
-https://bugs.gentoo.org/705198
-
-From mkspecs/features/create_cmake.prf:
-
-# CMAKE_DEBUG_AND_RELEASE is used to tell the _populate_$${CMAKE_MODULE_NAME}_target_properties
-# functions whether a Configuration specific generator expression needs to be added to the values
-# of INTERFACE_LINK_LIBRARIES and INTERFACE_LINK_OPTIONS. For debug_and_release builds, we do need
-# configuration specific values. For singular builds (only release or only debug), we want the
-# values to be applied regardless of the configuration.
-# This would allow on Linux and macOS (and with a recent enough version of CMake on Windows) to
-# build a Debug configuration of an application, even if Qt was built in a Release configuration.
-
-qt5-build.eclass is configuring either as 'release' or as 'debug', so we make IsDebugAndRelease
-optional and default to FALSE.
-
---- a/mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in 2020-01-23 13:37:32.000000000 +0100
-+++ b/mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in 2020-02-09 15:15:21.156219814 +0100
-@@ -538,8 +538,14 @@
-
- file(GLOB pluginTargets \"${CMAKE_CURRENT_LIST_DIR}/Qt5$${CMAKE_MODULE_NAME}_*Plugin.cmake\")
-
-- macro(_populate_$${CMAKE_MODULE_NAME}_plugin_properties Plugin Configuration PLUGIN_LOCATION
-- IsDebugAndRelease)
-+ macro(_populate_$${CMAKE_MODULE_NAME}_plugin_properties Plugin Configuration PLUGIN_LOCATION)
-+ set(IsDebugAndRelease FALSE)
-+ set (list_var ${ARGN})
-+ list(LENGTH list_var num_extra_arg)
-+ if (${num_extra_arg} GREATER 0)
-+ list(GET list_var 0 IsDebugAndRelease)
-+ endif()
-+
- set_property(TARGET Qt5::${Plugin} APPEND PROPERTY IMPORTED_CONFIGURATIONS ${Configuration})
-
- !!IF isEmpty(CMAKE_PLUGIN_DIR_IS_ABSOLUTE)
diff --git a/dev-qt/qtgui/files/qtgui-5.15.2-bogus-xcb-util-dep.patch b/dev-qt/qtgui/files/qtgui-5.15.2-bogus-xcb-util-dep.patch
deleted file mode 100644
index b7f6548..0000000
--- a/dev-qt/qtgui/files/qtgui-5.15.2-bogus-xcb-util-dep.patch
+++ /dev/null
@@ -1,72 +0,0 @@
-From 61b07d75f96d4dfb07b485b2a9bd7aed099df987 Mon Sep 17 00:00:00 2001
-From: Liang Qi <liang.qi@qt.io>
-Date: Tue, 1 Dec 2020 08:43:28 +0100
-Subject: [PATCH] Revert "xcb: add xcb-util dependency for xcb-image"
-MIME-Version: 1.0
-Content-Type: text/plain; charset=utf8
-Content-Transfer-Encoding: 8bit
-
-This reverts commit adc42bebcac764ca8de78578e3a4ac39b621bd09.
-
-adc42beb is wrong, the bug is for static build of qt with static
-xcb. It adds the explicit dependency of xcb-util 0.3.9, which is
-not available on Debian yet.
-
-Task-number: QTBUG-86287
-Fixes: QTBUG-88688
-Change-Id: Iffc821f49bdfcad3f2556951d3677c35a7682266
-Reviewed-by: Thiago Macieira <thiago.macieira@intel.com>
-Reviewed-by: Tor Arne Vestbø <tor.arne.vestbo@qt.io>
-(adapted from commit 92a57e0b016f811876ec1d62328ca8edfe452a3a)
----
- src/gui/configure.json | 14 ++------------
- 1 file changed, 2 insertions(+), 12 deletions(-)
-
-diff --git a/src/gui/configure.json b/src/gui/configure.json
-index c8c4864eca6..1f08795c57b 100644
---- a/src/gui/configure.json
-+++ b/src/gui/configure.json
-@@ -601,15 +601,6 @@
- ],
- "use": "xcb"
- },
-- "xcb_util": {
-- "label": "XCB Util >= 0.3.9",
-- "headers": "xcb/xcb_util.h",
-- "sources": [
-- { "type": "pkgConfig", "args": "xcb-util >= 0.3.9" },
-- "-lxcb-util"
-- ],
-- "use": "xcb"
-- },
- "xcb_image": {
- "label": "XCB Image >= 0.3.9",
- "headers": "xcb/xcb_image.h",
-@@ -617,7 +608,7 @@
- { "type": "pkgConfig", "args": "xcb-image >= 0.3.9" },
- "-lxcb-image"
- ],
-- "use": "xcb_shm xcb_util xcb"
-+ "use": "xcb_shm xcb"
- },
- "xcb_keysyms": {
- "label": "XCB Keysyms >= 0.3.9",
-@@ -1065,7 +1056,6 @@
- "tail": "#undef explicit",
- "include": [
- "xcb/xcb.h",
-- "xcb/xcb_util.h",
- "xcb/xcb_image.h",
- "xcb/xcb_keysyms.h",
- "xcb/randr.h",
-@@ -1097,7 +1087,7 @@
- "xcb_xkb_get_kbd_by_name_replies_key_names_value_list_sizeof(nullptr, 0, 0, 0, 0, 0, 0, 0, 0);"
- ]
- },
-- "use": "xcb_icccm xcb_util xcb_image xcb_keysyms xcb_randr xcb_render xcb_renderutil xcb_shape xcb_shm xcb_sync xcb_xfixes xcb_xinerama xcb_xkb xcb"
-+ "use": "xcb_icccm xcb_image xcb_keysyms xcb_randr xcb_render xcb_renderutil xcb_shape xcb_shm xcb_sync xcb_xfixes xcb_xinerama xcb_xkb xcb"
- },
- "x11prefix": {
- "label": "X11 prefix",
---
-2.16.3
diff --git a/dev-qt/qtgui/qtgui-5.15.3.ebuild b/dev-qt/qtgui/qtgui-5.15.4.ebuild
index 441add6..38a3521 100644
--- a/dev-qt/qtgui/qtgui-5.15.3.ebuild
+++ b/dev-qt/qtgui/qtgui-5.15.4.ebuild
@@ -11,7 +11,7 @@ DESCRIPTION="The GUI module and platform plugins for the Qt5 framework"
SLOT=5/${QT5_PV} # bug 707658
if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi
IUSE="accessibility dbus egl eglfs evdev +gif gles2-only ibus jpeg
@@ -38,7 +38,7 @@ RDEPEND="
x11-libs/libdrm
)
evdev? ( sys-libs/mtdev )
- jpeg? ( virtual/jpeg )
+ jpeg? ( media-libs/libjpeg-turbo:= )
gles2-only? ( media-libs/libglvnd )
!gles2-only? ( media-libs/libglvnd[X] )
libinput? (