summaryrefslogtreecommitdiff
path: root/dev-util/android-udev-rules/android-udev-rules-20210501-r1.ebuild
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-10-20 13:20:07 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-10-20 13:20:07 -0400
commitf6298779718db2970d14e6e2a0bc1fe0d993679f (patch)
treef37328597d84d96daf390b3e70ba6a0020af4f66 /dev-util/android-udev-rules/android-udev-rules-20210501-r1.ebuild
parente43eed86c776b6bdfd09b14a496fd99a408ae946 (diff)
downloadgentoo-overlay-f6298779718db2970d14e6e2a0bc1fe0d993679f.tar.xz
gentoo-overlay-f6298779718db2970d14e6e2a0bc1fe0d993679f.zip
dev-util/android-udev-rules: convert to acct-group
Diffstat (limited to 'dev-util/android-udev-rules/android-udev-rules-20210501-r1.ebuild')
-rw-r--r--dev-util/android-udev-rules/android-udev-rules-20210501-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/android-udev-rules/android-udev-rules-20210501-r1.ebuild b/dev-util/android-udev-rules/android-udev-rules-20210501-r1.ebuild
new file mode 100644
index 0000000..22bf11a
--- /dev/null
+++ b/dev-util/android-udev-rules/android-udev-rules-20210501-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vcs-snapshot udev
+
+DESCRIPTION="Comprehensive list of udev rules to connect to android devices"
+HOMEPAGE="https://github.com/M0Rf30/android-udev-rules"
+SRC_URI="https://github.com/M0Rf30/android-udev-rules/archive/${PV}.tar.gz -> ${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ acct-group/adbusers
+ virtual/udev
+"
+
+src_install() {
+ udev_dorules 51-android.rules
+}
+
+pkg_postinst() {
+ einfo "To be able to use android devices,"
+ einfo "add yourself to the 'adbusers' group by calling"
+ einfo " usermod -a -G adbusers <user>"
+}