summaryrefslogtreecommitdiff
path: root/dev-util/binaryen/binaryen-101.ebuild
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-09-11 09:53:11 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-09-11 09:53:11 -0400
commit1b334f896e21de3acfd435bd686b402180f7d1f4 (patch)
tree39aa230f64d8e0c3ce09c179c60f0948a7365cfb /dev-util/binaryen/binaryen-101.ebuild
parentcd6db1b8550bf817d916c88189ed3162807284ce (diff)
downloadgentoo-overlay-1b334f896e21de3acfd435bd686b402180f7d1f4.tar.xz
gentoo-overlay-1b334f896e21de3acfd435bd686b402180f7d1f4.zip
dev-util/binaryen: 102
Diffstat (limited to 'dev-util/binaryen/binaryen-101.ebuild')
-rw-r--r--dev-util/binaryen/binaryen-101.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-util/binaryen/binaryen-101.ebuild b/dev-util/binaryen/binaryen-101.ebuild
deleted file mode 100644
index b2e42e7..0000000
--- a/dev-util/binaryen/binaryen-101.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="Compiler and toolchain infrastructure library for WebAssembly"
-HOMEPAGE="https://github.com/WebAssembly/binaryen"
-SRC_URI="https://github.com/WebAssembly/binaryen/archive/version_${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-# broken
-RESTRICT="test"
-
-S="${WORKDIR}/binaryen-version_${PV}"
-
-PATCHES=(${FILESDIR}/binaryen-undo-compile-flag-braindamage.patch)
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_WERROR=no
- -DBUILD_LLVM_DWARF=no
- )
- cmake_src_configure
-}
-
-src_test() {
- cd "${BUILD_DIR}" || die
- "${S}/check.py" || die
-}