summaryrefslogtreecommitdiff
path: root/dev-util/binaryen/binaryen-101.ebuild
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-04-24 16:26:30 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-04-24 16:26:30 -0400
commit1c09802fd645ef2bca0d048aaeb51faa1de38392 (patch)
tree49840c53247186da072055b5790efed64afdc385 /dev-util/binaryen/binaryen-101.ebuild
parent03ae4b4892e5461bd2c2fb1739b59afc94a8f083 (diff)
downloadgentoo-overlay-1c09802fd645ef2bca0d048aaeb51faa1de38392.tar.xz
gentoo-overlay-1c09802fd645ef2bca0d048aaeb51faa1de38392.zip
dev-util/binaryen: new package
Diffstat (limited to 'dev-util/binaryen/binaryen-101.ebuild')
-rw-r--r--dev-util/binaryen/binaryen-101.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/binaryen/binaryen-101.ebuild b/dev-util/binaryen/binaryen-101.ebuild
new file mode 100644
index 0000000..e03a08d
--- /dev/null
+++ b/dev-util/binaryen/binaryen-101.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Compiler and toolchain infrastructure library for WebAssembly"
+HOMEPAGE="https://github.com/WebAssembly/binaryen"
+SRC_URI="https://github.com/WebAssembly/binaryen/archive/version_${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# broken
+RESTRICT="test"
+
+S="${WORKDIR}/binaryen-version_${PV}"
+
+PATCHES=(${FILESDIR}/binaryen-undo-compile-flag-braindamage.patch)
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_WERROR=no
+ -DBUILD_LLVM_DWARF=no
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ cd "${BUILD_DIR}" || die
+ ${S}/check.py || die
+}