summaryrefslogtreecommitdiff
path: root/dev-util/binaryen/binaryen-102.ebuild
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-09-11 09:53:11 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-09-11 09:53:11 -0400
commit1b334f896e21de3acfd435bd686b402180f7d1f4 (patch)
tree39aa230f64d8e0c3ce09c179c60f0948a7365cfb /dev-util/binaryen/binaryen-102.ebuild
parentcd6db1b8550bf817d916c88189ed3162807284ce (diff)
downloadgentoo-overlay-1b334f896e21de3acfd435bd686b402180f7d1f4.tar.xz
gentoo-overlay-1b334f896e21de3acfd435bd686b402180f7d1f4.zip
dev-util/binaryen: 102
Diffstat (limited to 'dev-util/binaryen/binaryen-102.ebuild')
-rw-r--r--dev-util/binaryen/binaryen-102.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/binaryen/binaryen-102.ebuild b/dev-util/binaryen/binaryen-102.ebuild
new file mode 100644
index 0000000..b2e42e7
--- /dev/null
+++ b/dev-util/binaryen/binaryen-102.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Compiler and toolchain infrastructure library for WebAssembly"
+HOMEPAGE="https://github.com/WebAssembly/binaryen"
+SRC_URI="https://github.com/WebAssembly/binaryen/archive/version_${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# broken
+RESTRICT="test"
+
+S="${WORKDIR}/binaryen-version_${PV}"
+
+PATCHES=(${FILESDIR}/binaryen-undo-compile-flag-braindamage.patch)
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_WERROR=no
+ -DBUILD_LLVM_DWARF=no
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ cd "${BUILD_DIR}" || die
+ "${S}/check.py" || die
+}