summaryrefslogtreecommitdiff
path: root/dev-util/binaryen/binaryen-103.ebuild
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-12-03 12:20:19 -0500
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-12-03 12:20:19 -0500
commit43ba16dcf99256afef7fdbe4182a35d2635bef62 (patch)
tree632cf79abff25867b260ebb1281e8503ad3a8b0c /dev-util/binaryen/binaryen-103.ebuild
parent57bf4393de6aa3a42d66ed2e7b70dcdd0a35e2dd (diff)
downloadgentoo-overlay-43ba16dcf99256afef7fdbe4182a35d2635bef62.tar.xz
gentoo-overlay-43ba16dcf99256afef7fdbe4182a35d2635bef62.zip
dev-util/binaryen: upgrade to 103
Diffstat (limited to 'dev-util/binaryen/binaryen-103.ebuild')
-rw-r--r--dev-util/binaryen/binaryen-103.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-util/binaryen/binaryen-103.ebuild b/dev-util/binaryen/binaryen-103.ebuild
new file mode 100644
index 0000000..f2e64bb
--- /dev/null
+++ b/dev-util/binaryen/binaryen-103.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Compiler and toolchain infrastructure library for WebAssembly"
+HOMEPAGE="https://github.com/WebAssembly/binaryen"
+SRC_URI="https://github.com/WebAssembly/binaryen/archive/version_${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# broken
+RESTRICT="test"
+
+S="${WORKDIR}/binaryen-version_${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_WERROR=no
+ -DBUILD_LLVM_DWARF=no
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ cd "${BUILD_DIR}" || die
+ "${S}/check.py" || die
+}