summaryrefslogtreecommitdiff
path: root/dev-util/wabt/wabt-1.0.24.ebuild
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-08-30 08:48:08 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-08-30 08:48:08 -0400
commit2be4d7c08ce05665007274578a2378bd6b64afeb (patch)
tree61a32dc0e1600f13b1f334f440332641e9d95286 /dev-util/wabt/wabt-1.0.24.ebuild
parent25c3787bb9eb7655dbbf8052db714981a81323e1 (diff)
downloadgentoo-overlay-2be4d7c08ce05665007274578a2378bd6b64afeb.tar.xz
gentoo-overlay-2be4d7c08ce05665007274578a2378bd6b64afeb.zip
dev-util/wabt: bump
Diffstat (limited to 'dev-util/wabt/wabt-1.0.24.ebuild')
-rw-r--r--dev-util/wabt/wabt-1.0.24.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-util/wabt/wabt-1.0.24.ebuild b/dev-util/wabt/wabt-1.0.24.ebuild
new file mode 100644
index 0000000..506cdbd
--- /dev/null
+++ b/dev-util/wabt/wabt-1.0.24.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="The WebAssembly Binary Toolkit"
+HOMEPAGE="https://github.com/WebAssembly/wabt"
+SRC_URI="https://github.com/WebAssembly/wabt/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ test? ( dev-cpp/gtest )
+"
+RDEPEND=""
+BDEPEND="
+ test? ( dev-cpp/gtest )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTS=$(usex test)
+ -DUSE_SYSTEM_GTEST=ON
+ )
+ cmake_src_configure
+}