summaryrefslogtreecommitdiff
path: root/games-rpg/runescape-launcher/runescape-launcher-2.2.7.ebuild
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-07-28 09:41:37 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-07-28 09:41:37 -0400
commitd241ee7943383a8ad8aacd70d5e301a6acf22c38 (patch)
tree5aaddca6d5744a9e3565da0846cbda2e1a34be3b /games-rpg/runescape-launcher/runescape-launcher-2.2.7.ebuild
downloadgentoo-overlay-d241ee7943383a8ad8aacd70d5e301a6acf22c38.tar.xz
gentoo-overlay-d241ee7943383a8ad8aacd70d5e301a6acf22c38.zip
Initial commit
Diffstat (limited to 'games-rpg/runescape-launcher/runescape-launcher-2.2.7.ebuild')
-rw-r--r--games-rpg/runescape-launcher/runescape-launcher-2.2.7.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/games-rpg/runescape-launcher/runescape-launcher-2.2.7.ebuild b/games-rpg/runescape-launcher/runescape-launcher-2.2.7.ebuild
new file mode 100644
index 0000000..a071d10
--- /dev/null
+++ b/games-rpg/runescape-launcher/runescape-launcher-2.2.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit unpacker
+
+DESCRIPTION="Official RuneScape NXT client launcher"
+HOMEPAGE="http://www.runescape.com"
+SRC_URI="http://content.runescape.com/downloads/ubuntu/pool/non-free/${PN:0:1}/${PN}/${PN}_${PV}_amd64.deb"
+
+LICENSE="RuneScape-EULA"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+DEPEND=""
+RDEPEND="
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ sys-libs/libcap
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXxf86vm
+ dev-libs/openssl
+ x11-libs/pango
+ media-libs/libsdl2"
+BDEPEND=""
+
+RESTRICT="bindist mirror strip"
+QA_PREBUILT="/opt/runescape-launcher/runescape"
+
+S="${WORKDIR}"
+
+src_install() {
+ cp -r usr "${D}"
+}