summaryrefslogtreecommitdiff
path: root/gui-apps
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2023-06-10 14:11:31 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2023-06-10 14:12:18 -0400
commit04630dc3ebb0918a62c27c1dbc43f4c6e4801324 (patch)
tree11d4ac9a63ae820a9361efa0eb9697b290fdeeb2 /gui-apps
parente28343118efa0f52254b4ea4c0756c72ef9a6ea6 (diff)
downloadgentoo-overlay-04630dc3ebb0918a62c27c1dbc43f4c6e4801324.tar.xz
gentoo-overlay-04630dc3ebb0918a62c27c1dbc43f4c6e4801324.zip
gui-apps/wob: new package
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/wob/Manifest1
-rw-r--r--gui-apps/wob/metadata.xml18
-rw-r--r--gui-apps/wob/wob-0.14.2.ebuild34
3 files changed, 53 insertions, 0 deletions
diff --git a/gui-apps/wob/Manifest b/gui-apps/wob/Manifest
new file mode 100644
index 0000000..aab291a
--- /dev/null
+++ b/gui-apps/wob/Manifest
@@ -0,0 +1 @@
+DIST wob-0.14.2.tar.gz 21848 BLAKE2B 10dffa9a168ae9b17ec3aed651029100c35050d65fc392dcd6775a321d1ced46b085376c8b74b789c6712577f380ec97d7141d44429acf1a2def2443b20ca3b5 SHA512 933d6bb0469f3b446f8998738ebe7045a1d707a814345961848a025e53cd9bd367cf138c8c6deafe8906c887e783bef85f669e9f107c51c51d357f087aaad6b8
diff --git a/gui-apps/wob/metadata.xml b/gui-apps/wob/metadata.xml
new file mode 100644
index 0000000..78784e3
--- /dev/null
+++ b/gui-apps/wob/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription lang="en">
+ A lightweight overlay volume/backlight/progress/anything bar
+ for wlroots based Wayland compositors (requrires support for
+ wlr_layer_shell_unstable_v1). This project is inspired by
+ xob - X Overlay Bar
+ </longdescription>
+ <upstream>
+ <remote-id type="github">francma/wob</remote-id>
+ <bugs-to>https://github.com/francma/wob/issues</bugs-to>
+ </upstream>
+ <use>
+ <flag name="man">Install man page</flag>
+ <flag name="seccomp">Linux kernel syscall filtering</flag>
+ </use>
+</pkgmetadata>
diff --git a/gui-apps/wob/wob-0.14.2.ebuild b/gui-apps/wob/wob-0.14.2.ebuild
new file mode 100644
index 0000000..bf8f34d
--- /dev/null
+++ b/gui-apps/wob/wob-0.14.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Lightweight overlay volume/backlight/progress/anything bar for Wayland"
+HOMEPAGE="https://github.com/francma/wob"
+SRC_URI="https://github.com/francma/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+man +seccomp"
+
+RDEPEND="dev-libs/wayland"
+DEPEND="${RDEPEND}
+ dev-libs/inih
+ dev-libs/wayland-protocols
+ seccomp? ( sys-libs/libseccomp )
+"
+BDEPEND="
+ dev-util/wayland-scanner
+ man? ( app-text/scdoc )
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature man man-pages)
+ $(meson_feature seccomp)
+ )
+ meson_src_configure
+}