summaryrefslogtreecommitdiff
path: root/gui-apps
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2023-08-19 20:50:37 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2023-08-19 20:50:53 -0400
commit87327437149e88062f9fd67fabe3461b09e35194 (patch)
tree020e048b316e9e0335f3c8c75e3f5cf58d9a21c3 /gui-apps
parentf89c30e88fe18f25fcf348ff72d0f209440deb7d (diff)
downloadgentoo-overlay-87327437149e88062f9fd67fabe3461b09e35194.tar.xz
gentoo-overlay-87327437149e88062f9fd67fabe3461b09e35194.zip
gui-apps/wlsunset: new package
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/wlsunset/Manifest1
-rw-r--r--gui-apps/wlsunset/metadata.xml7
-rw-r--r--gui-apps/wlsunset/wlsunset-0.3.0.ebuild38
3 files changed, 46 insertions, 0 deletions
diff --git a/gui-apps/wlsunset/Manifest b/gui-apps/wlsunset/Manifest
new file mode 100644
index 0000000..dc36999
--- /dev/null
+++ b/gui-apps/wlsunset/Manifest
@@ -0,0 +1 @@
+DIST wlsunset-0.3.0.tar.gz 16533 BLAKE2B 930635e82963d14fae9f95e2219574c962adbf32406bd184d35b79848dce2f2edaa526aaaf21c2dfdde9f4d4f9fe04011d592955867c3b01b5de4778ef9915f1 SHA512 0685989ec99d7066d5d1efacfbb4676d2df235d33d64cfe3d41c762ccc2ff5c292e03430414b43d719c35ddc0ad8267b765764c15afd1b3177ed1e0bb6f449c1
diff --git a/gui-apps/wlsunset/metadata.xml b/gui-apps/wlsunset/metadata.xml
new file mode 100644
index 0000000..ec5cc1f
--- /dev/null
+++ b/gui-apps/wlsunset/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="sourcehut">~kennylevinsen/wlsunset</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/gui-apps/wlsunset/wlsunset-0.3.0.ebuild b/gui-apps/wlsunset/wlsunset-0.3.0.ebuild
new file mode 100644
index 0000000..3a80af2
--- /dev/null
+++ b/gui-apps/wlsunset/wlsunset-0.3.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+if [[ "${PV}" == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.sr.ht/~kennylevinsen/wlsunset"
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://git.sr.ht/~kennylevinsen/wlsunset/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="Day/night gamma adjustments for Wayland"
+HOMEPAGE="https://sr.ht/~kennylevinsen/wlsunset/"
+LICENSE="MIT"
+SLOT="0"
+
+BDEPEND="
+ app-text/scdoc
+ dev-util/wayland-scanner
+"
+RDEPEND="dev-libs/wayland"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/wayland-protocols
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dwerror=false
+ -Dman-pages=enabled
+ )
+
+ meson_src_configure
+}