summaryrefslogtreecommitdiff
path: root/gui-wm/tinywl/tinywl-0.15.1.ebuild
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2022-06-19 09:16:52 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2022-06-19 09:16:52 -0400
commitfa5c71c1be0aab592461403f6af1f00c32b294c5 (patch)
treece0589ebbcb82b9371a9642db76c434431121d9d /gui-wm/tinywl/tinywl-0.15.1.ebuild
parentb311733f9f7fe956679b12c75c13173bd1ca4ff0 (diff)
downloadgentoo-overlay-fa5c71c1be0aab592461403f6af1f00c32b294c5.tar.xz
gentoo-overlay-fa5c71c1be0aab592461403f6af1f00c32b294c5.zip
gui-wm/tinywl: new package
used for virtualwl.eclass
Diffstat (limited to 'gui-wm/tinywl/tinywl-0.15.1.ebuild')
-rw-r--r--gui-wm/tinywl/tinywl-0.15.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/gui-wm/tinywl/tinywl-0.15.1.ebuild b/gui-wm/tinywl/tinywl-0.15.1.ebuild
new file mode 100644
index 0000000..c8ddb20
--- /dev/null
+++ b/gui-wm/tinywl/tinywl-0.15.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION='"minimum viable product" Wayland compositor based on wlroots'
+HOMEPAGE="https://gitlab.freedesktop.org/wlroots/wlroots/-/tree/tinywl"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/wlroots/wlroots.git"
+ inherit git-r3
+else
+ SRC_URI="https://gitlab.freedesktop.org/wlroots/wlroots/-/archive/${PV}/wlroots-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="CC0-1.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ >=gui-libs/wlroots-${PV}:=
+ dev-libs/wayland-protocols
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-libs/wayland-protocols
+ virtual/pkgconfig
+"
+
+S=${WORKDIR}/wlroots-${PV}
+
+PATCHES=(
+ "${FILESDIR}/tinywl-don-t-crash-when-there-is-no-keyboard.patch"
+)
+
+S="${WORKDIR}/wlroots-${PV}/tinywl"
+
+src_prepare() {
+ cd ..
+ default
+}
+
+src_install() {
+ dobin tinywl
+}