summaryrefslogtreecommitdiff
path: root/media-fonts/noto/noto-20230117.ebuild
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2023-02-06 18:57:14 -0500
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2023-02-06 18:57:14 -0500
commit91db43b5bca6794e8e366fc37106f1befbc9b889 (patch)
tree9bf698cd4c749bf8c1e61cc38f447085eb2a4900 /media-fonts/noto/noto-20230117.ebuild
parentc7ecfcd062389c195df37f8deb58b1e466644fa1 (diff)
downloadgentoo-overlay-91db43b5bca6794e8e366fc37106f1befbc9b889.tar.xz
gentoo-overlay-91db43b5bca6794e8e366fc37106f1befbc9b889.zip
media-fonts/noto: upgrade to 20230117
Diffstat (limited to 'media-fonts/noto/noto-20230117.ebuild')
-rw-r--r--media-fonts/noto/noto-20230117.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-fonts/noto/noto-20230117.ebuild b/media-fonts/noto/noto-20230117.ebuild
new file mode 100644
index 0000000..d0503aa
--- /dev/null
+++ b/media-fonts/noto/noto-20230117.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Google's font family that aims to support all the world's languages"
+HOMEPAGE="https://www.google.com/get/noto/ https://github.com/googlefonts/noto-fonts"
+
+COMMIT="6bff404f9a23cd603190277422d043a0afd7908e"
+SRC_URI="
+ https://github.com/notofonts/notofonts.github.io/raw/${COMMIT}/fonts/NotoSans/googlefonts/variable-ttf/NotoSans%5Bwdth%2Cwght%5D.ttf -> NotoSans[wdth,wght]-${COMMIT}.ttf
+ https://github.com/notofonts/notofonts.github.io/raw/${COMMIT}/fonts/NotoSans/googlefonts/variable-ttf/NotoSans-Italic%5Bwdth%2Cwght%5D.ttf -> NotoSans-Italic[wdth,wght]-${COMMIT}.ttf
+ https://github.com/notofonts/notofonts.github.io/raw/${COMMIT}/fonts/NotoSerif/googlefonts/variable-ttf/NotoSerif%5Bwdth%2Cwght%5D.ttf -> NotoSerif[wdth,wght]-${COMMIT}.ttf
+ https://github.com/notofonts/notofonts.github.io/raw/${COMMIT}/fonts/NotoSerif/googlefonts/variable-ttf/NotoSerif-Italic%5Bwdth%2Cwght%5D.ttf -> NotoSerif-Italic[wdth,wght]-${COMMIT}.ttf
+ "
+
+LICENSE="OFL-1.1"
+SLOT="0"
+KEYWORDS="~*"
+IUSE=""
+
+S="${DISTDIR}"
+
+src_install() {
+ insinto /usr/share/fonts/${PN}
+ newins "NotoSans[wdth,wght]-${COMMIT}.ttf" "NotoSans[wdth,wght].ttf"
+ newins "NotoSans-Italic[wdth,wght]-${COMMIT}.ttf" "NotoSans-Italic[wdth,wght].ttf"
+ newins "NotoSerif[wdth,wght]-${COMMIT}.ttf" "NotoSerif[wdth,wght].ttf"
+ newins "NotoSerif-Italic[wdth,wght]-${COMMIT}.ttf" "NotoSerif-Italic[wdth,wght].ttf"
+ insinto /etc/fonts/conf.avail
+ # From ArchLinux
+ doins "${FILESDIR}/66-noto-serif.conf"
+ doins "${FILESDIR}/66-noto-mono.conf"
+ doins "${FILESDIR}/66-noto-sans.conf"
+}