summaryrefslogtreecommitdiff
path: root/media-libs/svt-av1/svt-av1-9999.ebuild
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-08-14 21:43:27 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-08-14 21:43:27 -0400
commit8ba106d6a024d569d78d9c3fadaa805ba43f3374 (patch)
tree0ece5d5ab7719ad1c7906056341f413d5bca203c /media-libs/svt-av1/svt-av1-9999.ebuild
parent37ca729b962667de1764eebcef181aa3928fd39e (diff)
downloadgentoo-overlay-8ba106d6a024d569d78d9c3fadaa805ba43f3374.tar.xz
gentoo-overlay-8ba106d6a024d569d78d9c3fadaa805ba43f3374.zip
media-libs/svt-av1: import
Diffstat (limited to 'media-libs/svt-av1/svt-av1-9999.ebuild')
-rw-r--r--media-libs/svt-av1/svt-av1-9999.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-libs/svt-av1/svt-av1-9999.ebuild b/media-libs/svt-av1/svt-av1-9999.ebuild
new file mode 100644
index 0000000..dbdcc33
--- /dev/null
+++ b/media-libs/svt-av1/svt-av1-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+inherit flag-o-matic cmake-multilib
+
+DESCRIPTION="Scalable Video Technology for AV1 (SVT-AV1 Encoder and Decoder)"
+HOMEPAGE="https://github.com/AOMediaCodec/SVT-AV1"
+
+if [[ ${PV} = 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/AOMediaCodec/SVT-AV1.git"
+else
+ SRC_URI="https://github.com/AOMediaCodec/SVT-AV1/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 -x86" # -x86: https://github.com/AOMediaCodec/SVT-AV1/issues/1231
+ S="${WORKDIR}/SVT-AV1-${PV}"
+fi
+
+# Also see "Alliance for Open Media Patent License 1.0"
+LICENSE="BSD-2 Apache-2.0 BSD ISC LGPL-2.1+ MIT"
+SLOT="0"
+
+DEPEND="amd64? ( dev-lang/yasm )"
+
+multilib_src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ local mycmakeargs=(
+ # Tests require linking against https://github.com/Cidana-Developers/aom/tree/av1-normative ?
+ # undefined reference to `ifd_inspect'
+ # https://github.com/Cidana-Developers/aom/commit/cfc5c9e95bcb48a5a41ca7908b44df34ea1313c0
+ -DBUILD_TESTING=OFF
+ )
+
+ cmake_src_configure
+}