summaryrefslogtreecommitdiff
path: root/media-libs/x265/files/tests.patch
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-07-29 15:09:41 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-07-29 15:09:53 -0400
commit2d93f2a120a24a93d0e6fe773a4c50b22a7be8bd (patch)
tree72e9ab1978c5fb0b5b37e51639cc565bb8846ba0 /media-libs/x265/files/tests.patch
parent7aab4631173a71d3978bfecb140786751e61f12c (diff)
downloadgentoo-overlay-2d93f2a120a24a93d0e6fe773a4c50b22a7be8bd.tar.xz
gentoo-overlay-2d93f2a120a24a93d0e6fe773a4c50b22a7be8bd.zip
media-libs/x265: add
Diffstat (limited to 'media-libs/x265/files/tests.patch')
-rw-r--r--media-libs/x265/files/tests.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/media-libs/x265/files/tests.patch b/media-libs/x265/files/tests.patch
new file mode 100644
index 0000000..6c85829
--- /dev/null
+++ b/media-libs/x265/files/tests.patch
@@ -0,0 +1,16 @@
+Tests run against static library (upstream build system):
+We build main as both shared & static, main10 & 12 are static only and linked into main.
+All need PLATFORM_LIBS, so instruct cmake to also link them.
+
+Index: source/CMakeLists.txt
+===================================================================
+--- source.orig/CMakeLists.txt
++++ source/CMakeLists.txt
+@@ -578,6 +578,7 @@ endif()
+ if(SVTHEVC_FOUND)
+ target_link_libraries(x265-static ${SVT_HEVC_LIBRARY})
+ endif()
++target_link_libraries(x265-static ${PLATFORM_LIBS})
+ install(TARGETS x265-static
+ LIBRARY DESTINATION ${LIB_INSTALL_DIR}
+ ARCHIVE DESTINATION ${LIB_INSTALL_DIR})