summaryrefslogtreecommitdiff
path: root/media-sound/qjackctl/qjackctl-0.6.2.ebuild
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-07-28 09:54:54 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-07-28 09:54:54 -0400
commit734427ad69fcf920f861ebfe4b1141c89496317b (patch)
treed49fd81a147f543237569152cae03aedb0dfa534 /media-sound/qjackctl/qjackctl-0.6.2.ebuild
parentd241ee7943383a8ad8aacd70d5e301a6acf22c38 (diff)
downloadgentoo-overlay-734427ad69fcf920f861ebfe4b1141c89496317b.tar.xz
gentoo-overlay-734427ad69fcf920f861ebfe4b1141c89496317b.zip
import more packages
Diffstat (limited to 'media-sound/qjackctl/qjackctl-0.6.2.ebuild')
-rw-r--r--media-sound/qjackctl/qjackctl-0.6.2.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/media-sound/qjackctl/qjackctl-0.6.2.ebuild b/media-sound/qjackctl/qjackctl-0.6.2.ebuild
new file mode 100644
index 0000000..8fef3fa
--- /dev/null
+++ b/media-sound/qjackctl/qjackctl-0.6.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic qmake-utils xdg-utils
+
+DESCRIPTION="Qt GUI to control the JACK Audio Connection Kit and ALSA sequencer connections"
+HOMEPAGE="https://qjackctl.sourceforge.io/"
+SRC_URI="mirror://sourceforge/qjackctl/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="alsa dbus debug portaudio"
+
+BDEPEND="dev-qt/linguist-tools:5"
+RDEPEND="
+ app-arch/gzip
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ virtual/jack
+ alsa? ( media-libs/alsa-lib )
+ dbus? ( dev-qt/qtdbus:5 )
+ portaudio? ( media-libs/portaudio )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ append-cxxflags -std=c++11
+ local myeconfargs=(
+ $(use_enable alsa alsa-seq)
+ $(use_enable dbus)
+ $(use_enable debug)
+ $(use_enable portaudio)
+ --enable-jack-version
+ )
+ econf "${myeconfargs[@]}"
+ eqmake5 ${PN}.pro -o ${PN}.mak
+}
+
+src_compile() {
+ emake -f ${PN}.mak
+}
+
+src_install() {
+ default
+
+ gunzip "${D}/usr/share/man/man1/qjackctl.fr.1.gz" || die
+ gunzip "${D}/usr/share/man/man1/qjackctl.1.gz" || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}