summaryrefslogtreecommitdiff
path: root/media-sound/qjackctl/qjackctl-0.6.2.ebuild
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-08-21 08:58:59 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-08-21 08:58:59 -0400
commite3ec57733d297c0c48bf6fd142e9928965e02706 (patch)
tree4d452579e51926ad922058db2bed5563678011dd /media-sound/qjackctl/qjackctl-0.6.2.ebuild
parente386003636dd08be2c8f9868942580f6c0172843 (diff)
downloadgentoo-overlay-e3ec57733d297c0c48bf6fd142e9928965e02706.tar.xz
gentoo-overlay-e3ec57733d297c0c48bf6fd142e9928965e02706.zip
media-sound/qjackctl: sync
Diffstat (limited to 'media-sound/qjackctl/qjackctl-0.6.2.ebuild')
-rw-r--r--media-sound/qjackctl/qjackctl-0.6.2.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/media-sound/qjackctl/qjackctl-0.6.2.ebuild b/media-sound/qjackctl/qjackctl-0.6.2.ebuild
deleted file mode 100644
index 8fef3fa..0000000
--- a/media-sound/qjackctl/qjackctl-0.6.2.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic qmake-utils xdg-utils
-
-DESCRIPTION="Qt GUI to control the JACK Audio Connection Kit and ALSA sequencer connections"
-HOMEPAGE="https://qjackctl.sourceforge.io/"
-SRC_URI="mirror://sourceforge/qjackctl/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="alsa dbus debug portaudio"
-
-BDEPEND="dev-qt/linguist-tools:5"
-RDEPEND="
- app-arch/gzip
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
- dev-qt/qtxml:5
- virtual/jack
- alsa? ( media-libs/alsa-lib )
- dbus? ( dev-qt/qtdbus:5 )
- portaudio? ( media-libs/portaudio )"
-DEPEND="${RDEPEND}"
-
-src_configure() {
- append-cxxflags -std=c++11
- local myeconfargs=(
- $(use_enable alsa alsa-seq)
- $(use_enable dbus)
- $(use_enable debug)
- $(use_enable portaudio)
- --enable-jack-version
- )
- econf "${myeconfargs[@]}"
- eqmake5 ${PN}.pro -o ${PN}.mak
-}
-
-src_compile() {
- emake -f ${PN}.mak
-}
-
-src_install() {
- default
-
- gunzip "${D}/usr/share/man/man1/qjackctl.fr.1.gz" || die
- gunzip "${D}/usr/share/man/man1/qjackctl.1.gz" || die
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}