summaryrefslogtreecommitdiff
path: root/media-sound
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2022-01-23 09:44:28 -0500
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2022-01-23 09:44:28 -0500
commit6fd75cd341bffe75993432f74b7fd79348742213 (patch)
tree89e2be062cbde91d3512084d502d96fdcb8af319 /media-sound
parent455a0bfe3059771f42e19c8a617a506fde4a5616 (diff)
downloadgentoo-overlay-6fd75cd341bffe75993432f74b7fd79348742213.tar.xz
gentoo-overlay-6fd75cd341bffe75993432f74b7fd79348742213.zip
media-sound/pamixer: new package
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/pamixer/Manifest1
-rw-r--r--media-sound/pamixer/pamixer-1.4.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/media-sound/pamixer/Manifest b/media-sound/pamixer/Manifest
new file mode 100644
index 0000000..996e474
--- /dev/null
+++ b/media-sound/pamixer/Manifest
@@ -0,0 +1 @@
+DIST pamixer-1.4.tar.gz 17614 BLAKE2B afd8b26d987d85c043e88870805b5504ff1f7fb96583b8002dfe106ba4d9a25cf429d7ff81d4ab8a2c75501d5926136089b68fe919c997dd3bb6d4662957c66b SHA512 e3916ed8dc020bb43e57994a9f35a506147a0fde42b88c30c661cbeffa40e0f74cae66cd015394e524684c32f9674de3e3763a1396a3e1b9aecbfdc3ed117fe4
diff --git a/media-sound/pamixer/pamixer-1.4.ebuild b/media-sound/pamixer/pamixer-1.4.ebuild
new file mode 100644
index 0000000..a9205dd
--- /dev/null
+++ b/media-sound/pamixer/pamixer-1.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Pulseaudio command line mixer."
+HOMEPAGE="https://github.com/cdemoulins/pamixer"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/cdemoulins/pamixer"
+else
+ SRC_URI="https://github.com/cdemoulins/pamixer/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="
+ dev-libs/boost
+ media-sound/pulseaudio"
+
+DEPEND="${RDEPEND}"
+
+src_install() {
+ dobin ${PN}
+ dodoc README.rst
+}