summaryrefslogtreecommitdiff
path: root/net-mail
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-11-05 11:48:09 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-11-05 11:48:09 -0400
commit3fd7aa8e4660ec8338891e653d2ebccebfe149c4 (patch)
tree8df0faf2af6f62837120d28843bda6f5dac002f3 /net-mail
parentcd86b59649df944ea7a52dce9e5080a749c5d464 (diff)
downloadgentoo-overlay-3fd7aa8e4660ec8338891e653d2ebccebfe149c4.tar.xz
gentoo-overlay-3fd7aa8e4660ec8338891e653d2ebccebfe149c4.zip
net-mail/notmuch: add
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/notmuch/Manifest2
-rw-r--r--net-mail/notmuch/files/50notmuch-gentoo.el7
-rw-r--r--net-mail/notmuch/files/notmuch-assume-modern-gmime.patch222
-rw-r--r--net-mail/notmuch/metadata.xml23
-rw-r--r--net-mail/notmuch/notmuch-0.34-r1.ebuild307
5 files changed, 561 insertions, 0 deletions
diff --git a/net-mail/notmuch/Manifest b/net-mail/notmuch/Manifest
new file mode 100644
index 0000000..777fdcf
--- /dev/null
+++ b/net-mail/notmuch/Manifest
@@ -0,0 +1,2 @@
+DIST database-v1.tar.xz 204876 BLAKE2B 846a8d2f17edb61ed1c3d3c655becd1f60b4046772058706f13d516f65421a5105593660f1c556907bb2bb9607a3c2521243d1be07bffb70817ad3b8461680ca SHA512 e2d87373e00b65756d7fea40c54fb236d7a37ce839145c3afd99ab26efdc17796e540c021e2c24e521df2d0a01ccbf918994f87a0d83235ff9b109a51555b3d0
+DIST notmuch-0.34.tar.xz 748232 BLAKE2B 161fc1bd047b5489a4f2fd64f4843e73fd82cf6a408ef04ab1bab34df0995fd4199585cf8fa12980a4fdab054d03437323ed366ca87f2f6dad2d006900cad352 SHA512 c7c802ee6fc056cb626611e3403541e404c628d238983299faf877e7eca9dfb94bd643c399e6a6cda53b051d2ad837ad03b124a1f44e17c7637a9c9b23e33c73
diff --git a/net-mail/notmuch/files/50notmuch-gentoo.el b/net-mail/notmuch/files/50notmuch-gentoo.el
new file mode 100644
index 0000000..95e0624
--- /dev/null
+++ b/net-mail/notmuch/files/50notmuch-gentoo.el
@@ -0,0 +1,7 @@
+(add-to-list 'load-path "@SITELISP@")
+(if (boundp 'image-load-path)
+ (add-to-list 'image-load-path "@SITEETC@" t))
+(autoload 'notmuch "notmuch" nil t)
+(autoload 'notmuch-search "notmuch" nil t)
+(autoload 'notmuch-hello "notmuch-hello" nil t)
+(autoload 'notmuch-show "notmuch-show" nil t)
diff --git a/net-mail/notmuch/files/notmuch-assume-modern-gmime.patch b/net-mail/notmuch/files/notmuch-assume-modern-gmime.patch
new file mode 100644
index 0000000..6e3c8d3
--- /dev/null
+++ b/net-mail/notmuch/files/notmuch-assume-modern-gmime.patch
@@ -0,0 +1,222 @@
+diff --git a/configure b/configure
+index 6c3a38f1..39d1f8c6 100755
+--- a/configure
++++ b/configure
+@@ -464,215 +464,8 @@ if pkg-config --exists "gmime-3.0 >= $GMIME_MINVER"; then
+ gmime_cflags=$(pkg-config --cflags gmime-3.0)
+ gmime_ldflags=$(pkg-config --libs gmime-3.0)
+
+- printf "Checking for GMime session key extraction support... "
+-
+- cat > _check_session_keys.c <<EOF
+-#include <gmime/gmime.h>
+-#include <stdio.h>
+-
+-int main () {
+- GError *error = NULL;
+- GMimeParser *parser = NULL;
+- GMimeMultipartEncrypted *body = NULL;
+- GMimeDecryptResult *decrypt_result = NULL;
+- GMimeObject *output = NULL;
+-
+- g_mime_init ();
+- parser = g_mime_parser_new ();
+- g_mime_parser_init_with_stream (parser, g_mime_stream_file_open("$srcdir/test/corpora/crypto/basic-encrypted.eml", "r", &error));
+- if (error) return !! fprintf (stderr, "failed to instantiate parser with test/corpora/crypto/basic-encrypted.eml\n");
+-
+- body = GMIME_MULTIPART_ENCRYPTED(g_mime_message_get_mime_part (g_mime_parser_construct_message (parser, NULL)));
+- if (body == NULL) return !! fprintf (stderr, "did not find a multipart encrypted message\n");
+-
+- output = g_mime_multipart_encrypted_decrypt (body, GMIME_DECRYPT_EXPORT_SESSION_KEY, NULL, &decrypt_result, &error);
+- if (error || output == NULL) return !! fprintf (stderr, "decryption failed\n");
+-
+- if (decrypt_result == NULL) return !! fprintf (stderr, "no GMimeDecryptResult found\n");
+- if (decrypt_result->session_key == NULL) return !! fprintf (stderr, "GMimeDecryptResult has no session key\n");
+-
+- printf ("%s\n", decrypt_result->session_key);
+- return 0;
+-}
+-EOF
+- if ! TEMP_GPG=$(mktemp -d "${TMPDIR:-/tmp}/notmuch.XXXXXX"); then
+- printf 'No.\nCould not make tempdir for testing session-key support.\n'
+- errors=$((errors + 1))
+- elif ${CC} ${CFLAGS} ${gmime_cflags} _check_session_keys.c ${gmime_ldflags} -o _check_session_keys \
+- && GNUPGHOME=${TEMP_GPG} gpg --batch --quiet --import < "$srcdir"/test/gnupg-secret-key.asc \
+- && SESSION_KEY=$(GNUPGHOME=${TEMP_GPG} ./_check_session_keys) \
+- && [ $SESSION_KEY = 9:0BACD64099D1468AB07C796F0C0AC4851948A658A15B34E803865E9FC635F2F5 ]
+- then
+- printf "OK.\n"
+- else
+- cat <<EOF
+-No.
+-*** Error: Could not extract session keys from encrypted message.
+-
+-This is likely due to your GMime having been built against a old
+-version of GPGME.
+-
+-Please try to rebuild your version of GMime against a more recent
+-version of GPGME (at least GPGME 1.8.0).
+-EOF
+- if command -v gpgme-config >/dev/null; then
+- printf 'Your current GPGME development version is: %s\n' "$(gpgme-config --version)"
+- else
+- printf 'You do not have the GPGME development libraries installed.\n'
+- fi
+- errors=$((errors + 1))
+- fi
+- if [ -n "$TEMP_GPG" -a -d "$TEMP_GPG" ]; then
+- rm -rf "$TEMP_GPG"
+- fi
+-
+- # see https://github.com/jstedfast/gmime/pull/90
+- # should be fixed in GMime in 3.2.7, but some distros might patch
+- printf "Checking for GMime X.509 certificate validity... "
+-
+- cat > _check_x509_validity.c <<EOF
+-#include <stdio.h>
+-#include <gmime/gmime.h>
+-
+-int main () {
+- GError *error = NULL;
+- GMimeParser *parser = NULL;
+- GMimeApplicationPkcs7Mime *body = NULL;
+- GMimeSignatureList *sig_list = NULL;
+- GMimeSignature *sig = NULL;
+- GMimeCertificate *cert = NULL;
+- GMimeObject *output = NULL;
+- GMimeValidity validity = GMIME_VALIDITY_UNKNOWN;
+- int len;
+-
+- g_mime_init ();
+- parser = g_mime_parser_new ();
+- g_mime_parser_init_with_stream (parser, g_mime_stream_file_open("$srcdir/test/corpora/pkcs7/smime-onepart-signed.eml", "r", &error));
+- if (error) return !! fprintf (stderr, "failed to instantiate parser with test/corpora/pkcs7/smime-onepart-signed.eml\n");
+-
+- body = GMIME_APPLICATION_PKCS7_MIME(g_mime_message_get_mime_part (g_mime_parser_construct_message (parser, NULL)));
+- if (body == NULL) return !! fprintf (stderr, "did not find a application/pkcs7 message\n");
+-
+- sig_list = g_mime_application_pkcs7_mime_verify (body, GMIME_VERIFY_NONE, &output, &error);
+- if (error || output == NULL) return !! fprintf (stderr, "verify failed\n");
+-
+- if (sig_list == NULL) return !! fprintf (stderr, "no GMimeSignatureList found\n");
+- len = g_mime_signature_list_length (sig_list);
+- if (len != 1) return !! fprintf (stderr, "expected 1 signature, got %d\n", len);
+- sig = g_mime_signature_list_get_signature (sig_list, 0);
+- if (sig == NULL) return !! fprintf (stderr, "no GMimeSignature found at position 0\n");
+- cert = g_mime_signature_get_certificate (sig);
+- if (cert == NULL) return !! fprintf (stderr, "no GMimeCertificate found\n");
+- validity = g_mime_certificate_get_id_validity (cert);
+- if (validity != GMIME_VALIDITY_FULL) return !! fprintf (stderr, "Got validity %d, expected %d\n", validity, GMIME_VALIDITY_FULL);
+-
+- return 0;
+-}
+-EOF
+- if ! TEMP_GPG=$(mktemp -d "${TMPDIR:-/tmp}/notmuch.XXXXXX"); then
+- printf 'No.\nCould not make tempdir for testing X.509 certificate validity support.\n'
+- errors=$((errors + 1))
+- elif ${CC} ${CFLAGS} ${gmime_cflags} _check_x509_validity.c ${gmime_ldflags} -o _check_x509_validity \
+- && echo disable-crl-checks > "$TEMP_GPG/gpgsm.conf" \
+- && echo "4D:E0:FF:63:C0:E9:EC:01:29:11:C8:7A:EE:DA:3A:9A:7F:6E:C1:0D S" >> "$TEMP_GPG/trustlist.txt" \
+- && GNUPGHOME=${TEMP_GPG} gpgsm --batch --quiet --import < "$srcdir"/test/smime/ca.crt
+- then
+- if GNUPGHOME=${TEMP_GPG} ./_check_x509_validity; then
+- gmime_x509_cert_validity=1
+- printf "Yes.\n"
+- else
+- gmime_x509_cert_validity=0
+- printf "No.\n"
+- if pkg-config --exists "gmime-3.0 >= 3.2.7"; then
+- cat <<EOF
+-*** Error: GMime fails to calculate X.509 certificate validity, and
+-is later than 3.2.7, which should have fixed this issue.
+-
+-Please follow up on https://github.com/jstedfast/gmime/pull/90 with
+-more details.
+-EOF
+- errors=$((errors + 1))
+- fi
+- fi
+- else
+- printf 'No.\nFailed to set up gpgsm for testing X.509 certificate validity support.\n'
+- errors=$((errors + 1))
+- fi
+- if [ -n "$TEMP_GPG" -a -d "$TEMP_GPG" ]; then
+- rm -rf "$TEMP_GPG"
+- fi
+-
+- # see https://dev.gnupg.org/T3464
+- # there are problems verifying signatures when decrypting with session keys with GPGME 1.13.0 and 1.13.1
+- printf "Checking signature verification when decrypting using session keys... "
+-
+- cat > _verify_sig_with_session_key.c <<EOF
+-#include <stdio.h>
+-#include <gmime/gmime.h>
+-
+-int main () {
+- GError *error = NULL;
+- GMimeParser *parser = NULL;
+- GMimeMultipartEncrypted *body = NULL;
+- GMimeDecryptResult *result = NULL;
+- GMimeSignatureList *sig_list = NULL;
+- GMimeSignature *sig = NULL;
+- GMimeObject *output = NULL;
+- GMimeSignatureStatus status;
+- int len;
+-
+- g_mime_init ();
+- parser = g_mime_parser_new ();
+- g_mime_parser_init_with_stream (parser, g_mime_stream_file_open("$srcdir/test/corpora/crypto/encrypted-signed.eml", "r", &error));
+- if (error) return !! fprintf (stderr, "failed to instantiate parser with test/corpora/pkcs7/smime-onepart-signed.eml\n");
+-
+- body = GMIME_MULTIPART_ENCRYPTED(g_mime_message_get_mime_part (g_mime_parser_construct_message (parser, NULL)));
+- if (body == NULL) return !! fprintf (stderr, "did not find a multipart/encrypted message\n");
+-
+- output = g_mime_multipart_encrypted_decrypt (body, GMIME_DECRYPT_NONE, "9:13607E4217515A70EC8DF9DBC16C5327B94577561D98AD1246FA8756659C7899", &result, &error);
+- if (error || output == NULL) return !! fprintf (stderr, "decrypt failed\n");
+-
+- sig_list = g_mime_decrypt_result_get_signatures (result);
+- if (sig_list == NULL) return !! fprintf (stderr, "sig_list is NULL\n");
+-
+- if (sig_list == NULL) return !! fprintf (stderr, "no GMimeSignatureList found\n");
+- len = g_mime_signature_list_length (sig_list);
+- if (len != 1) return !! fprintf (stderr, "expected 1 signature, got %d\n", len);
+- sig = g_mime_signature_list_get_signature (sig_list, 0);
+- if (sig == NULL) return !! fprintf (stderr, "no GMimeSignature found at position 0\n");
+- status = g_mime_signature_get_status (sig);
+- if (status & GMIME_SIGNATURE_STATUS_KEY_MISSING) return !! fprintf (stderr, "signature status contains KEY_MISSING (see https://dev.gnupg.org/T3464)\n");
+-
+- return 0;
+-}
+-EOF
+- if ! TEMP_GPG=$(mktemp -d "${TMPDIR:-/tmp}/notmuch.XXXXXX"); then
+- printf 'No.\nCould not make tempdir for testing signature verification when decrypting with session keys.\n'
+- errors=$((errors + 1))
+- elif ${CC} ${CFLAGS} ${gmime_cflags} _verify_sig_with_session_key.c ${gmime_ldflags} -o _verify_sig_with_session_key \
+- && GNUPGHOME=${TEMP_GPG} gpg --batch --quiet --import < "$srcdir"/test/gnupg-secret-key.asc \
+- && rm -f ${TEMP_GPG}/private-keys-v1.d/*.key
+- then
+- if GNUPGHOME=${TEMP_GPG} ./_verify_sig_with_session_key; then
+- gmime_verify_with_session_key=1
+- printf "Yes.\n"
+- else
+- gmime_verify_with_session_key=0
+- printf "No.\n"
+- cat <<EOF
+-*** Error: GMime fails to verify signatures when decrypting with a session key.
+-
+-This is most likely due to a buggy version of GPGME, which should be fixed in 1.13.2 or later.
+-See https://dev.gnupg.org/T3464 for more details.
+-EOF
+- fi
+- else
+- printf 'No.\nFailed to set up gpg for testing signature verification while decrypting with a session key.\n'
+- errors=$((errors + 1))
+- fi
+- if [ -n "$TEMP_GPG" -a -d "$TEMP_GPG" ]; then
+- rm -rf "$TEMP_GPG"
+- fi
++ gmime_x509_cert_validity=1
++ gmime_verify_with_session_key=1
+ else
+ have_gmime=0
+ printf "No.\n"
diff --git a/net-mail/notmuch/metadata.xml b/net-mail/notmuch/metadata.xml
new file mode 100644
index 0000000..e186496
--- /dev/null
+++ b/net-mail/notmuch/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <use>
+ <flag name="apidoc">Provide doxygen generated API docs</flag>
+ <flag name="doc">Install API documentation</flag>
+ <flag name="crypt">Support decryption and verification of PGP/MIME
+ messages and in Emacs UI - encryption; support also S/MIME
+ signature verification since version 0.22</flag>
+ <flag name="emacs">Install Emacs UI (the main one)</flag>
+ <flag name="mutt">Install helper script for Mutt</flag>
+ <flag name="nmbug">Install experimental tag sharing /
+ pseudo-bug-tracking script for Notmuch
+ (see http://notmuchmail.org/nmbug/)</flag>
+ <flag name="valgrind">Depend on dev-util/valgrind for test suite</flag>
+ </use>
+ <longdescription lang="en">
+ Notmuch is a system for indexing, searching, reading, and tagging large
+ collections of email messages in maildir or mh format. It uses the
+ Xapian library to provide fast, full-text search with a convenient
+ search syntax.
+ </longdescription>
+</pkgmetadata>
diff --git a/net-mail/notmuch/notmuch-0.34-r1.ebuild b/net-mail/notmuch/notmuch-0.34-r1.ebuild
new file mode 100644
index 0000000..ec0bf11
--- /dev/null
+++ b/net-mail/notmuch/notmuch-0.34-r1.ebuild
@@ -0,0 +1,307 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_OPTIONAL=1
+DISTUTILS_USE_SETUPTOOLS=manual
+NEED_EMACS="24.1"
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
+
+inherit bash-completion-r1 desktop distutils-r1 elisp-common flag-o-matic pax-utils toolchain-funcs xdg-utils
+
+DESCRIPTION="Thread-based e-mail indexer, supporting quick search and tagging"
+HOMEPAGE="https://notmuchmail.org/"
+SRC_URI="https://notmuchmail.org/releases/${P}.tar.xz
+ test? ( https://notmuchmail.org/releases/test-databases/database-v1.tar.xz )"
+
+LICENSE="GPL-3"
+# Sub-slot corresponds to major wersion of libnotmuch.so.X.Y. Bump of Y is
+# meant to be binary backward compatible.
+SLOT="0/5"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
+REQUIRED_USE="
+ apidoc? ( doc )
+ nmbug? ( python )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ test? ( crypt emacs python valgrind )
+"
+IUSE="apidoc crypt doc emacs mutt nmbug python test valgrind"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ app-arch/xz-utils[extra-filters(-)]
+ virtual/pkgconfig
+ apidoc? (
+ app-doc/doxygen
+ dev-lang/perl
+ )
+ doc? (
+ dev-python/sphinx
+ sys-apps/texinfo
+ )
+ python? (
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+ )
+ test? (
+ app-shells/bash
+ sys-process/parallel
+ )
+"
+
+COMMON_DEPEND="
+ dev-libs/glib
+ dev-libs/gmime:3.0[crypt?]
+ >=dev-libs/xapian-1.4.0:=
+ sys-libs/talloc
+ sys-libs/zlib:=
+ emacs? ( >=app-editors/emacs-${NEED_EMACS}:* )
+ python? (
+ ${PYTHON_DEPS}
+ virtual/python-cffi[${PYTHON_USEDEP}]
+ )
+"
+
+DEPEND="${COMMON_DEPEND}
+ test? (
+ >=app-editors/emacs-${NEED_EMACS}:*[libxml2]
+ app-misc/dtach
+ sys-devel/gdb[python]
+ crypt? (
+ app-crypt/gnupg
+ dev-libs/openssl
+ )
+ )
+ valgrind? ( dev-util/valgrind )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ crypt? ( app-crypt/gnupg )
+ mutt? (
+ dev-perl/File-Which
+ dev-perl/Mail-Box
+ dev-perl/MailTools
+ dev-perl/String-ShellQuote
+ dev-perl/Term-ReadLine-Gnu
+ virtual/perl-Digest-SHA
+ virtual/perl-File-Path
+ virtual/perl-Getopt-Long
+ dev-perl/Pod-Parser
+ )
+ nmbug? ( dev-vcs/git )
+"
+
+SITEFILE="50${PN}-gentoo.el"
+
+PATCHES=(
+ "${FILESDIR}/notmuch-assume-modern-gmime.patch"
+)
+
+pkg_setup() {
+ use emacs && elisp-check-emacs-version
+}
+
+src_unpack() {
+ unpack "${P}".tar.xz
+ if use test; then
+ mkdir -p "${S}"/test/test-databases || die
+ cp "${DISTDIR}"/database-v1.tar.xz "${S}"/test/test-databases/ || die
+ fi
+}
+
+src_prepare() {
+ default
+
+ use python && distutils-r1_src_prepare
+
+ mv contrib/notmuch-mutt/README contrib/notmuch-mutt/README-mutt || die
+
+ # Override 'install' target, we want to install manpages with doman, but let it install texinfo files.
+ sed -i "s/all install-man install-info/all $(usex doc install-info '')/" "Makefile.local" || die
+
+ use test && append-flags '-g'
+
+ # Non-autoconf configure
+ [[ ${CHOST} == *-solaris* ]] && append-ldflags '-lnsl' '-lsocket'
+
+ # sphinx-4 broke everything. https://bugs.gentoo.org/789492
+ echo 'man_make_section_directory = False' >> doc/conf.py || die
+}
+
+src_configure() {
+ python_setup # For sphinx
+
+ tc-export CC CXX
+
+ local myconf=(
+ --bashcompletiondir="$(get_bashcompdir)"
+ --emacslispdir="${EPREFIX}/${SITELISP}/${PN}"
+ --emacsetcdir="${EPREFIX}/${SITEETC}/${PN}"
+ --without-desktop
+ --without-ruby
+ --zshcompletiondir="${EPREFIX}/usr/share/zsh/site-functions"
+ $(use_with apidoc api-docs)
+ $(use_with doc docs)
+ $(use_with emacs)
+ )
+
+ # FIXME:
+ # Checking for GMime session key extraction support... * ACCESS DENIED: open_wr: /dev/bus/usb/001/011
+ # notmuch configure compiles a program _check_session_keys.c, inline in ./configure script
+ # gmime/gpg/scdaemon tries to open usb devices in GMime test
+ # we pretend to allow it, without actually allowing it to read or write.
+ # https://bugs.gentoo.org/821328
+ addpredict /dev/bus/usb
+
+ econf "${myconf[@]}"
+}
+
+python_compile() {
+ pushd bindings/python-cffi > /dev/null || die
+ distutils-r1_python_compile
+ # copy stuff just in case
+ if use test; then
+ mkdir -p build/stage/tests || die
+ cp -v tests/*.py build/stage/tests || die
+ fi
+ popd > /dev/null || die
+
+ # TODO: we want to drop those, research revdeps
+ pushd bindings/python > /dev/null || die
+ distutils-r1_python_compile
+ popd > /dev/null || die
+}
+
+python_compile_all() {
+ use doc && emake -C bindings/python/docs html
+}
+
+src_compile() {
+ python_setup # For sphinx
+
+ # prevent race in emacs doc generation
+ # FileNotFoundError: [Errno 2] No such file or directory: '..work/notmuch-0.31/emacs/notmuch.rsti'
+ if use emacs; then
+ use doc && emake -j1 -C emacs docstring.stamp V=1 #nowarn
+ fi
+
+ emake V=1
+
+ use python && distutils-r1_src_compile
+
+ if use mutt; then
+ pushd contrib/notmuch-mutt > /dev/null || die
+ emake notmuch-mutt.1
+ popd > /dev/null || die
+ fi
+}
+
+python_test() {
+ # we only have tests for cffi bindings
+ pushd bindings/python-cffi > /dev/null || die
+ rm -f tox.ini || die
+ pytest -vv || die "Tests failed with ${EPYTHON}"
+ popd > /dev/null || die
+}
+
+src_test() {
+ local test_failures=()
+ pax-mark -m notmuch
+
+ # we run pytest via eclass phasefunc, so delete upstream launcher
+ use python && { rm -v test/T391-python-cffi.sh || die ; }
+
+ LD_LIBRARY_PATH="${S}/lib" \
+ nonfatal emake test V=1 OPTIONS="--verbose --tee" || test_failures+=( "'emake tests'" )
+ pax-mark -ze notmuch
+
+ # both lib and bin needed for testsuite.
+ if use python; then
+ LD_LIBRARY_PATH="${S}/lib" \
+ PATH="${S}:${PATH}" \
+ nonfatal distutils-r1_src_test || test_failures+=( "'python tests'" )
+ fi
+
+ [[ ${test_failures} ]] && die "Tests failed: ${test_failures[@]}"
+}
+
+python_install() {
+ pushd bindings/python-cffi > /dev/null || die
+ distutils-r1_python_install
+ popd > /dev/null || die
+
+ pushd bindings/python > /dev/null || die
+ distutils-r1_python_install
+ popd > /dev/null || die
+}
+
+src_install() {
+ default
+
+ if use doc; then
+ pushd doc/_build/man/man1 > /dev/null || die
+ ln notmuch.1 notmuch-setup.1 || die
+ popd > /dev/null || die
+ if use apidoc; then
+ # rename overly generic manpage to avoid clashes
+ mv doc/_build/man/man3/deprecated.3 \
+ doc/_build/man/man3/notmuch-deprecated.3 || die
+ fi
+ doman doc/_build/man/man?/*.?
+ fi
+
+ if use emacs; then
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ domenu emacs/notmuch-emacs-mua.desktop
+ fi
+
+ if use nmbug; then
+ # TODO: those guys need proper deps
+ python_fix_shebang devel/nmbug/{nmbug,notmuch-report}
+ dobin devel/nmbug/{nmbug,notmuch-report}
+ fi
+
+ if use mutt; then
+ pushd contrib/notmuch-mutt > /dev/null || die
+ dobin notmuch-mutt
+ # this manpage is built by pod2man
+ doman notmuch-mutt.1
+ insinto /etc/mutt
+ doins notmuch-mutt.rc
+ dodoc README-mutt
+ popd > /dev/null || die
+ fi
+
+ local DOCS=( README{,.rst} INSTALL NEWS )
+ einstalldocs
+
+ if use python; then
+ use doc && local HTML_DOCS=( bindings/python/docs/html/. )
+ distutils-r1_src_install
+ fi
+}
+
+pkg_preinst() {
+ local _rcfile="/etc/mutt/notmuch-mutt.rc"
+ if use mutt && ! [[ -e "${EROOT}"${_rcfile} ]]; then
+ elog "To enable notmuch support in mutt, add the following line"
+ elog "to your mutt config file:"
+ elog ""
+ elog " source ${_rcfile}"
+ fi
+}
+
+pkg_postinst() {
+ if use emacs; then
+ elisp-site-regen
+ xdg_desktop_database_update
+ fi
+}
+
+pkg_postrm() {
+ if use emacs; then
+ elisp-site-regen
+ xdg_desktop_database_update
+ fi
+}