summaryrefslogtreecommitdiff
path: root/net-mail
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2023-06-11 10:12:44 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2023-06-11 10:12:44 -0400
commitf75f75db6b893d92e2d6049fcb37581b751cc330 (patch)
tree07531d9172db36ab97e11b8d57a0124bf69a56a2 /net-mail
parent04630dc3ebb0918a62c27c1dbc43f4c6e4801324 (diff)
downloadgentoo-overlay-f75f75db6b893d92e2d6049fcb37581b751cc330.tar.xz
gentoo-overlay-f75f75db6b893d92e2d6049fcb37581b751cc330.zip
net-mail/notmuch: sync
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/notmuch/files/notmuch-0.37-configure-clang16.patch24
-rw-r--r--net-mail/notmuch/notmuch-0.37-r2.ebuild (renamed from net-mail/notmuch/notmuch-0.37-r1.ebuild)26
2 files changed, 36 insertions, 14 deletions
diff --git a/net-mail/notmuch/files/notmuch-0.37-configure-clang16.patch b/net-mail/notmuch/files/notmuch-0.37-configure-clang16.patch
new file mode 100644
index 0000000..42c1083
--- /dev/null
+++ b/net-mail/notmuch/files/notmuch-0.37-configure-clang16.patch
@@ -0,0 +1,24 @@
+https://bugs.gentoo.org/879739
+https://nmbug.notmuchmail.org/nmweb/show/20221202191908.848227-1-qsx%40chaotikum.eu
+
+Probe for strcasestr using the C++ compiler
+
+The C++ compiler may define _GNU_SOURCE, causing <string.h> to
+declare strcasestr, while the C compiler does not. As a result,
+the probe may fail, resulting in an incompatible declaration
+of strcasestr in compat/compat.h.
+
+Upstream discussion:
+
+ [PATCH] compat/strcasestr: Include correct header file
+ <https://nmbug.notmuchmail.org/nmweb/show/20221202191908.848227-1-qsx%40chaotikum.eu>
+
+--- a/compat/have_strcasestr.c
++++ b/compat/have_strcasestr.c
+@@ -1,4 +1,5 @@
+ #define _GNU_SOURCE
++#include <string.h>
+ #include <strings.h>
+
+ int
+
diff --git a/net-mail/notmuch/notmuch-0.37-r1.ebuild b/net-mail/notmuch/notmuch-0.37-r2.ebuild
index 050d50a..f9fd203 100644
--- a/net-mail/notmuch/notmuch-0.37-r1.ebuild
+++ b/net-mail/notmuch/notmuch-0.37-r2.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_OPTIONAL=1
-NEED_EMACS="24.1"
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
+PYTHON_COMPAT=( python3_{9..12} pypy3 )
inherit bash-completion-r1 desktop distutils-r1 elisp-common flag-o-matic pax-utils toolchain-funcs xdg-utils
@@ -18,14 +17,14 @@ LICENSE="GPL-3"
# Sub-slot corresponds to major wersion of libnotmuch.so.X.Y. Bump of Y is
# meant to be binary backward compatible.
SLOT="0/5"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~x64-macos"
+KEYWORDS="~alpha amd64 arm arm64 ~ppc64 ~riscv x86 ~x64-macos"
REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
apidoc? ( doc )
nmbug? ( python )
- python? ( ${PYTHON_REQUIRED_USE} )
- test? ( crypt emacs python valgrind )
+ test? ( crypt emacs python )
"
-IUSE="apidoc crypt doc emacs mutt nmbug python test valgrind"
+IUSE="apidoc crypt doc emacs mutt nmbug python test"
RESTRICT="!test? ( test )"
BDEPEND="
@@ -58,7 +57,9 @@ COMMON_DEPEND="
emacs? ( >=app-editors/emacs-${NEED_EMACS}:* )
python? (
${PYTHON_DEPS}
- virtual/python-cffi[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/cffi[${PYTHON_USEDEP}]
+ ' 'python*')
)
"
@@ -72,7 +73,6 @@ DEPEND="${COMMON_DEPEND}
dev-libs/openssl
)
)
- valgrind? ( dev-util/valgrind )
"
RDEPEND="${COMMON_DEPEND}
@@ -95,6 +95,7 @@ SITEFILE="50${PN}-gentoo.el"
PATCHES=(
"${FILESDIR}/notmuch-assume-modern-gmime.patch"
+ "${FILESDIR}"/${PN}-0.37-configure-clang16.patch
)
pkg_setup() {
@@ -239,9 +240,6 @@ src_install() {
default
if use doc; then
- pushd doc/_build/man/man1 > /dev/null || die
- ln notmuch.1 notmuch-setup.1 || die
- popd > /dev/null || die
if use apidoc; then
# rename overly generic manpage to avoid clashes
mv doc/_build/man/man3/deprecated.3 \
@@ -257,8 +255,8 @@ src_install() {
if use nmbug; then
# TODO: those guys need proper deps
- python_fix_shebang devel/nmbug/{nmbug,notmuch-report}
- dobin devel/nmbug/{nmbug,notmuch-report}
+ python_fix_shebang devel/nmbug/notmuch-report
+ dobin devel/nmbug/notmuch-report
fi
if use mutt; then