summaryrefslogtreecommitdiff
path: root/net-misc/gallery-dl/gallery-dl-1.14.0.ebuild
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-07-28 09:41:37 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-07-28 09:41:37 -0400
commitd241ee7943383a8ad8aacd70d5e301a6acf22c38 (patch)
tree5aaddca6d5744a9e3565da0846cbda2e1a34be3b /net-misc/gallery-dl/gallery-dl-1.14.0.ebuild
downloadgentoo-overlay-d241ee7943383a8ad8aacd70d5e301a6acf22c38.tar.xz
gentoo-overlay-d241ee7943383a8ad8aacd70d5e301a6acf22c38.zip
Initial commit
Diffstat (limited to 'net-misc/gallery-dl/gallery-dl-1.14.0.ebuild')
-rw-r--r--net-misc/gallery-dl/gallery-dl-1.14.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-misc/gallery-dl/gallery-dl-1.14.0.ebuild b/net-misc/gallery-dl/gallery-dl-1.14.0.ebuild
new file mode 100644
index 0000000..c2eddf9
--- /dev/null
+++ b/net-misc/gallery-dl/gallery-dl-1.14.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=(python{3_6,3_7,3_8})
+PYTHON_REQ_USE=(sqlite)
+
+inherit bash-completion-r1 distutils-r1
+
+MY_PN="gallery_dl"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Command-line program to download image-galleries and collections"
+HOMEPAGE="https://github.com/mikf/gallery-dl"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+python_install_all() {
+ dodoc README.rst
+
+ distutils-r1_python_install_all
+}