summaryrefslogtreecommitdiff
path: root/net-misc/gallery-dl/gallery-dl-1.14.4.ebuild
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-08-30 20:18:25 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-08-30 20:18:25 -0400
commit4e5feb9f0844a76f33f9dc7b134dd14a8d9a107b (patch)
treec3231738cf4ab8f703abf9df996899675e690303 /net-misc/gallery-dl/gallery-dl-1.14.4.ebuild
parent52c0a9a7377164b6488c3792e48859c848d248f6 (diff)
downloadgentoo-overlay-4e5feb9f0844a76f33f9dc7b134dd14a8d9a107b.tar.xz
gentoo-overlay-4e5feb9f0844a76f33f9dc7b134dd14a8d9a107b.zip
net-misc/gallery-dl: bump
Diffstat (limited to 'net-misc/gallery-dl/gallery-dl-1.14.4.ebuild')
-rw-r--r--net-misc/gallery-dl/gallery-dl-1.14.4.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/net-misc/gallery-dl/gallery-dl-1.14.4.ebuild b/net-misc/gallery-dl/gallery-dl-1.14.4.ebuild
deleted file mode 100644
index 0f26851..0000000
--- a/net-misc/gallery-dl/gallery-dl-1.14.4.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=(python{3_6,3_7,3_8,3_9})
-PYTHON_REQ_USE=(sqlite)
-
-inherit distutils-r1
-
-DESCRIPTION="Command-line program to download image-galleries and collections"
-HOMEPAGE="https://github.com/mikf/gallery-dl"
-SRC_URI="mirror://pypi/g/gallery_dl/gallery_dl-${PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
-IUSE="test"
-
-RDEPEND="
- dev-python/requests[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- ${RDEPEND}
- dev-python/nose
- )
-"
-
-S="${WORKDIR}/gallery_dl-${PV}"
-
-python_test() {
- local noseargs=(
- -v
-
- # requires network access
- -I 'test_results\.py'
-
- # AssertionErrors?
- -e test_expires_db
- -e test_invalidate_db
- -e test_update_db
- )
- nosetests "${noseargs[@]}" || die
-}
-
-python_install_all() {
- dodoc README.rst
-
- distutils-r1_python_install_all
-}