summaryrefslogtreecommitdiff
path: root/net-misc
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-11-05 11:48:01 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-11-05 11:48:01 -0400
commitcd86b59649df944ea7a52dce9e5080a749c5d464 (patch)
tree888d2794e3cfd63db648c8ebedafa73a63ec25d0 /net-misc
parent133848f6c4f0bc1b337d68eb52beb0cf4573256c (diff)
downloadgentoo-overlay-cd86b59649df944ea7a52dce9e5080a749c5d464.tar.xz
gentoo-overlay-cd86b59649df944ea7a52dce9e5080a749c5d464.zip
net-misc/yt-dlp: add
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/yt-dlp/Manifest1
-rw-r--r--net-misc/yt-dlp/metadata.xml16
-rw-r--r--net-misc/yt-dlp/yt-dlp-2021.10.22-r3.ebuild61
3 files changed, 78 insertions, 0 deletions
diff --git a/net-misc/yt-dlp/Manifest b/net-misc/yt-dlp/Manifest
new file mode 100644
index 0000000..dfa7cc0
--- /dev/null
+++ b/net-misc/yt-dlp/Manifest
@@ -0,0 +1 @@
+DIST yt-dlp-2021.10.22.tar.gz 2010916 BLAKE2B fb8f789c74df06dcd672d00ac16eb7cbf466755c3fa607acdd21dd9a9ef2af158a5272f88656133078bd50585506b65cf3b3c03236726de954ccfa0b6c1195fc SHA512 2b590703f8d4f9454b50983019aca8046205234bd98cac4da73a6688eae177a19ef641e486aea92d86197ee7ad6c564c65f9b9496d623c00bdcc349817d5b1f8
diff --git a/net-misc/yt-dlp/metadata.xml b/net-misc/yt-dlp/metadata.xml
new file mode 100644
index 0000000..1fbaa63
--- /dev/null
+++ b/net-misc/yt-dlp/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>slashbeast@gentoo.org</email>
+ <name>Piotr Karbowski</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>ionen@gentoo.org</email>
+ <name>Ionen Wolkens</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">yt-dlp/yt-dlp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-misc/yt-dlp/yt-dlp-2021.10.22-r3.ebuild b/net-misc/yt-dlp/yt-dlp-2021.10.22-r3.ebuild
new file mode 100644
index 0000000..2a57c97
--- /dev/null
+++ b/net-misc/yt-dlp/yt-dlp-2021.10.22-r3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit bash-completion-r1 distutils-r1 optfeature
+
+DESCRIPTION="youtube-dl fork with additional features and fixes"
+HOMEPAGE="https://github.com/yt-dlp/yt-dlp"
+SRC_URI="mirror://pypi/${P::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~riscv ~x86"
+
+RDEPEND="
+ !net-misc/youtube-dl"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -m 'not download'
+}
+
+python_install_all() {
+ dodoc README.md Changelog.md supportedsites.md
+ doman yt-dlp.1
+
+ dobashcomp completions/bash/yt-dlp
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completions/fish/yt-dlp.fish
+
+ insinto /usr/share/zsh/site-functions
+ doins completions/zsh/_yt-dlp
+
+ rm -r "${ED}"/usr/share/doc/yt_dlp || die
+
+ newbin - youtube-dl <<-EOF
+ #!/usr/bin/env sh
+ exec yt-dlp --compat-options youtube-dl "\${@}"
+ EOF
+}
+
+pkg_postinst() {
+ if [[ ! ${REPLACING_VERSIONS} ]] ||
+ ver_test ${REPLACING_VERSIONS} -lt 2021.10.22-r2; then
+ elog 'A wrapper using "yt-dlp --compat-options youtube-dl" was installed'
+ elog 'as "youtube-dl". This is strictly for compatibility and it is'
+ elog 'recommended to use "yt-dlp" directly, it may be removed in the future.'
+ fi
+ optfeature 'merging seperate video and audio files as well as for various post-processing tasks' media-video/ffmpeg
+ optfeature 'embedding thumbnail in certain formats' media-libs/mutagen
+ optfeature 'decrypting AES-128 HLS streams and various other data' dev-python/pycryptodomex
+ optfeature 'downloading over websocket' dev-python/websockets
+ optfeature 'decrypting cookies of chromium-based browsers on Linux' dev-python/keyring
+ optfeature 'embedding thumbnail in mp4/m4a if mutagen is not present' media-video/atomicparsley
+ optfeature 'downloading rtmp streams. ffmpeg will be used as a fallback' media-video/rtmpdump
+ optfeature 'downloading rstp streams. ffmpeg will be used as a fallback' media-video/mplayer media-video/mpv
+}