summaryrefslogtreecommitdiff
path: root/sys-apps
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-07-28 09:41:37 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-07-28 09:41:37 -0400
commitd241ee7943383a8ad8aacd70d5e301a6acf22c38 (patch)
tree5aaddca6d5744a9e3565da0846cbda2e1a34be3b /sys-apps
downloadgentoo-overlay-d241ee7943383a8ad8aacd70d5e301a6acf22c38.tar.xz
gentoo-overlay-d241ee7943383a8ad8aacd70d5e301a6acf22c38.zip
Initial commit
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/xdg-desktop-portal-wlr/Manifest1
-rw-r--r--sys-apps/xdg-desktop-portal-wlr/metadata.xml8
-rw-r--r--sys-apps/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-0.1.0.ebuild40
3 files changed, 49 insertions, 0 deletions
diff --git a/sys-apps/xdg-desktop-portal-wlr/Manifest b/sys-apps/xdg-desktop-portal-wlr/Manifest
new file mode 100644
index 0000000..edf784a
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal-wlr/Manifest
@@ -0,0 +1 @@
+DIST xdg-desktop-portal-wlr-0.1.0.tar.gz 20600 BLAKE2B e7930bb2092d10adc3e34ffb5f4de8cd0c02f96085d97a56a1822f9d3bf92dee7dc3aa4e9a59ee6f868cbdc8fe3dd44511903aa4ac3b2724cc9eaf609ea3457f SHA512 07ae2ba3583e53f3b0e5b97cb60cb85ae835c403906f3b214f6feedc615e3266f5a0f9dc12997802834fdeb2958f6b22c195eebe420a93b3a697460a2a4e3367
diff --git a/sys-apps/xdg-desktop-portal-wlr/metadata.xml b/sys-apps/xdg-desktop-portal-wlr/metadata.xml
new file mode 100644
index 0000000..004555a
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal-wlr/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alex_y_xu@yahoo.ca</email>
+ <name>Alex Xu (Hello71)</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sys-apps/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-0.1.0.ebuild b/sys-apps/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-0.1.0.ebuild
new file mode 100644
index 0000000..cbce952
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-0.1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit meson
+
+SRC_URI="https://github.com/emersion/${PN}/releases/download/v${PV}/${P}.tar.gz"
+DESCRIPTION="xdg-desktop-portal backend for wlroots"
+HOMEPAGE="https://github.com/emersion/xdg-desktop-portal-wlr"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="systemd elogind"
+
+# FIXME: The X and wayland options are autodetected.
+BDEPEND="
+ virtual/pkgconfig
+ >=sys-devel/gettext-0.18.3
+"
+DEPEND="
+ >=media-video/pipewire-0.3
+ dev-libs/wayland
+ >=dev-libs/wayland-protocols-1.14
+ >=sys-apps/xdg-desktop-portal-1.7.0
+ systemd? ( sys-apps/systemd )
+ elogind? ( sys-auth/elogind )
+"
+RDEPEND="${DEPEND}"
+REQUIRED_USE="
+ ?? ( systemd elogind )
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature systemd)
+ )
+ meson_src_configure
+}