summaryrefslogtreecommitdiff
path: root/sys-boot/limine/limine-8.0.13.ebuild
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2024-10-01 15:17:56 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2024-10-01 15:17:56 -0400
commit4aa26a203d1d8c584311b80123d98c3ad8cf6d73 (patch)
tree3acc7b6d4dfc658b1fa31d7fd81b3b28415a40e0 /sys-boot/limine/limine-8.0.13.ebuild
parentaf42e1bcf3abc427f046cebd15a0e4c8dc6cc268 (diff)
downloadgentoo-overlay-4aa26a203d1d8c584311b80123d98c3ad8cf6d73.tar.xz
gentoo-overlay-4aa26a203d1d8c584311b80123d98c3ad8cf6d73.zip
sys-boot/limine: new package
Diffstat (limited to 'sys-boot/limine/limine-8.0.13.ebuild')
-rw-r--r--sys-boot/limine/limine-8.0.13.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sys-boot/limine/limine-8.0.13.ebuild b/sys-boot/limine/limine-8.0.13.ebuild
new file mode 100644
index 0000000..5d41343
--- /dev/null
+++ b/sys-boot/limine/limine-8.0.13.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Limine is a modern, advanced, and portable BIOS/UEFI multiprotocol bootloader"
+HOMEPAGE="https://limine-bootloader.org/"
+SRC_URI="https://github.com/limine-bootloader/limine/releases/download/v${PV}/limine-${PV}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="abi_x86_32 abi_x86_64 bios bios-pxe bios-cd uefi uefi-cd"
+
+BDEPEND="
+ app-alternatives/gzip
+ dev-lang/nasm
+ sys-apps/findutils
+ uefi-cd? ( sys-fs/mtools )
+"
+
+REQUIRED_USE="
+ bios? ( || ( amd64 x86 ) )
+ bios-cd? ( || ( amd64 x86 ) )
+ bios-pxe? ( || ( amd64 x86 ) )
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable bios)
+ $(use_enable bios-cd)
+ $(use_enable bios-pxe)
+
+ $(use_enable uefi-cd)
+ )
+
+ if use uefi; then
+ myconf+=(
+ $(use_enable abi_x86_32 uefi-ia32)
+ $(use_enable abi_x86_64 uefi-x86-64)
+ $(use_enable arm64 uefi-aarch64)
+ $(use_enable riscv uefi-riscv64)
+ )
+ fi
+
+ econf "${myconf[@]}"
+}