summaryrefslogtreecommitdiff
path: root/virtual/rust
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-07-28 09:54:54 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-07-28 09:54:54 -0400
commit734427ad69fcf920f861ebfe4b1141c89496317b (patch)
treed49fd81a147f543237569152cae03aedb0dfa534 /virtual/rust
parentd241ee7943383a8ad8aacd70d5e301a6acf22c38 (diff)
downloadgentoo-overlay-734427ad69fcf920f861ebfe4b1141c89496317b.tar.xz
gentoo-overlay-734427ad69fcf920f861ebfe4b1141c89496317b.zip
import more packages
Diffstat (limited to 'virtual/rust')
-rw-r--r--virtual/rust/metadata.xml4
-rw-r--r--virtual/rust/rust-1.41.1.ebuild15
-rw-r--r--virtual/rust/rust-1.42.0.ebuild15
-rw-r--r--virtual/rust/rust-1.43.1.ebuild15
-rw-r--r--virtual/rust/rust-1.44.0.ebuild15
-rw-r--r--virtual/rust/rust-1.44.1.ebuild15
-rw-r--r--virtual/rust/rust-1.45.0.ebuild15
7 files changed, 94 insertions, 0 deletions
diff --git a/virtual/rust/metadata.xml b/virtual/rust/metadata.xml
new file mode 100644
index 0000000..097975e
--- /dev/null
+++ b/virtual/rust/metadata.xml
@@ -0,0 +1,4 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+</pkgmetadata>
diff --git a/virtual/rust/rust-1.41.1.ebuild b/virtual/rust/rust-1.41.1.ebuild
new file mode 100644
index 0000000..315e172
--- /dev/null
+++ b/virtual/rust/rust-1.41.1.ebuild
@@ -0,0 +1,15 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for Rust language compiler"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ppc64 x86"
+
+BDEPEND=""
+RDEPEND="|| ( =dev-lang/rust-bin-${PV}* =dev-lang/rust-${PV}*[${MULTILIB_USEDEP}] )"
diff --git a/virtual/rust/rust-1.42.0.ebuild b/virtual/rust/rust-1.42.0.ebuild
new file mode 100644
index 0000000..3d180e1
--- /dev/null
+++ b/virtual/rust/rust-1.42.0.ebuild
@@ -0,0 +1,15 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for Rust language compiler"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+BDEPEND=""
+RDEPEND="|| ( =dev-lang/rust-bin-${PV}* =dev-lang/rust-${PV}*[${MULTILIB_USEDEP}] )"
diff --git a/virtual/rust/rust-1.43.1.ebuild b/virtual/rust/rust-1.43.1.ebuild
new file mode 100644
index 0000000..047d17e
--- /dev/null
+++ b/virtual/rust/rust-1.43.1.ebuild
@@ -0,0 +1,15 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for Rust language compiler"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ppc64 x86"
+
+BDEPEND=""
+RDEPEND="|| ( =dev-lang/rust-bin-${PV}*[${MULTILIB_USEDEP}] =dev-lang/rust-${PV}*[${MULTILIB_USEDEP}] )"
diff --git a/virtual/rust/rust-1.44.0.ebuild b/virtual/rust/rust-1.44.0.ebuild
new file mode 100644
index 0000000..3d33a14
--- /dev/null
+++ b/virtual/rust/rust-1.44.0.ebuild
@@ -0,0 +1,15 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for Rust language compiler"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+BDEPEND=""
+RDEPEND="|| ( =dev-lang/rust-bin-${PV}*[${MULTILIB_USEDEP}] =dev-lang/rust-${PV}*[${MULTILIB_USEDEP}] )"
diff --git a/virtual/rust/rust-1.44.1.ebuild b/virtual/rust/rust-1.44.1.ebuild
new file mode 100644
index 0000000..0e6e6e7
--- /dev/null
+++ b/virtual/rust/rust-1.44.1.ebuild
@@ -0,0 +1,15 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for Rust language compiler"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ppc64 x86"
+
+BDEPEND=""
+RDEPEND="|| ( ~dev-lang/rust-bin-${PV}[${MULTILIB_USEDEP}] ~dev-lang/rust-${PV}[${MULTILIB_USEDEP}] )"
diff --git a/virtual/rust/rust-1.45.0.ebuild b/virtual/rust/rust-1.45.0.ebuild
new file mode 100644
index 0000000..61df384
--- /dev/null
+++ b/virtual/rust/rust-1.45.0.ebuild
@@ -0,0 +1,15 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for Rust language compiler"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+BDEPEND=""
+RDEPEND="|| ( ~dev-lang/rust-bin-${PV}[${MULTILIB_USEDEP}] ~dev-lang/rust-${PV}[${MULTILIB_USEDEP}] )"