summaryrefslogtreecommitdiff
path: root/x11-apps
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-07-28 16:50:08 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-07-28 16:50:08 -0400
commitd8705b95a8ed3e817ffc0b95a8f5f2daef9b270e (patch)
treece1e02750c79e5a89e09f12f6309e80d9469d708 /x11-apps
parent95fda03f6c47d109e717562b55f890d96adb0246 (diff)
downloadgentoo-overlay-d8705b95a8ed3e817ffc0b95a8f5f2daef9b270e.tar.xz
gentoo-overlay-d8705b95a8ed3e817ffc0b95a8f5f2daef9b270e.zip
x11-apps/sx: add 2.1.3
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/sx/Manifest1
-rw-r--r--x11-apps/sx/sx-2.1.3.ebuild27
-rw-r--r--x11-apps/sx/sx-9999.ebuild13
3 files changed, 37 insertions, 4 deletions
diff --git a/x11-apps/sx/Manifest b/x11-apps/sx/Manifest
new file mode 100644
index 0000000..d7eb14d
--- /dev/null
+++ b/x11-apps/sx/Manifest
@@ -0,0 +1 @@
+DIST sx-2.1.3.tar.gz 3342 BLAKE2B 92d3ac1308261d4a9325262a44be8a7022ebf73b18058d2fd5493f8f9d0992b8bc2cc2ad77b747cf51b69f50727c6a422bd130f7805919c0d8e0c0ef2de8e8d0 SHA512 d945888cb164d85d7e1ae87f86a79d4ad3130b4656652d7def490b7846b6cb6ae3427e70e5bc311f4fc02bfc4e4e2ca6d618ba1a3a8f4c4cf4c4d212afbb4fb9
diff --git a/x11-apps/sx/sx-2.1.3.ebuild b/x11-apps/sx/sx-2.1.3.ebuild
new file mode 100644
index 0000000..c43076d
--- /dev/null
+++ b/x11-apps/sx/sx-2.1.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Start an xorg server"
+HOMEPAGE="https://github.com/Earnestly/sx"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Earnestly/sx.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/Earnestly/sx/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+}
diff --git a/x11-apps/sx/sx-9999.ebuild b/x11-apps/sx/sx-9999.ebuild
index a5ba000..2c2e7a2 100644
--- a/x11-apps/sx/sx-9999.ebuild
+++ b/x11-apps/sx/sx-9999.ebuild
@@ -3,15 +3,20 @@
EAPI=7
-inherit git-r3
-
DESCRIPTION="Start an xorg server"
HOMEPAGE="https://github.com/Earnestly/sx"
-EGIT_REPO_URI="https://github.com/Earnestly/sx.git"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Earnestly/sx.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/Earnestly/sx/archive/${PV}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
LICENSE="MIT"
SLOT="0"
-KEYWORDS=""
src_compile() {
: