summaryrefslogtreecommitdiff
path: root/x11-base/xorg-server/xorg-server-9999.ebuild
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-12-01 21:03:47 -0500
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-12-01 21:03:47 -0500
commit79d2556678671ab75762a89ba25d8ec19d221129 (patch)
treec02f6ba3db73060da827826338c4a5df26dc0d0f /x11-base/xorg-server/xorg-server-9999.ebuild
parent2ecd943940e562ac8f5e3ba4ab9b20049951e661 (diff)
downloadgentoo-overlay-79d2556678671ab75762a89ba25d8ec19d221129.tar.xz
gentoo-overlay-79d2556678671ab75762a89ba25d8ec19d221129.zip
x11-base/xorg-server: sync
Diffstat (limited to 'x11-base/xorg-server/xorg-server-9999.ebuild')
-rw-r--r--x11-base/xorg-server/xorg-server-9999.ebuild23
1 files changed, 5 insertions, 18 deletions
diff --git a/x11-base/xorg-server/xorg-server-9999.ebuild b/x11-base/xorg-server/xorg-server-9999.ebuild
index e6b07ab..99a8c50 100644
--- a/x11-base/xorg-server/xorg-server-9999.ebuild
+++ b/x11-base/xorg-server/xorg-server-9999.ebuild
@@ -15,14 +15,10 @@ if [[ ${PV} != 9999* ]]; then
fi
IUSE_SERVERS="dmx kdrive wayland xephyr xnest xorg xvfb"
-IUSE="${IUSE_SERVERS} debug +elogind ipv6 libressl +libglvnd minimal selinux suid systemd +udev unwind xcsecurity"
+IUSE="${IUSE_SERVERS} debug +elogind ipv6 libressl minimal selinux suid systemd +udev unwind xcsecurity"
-CDEPEND="libglvnd? (
- media-libs/libglvnd[X]
- !app-eselect/eselect-opengl
- !!x11-drivers/nvidia-drivers[-libglvnd(-)]
- )
- !libglvnd? ( >=app-eselect/eselect-opengl-1.3.0 )
+CDEPEND="
+ media-libs/libglvnd[X]
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
>=x11-apps/iceauth-1.0.2
@@ -78,7 +74,6 @@ CDEPEND="libglvnd? (
>=media-libs/libepoxy-1.5.4[egl(+)]
>=dev-libs/wayland-protocols-1.18
)
- >=x11-apps/xinit-1.3.3-r1
systemd? (
sys-apps/dbus
sys-apps/systemd
@@ -88,7 +83,8 @@ CDEPEND="libglvnd? (
sys-auth/elogind[pam]
sys-auth/pambase[elogind]
)
- "
+ !!x11-drivers/nvidia-drivers[-libglvnd(-)]
+"
DEPEND="${CDEPEND}
sys-devel/flex
@@ -212,15 +208,6 @@ src_install() {
find "${ED}"/var -type d -empty -delete || die
}
-pkg_postinst() {
- if ! use minimal; then
- # sets up libGL and DRI2 symlinks if needed (ie, on a fresh install)
- if ! use libglvnd; then
- eselect opengl set xorg-x11 --use-old
- fi
- fi
-}
-
pkg_postrm() {
# Get rid of module dir to ensure opengl-update works properly
if [[ -z ${REPLACED_BY_VERSION} && -e ${EROOT}/usr/$(get_libdir)/xorg/modules ]]; then