summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gui-apps/gammastep/gammastep-2.0.7-r1.ebuild (renamed from gui-apps/gammastep/gammastep-2.0.7.ebuild)21
1 files changed, 12 insertions, 9 deletions
diff --git a/gui-apps/gammastep/gammastep-2.0.7.ebuild b/gui-apps/gammastep/gammastep-2.0.7-r1.ebuild
index 28b1e7b..cf33697 100644
--- a/gui-apps/gammastep/gammastep-2.0.7.ebuild
+++ b/gui-apps/gammastep/gammastep-2.0.7-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7..10} )
inherit systemd autotools gnome2-utils python-r1
@@ -13,17 +13,20 @@ SRC_URI="https://gitlab.com/chinstrap/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.bz
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="appindicator geoclue gtk nls wayland"
+IUSE="X appindicator drm geoclue gtk nls wayland"
BDEPEND="${COMMON_DEPEND}
>=dev-util/intltool-0.50
nls? ( sys-devel/gettext )
"
-DEPEND=">=x11-libs/libX11-1.4
- x11-libs/libXxf86vm
- x11-libs/libxcb
- x11-libs/libdrm
+DEPEND="
+ X? (
+ >=x11-libs/libX11-1.4
+ x11-libs/libXxf86vm
+ x11-libs/libxcb
+ )
appindicator? ( dev-libs/libappindicator:3[introspection] )
+ drm? ( x11-libs/libdrm )
geoclue? ( app-misc/geoclue:2.0 dev-libs/glib:2 )
gtk? ( ${PYTHON_DEPS} )
wayland? ( >=dev-libs/wayland-1.15.0 )"
@@ -45,9 +48,9 @@ src_configure() {
econf \
$(use_enable nls) \
- --enable-drm \
- --enable-randr \
- --enable-vidmode \
+ $(use_enable drm) \
+ $(use_enable X randr) \
+ $(use_enable X vidmode) \
$(use_enable geoclue geoclue2) \
$(use_enable gtk gui) \
$(use_enable wayland) \