summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-arch/7-zip/7-zip-21.04_beta-r1.ebuild (renamed from app-arch/7-zip/7-zip-21.04_beta.ebuild)16
-rw-r--r--app-arch/7-zip/metadata.xml3
2 files changed, 12 insertions, 7 deletions
diff --git a/app-arch/7-zip/7-zip-21.04_beta.ebuild b/app-arch/7-zip/7-zip-21.04_beta-r1.ebuild
index ee18d6b..6c7a6c3 100644
--- a/app-arch/7-zip/7-zip-21.04_beta.ebuild
+++ b/app-arch/7-zip/7-zip-21.04_beta-r1.ebuild
@@ -48,15 +48,17 @@ src_compile() {
local myemakeargs=(
CC="$(tc-getCC) ${CFLAGS} ${LDFLAGS}"
CXX="$(tc-getCXX) ${CXXFLAGS} ${LDFLAGS}"
- MY_ASM=uasm
CFLAGS_WARN_WALL="-Wall -Wextra"
)
- if use amd64; then
- myemakeargs+=(IS_X64=1 USE_ASM=1)
- elif use arm64; then
- myemakeargs+=(IS_ARM64=1 USE_ASM=1)
- elif use x86; then
- myemakeargs+=(IS_X86=1 USE_ASM=1)
+ if use asm; then
+ myemakeargs+=(USE_ASM=1 MY_ASM=uasm)
+ if use amd64; then
+ myemakeargs+=(IS_X64=1)
+ elif use arm64; then
+ myemakeargs+=(IS_ARM64=1)
+ elif use x86; then
+ myemakeargs+=(IS_X86=1)
+ fi
fi
mkdir -p b/g || die
emake -f ../../cmpl_gcc.mak "${myemakeargs[@]}"
diff --git a/app-arch/7-zip/metadata.xml b/app-arch/7-zip/metadata.xml
index 004555a..aab945b 100644
--- a/app-arch/7-zip/metadata.xml
+++ b/app-arch/7-zip/metadata.xml
@@ -5,4 +5,7 @@
<email>alex_y_xu@yahoo.ca</email>
<name>Alex Xu (Hello71)</name>
</maintainer>
+ <use>
+ <flag name="asm">Use assembly implementations (currently only amd64, arm64, x86)</flag>
+ </use>
</pkgmetadata>