summaryrefslogtreecommitdiff
path: root/app-misc
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/ca-certificates/Manifest3
-rw-r--r--app-misc/ca-certificates/ca-certificates-20211016.3.72.ebuild197
-rw-r--r--app-misc/ca-certificates/files/ca-certificates-20150426-root.patch49
-rw-r--r--app-misc/ca-certificates/files/ca-certificates-no-cryptography.patch24
-rw-r--r--app-misc/ca-certificates/metadata.xml13
5 files changed, 0 insertions, 286 deletions
diff --git a/app-misc/ca-certificates/Manifest b/app-misc/ca-certificates/Manifest
deleted file mode 100644
index 6c10a91..0000000
--- a/app-misc/ca-certificates/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST ca-certificates_20211016.tar.xz 239608 BLAKE2B 9b4730b54fd9f472fe4e5427bf912d9a61d10d2c289d1e443b54cca469fa87f9e02b8f67e7e087aceceffc7dd2b4043cdb5380e2652bc619d51f3a224c64f717 SHA512 bedf072c8aa1b05b249ea272f5cecfe16bdcd762c02c712323f12ac7a278e8814453f5f3caad86a2581e451788b292ed3a76a6a81620926459bb890133cffde1
-DIST nss-3.72.tar.gz 83928300 BLAKE2B d92889e27e99095a18090eff0c08b8653ef1f53f4954f5bd018df2f2903647bc71f217159bb4b11f0d6b4fb289fda20bffa2d1d207d1836dcfc33dbd4bedf511 SHA512 1d818d2ef85735837275059fecf68d57e48152f0348ea54887c29171cf029b6944e94d99a8cd96e580a81edb678b79c55515ac0516e27daf6b290c34baed9ebb
-DIST nss-cacert-class1-class3-r2.patch 21925 BLAKE2B 7627ff9a09f084c19d72d0490676865e3cab3ca7c920ae1ce4bea2db664f37fd0aa84fcda919809a516891ab2a62e2e7a43a9d6ada4c231adfe4c216525fac7d SHA512 1ce6ff9ab310aaca9005eafb461338b291df8523cc7044e096cd75774ce746c26eed19ec6bb2643c6c67f94650f2f309463492d80a90568f38ce2557f8ada2f4
diff --git a/app-misc/ca-certificates/ca-certificates-20211016.3.72.ebuild b/app-misc/ca-certificates/ca-certificates-20211016.3.72.ebuild
deleted file mode 100644
index 3a0ffc1..0000000
--- a/app-misc/ca-certificates/ca-certificates-20211016.3.72.ebuild
+++ /dev/null
@@ -1,197 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# The Debian ca-certificates package merely takes the CA database as it exists
-# in the nss package and repackages it for use by openssl.
-#
-# The issue with using the compiled debs directly is two fold:
-# - they do not update frequently enough for us to rely on them
-# - they pull the CA database from nss tip of tree rather than the release
-#
-# So we take the Debian source tools and combine them with the latest nss
-# release to produce (largely) the same end result. The difference is that
-# now we know our cert database is kept in sync with nss and, if need be,
-# can be sync with nss tip of tree more frequently to respond to bugs.
-
-# When triaging user reports, refer to our wiki for tips:
-# https://wiki.gentoo.org/wiki/Certificates#Debugging_certificate_issues
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} )
-
-inherit python-any-r1
-
-if [[ ${PV} == *.* ]] ; then
- # Compile from source ourselves.
- PRECOMPILED=false
-
- DEB_VER=$(ver_cut 1)
- NSS_VER=$(ver_cut 2-)
- RTM_NAME="NSS_${NSS_VER//./_}_RTM"
-else
- # Debian precompiled version.
- PRECOMPILED=true
- inherit unpacker
-fi
-
-DESCRIPTION="Common CA Certificates PEM files"
-HOMEPAGE="https://packages.debian.org/sid/ca-certificates"
-NMU_PR=""
-if ${PRECOMPILED} ; then
- SRC_URI="mirror://debian/pool/main/c/${PN}/${PN}_${PV}${NMU_PR:++nmu}${NMU_PR}_all.deb"
-else
- SRC_URI="mirror://debian/pool/main/c/${PN}/${PN}_${DEB_VER}${NMU_PR:++nmu}${NMU_PR}.tar.xz
- https://archive.mozilla.org/pub/security/nss/releases/${RTM_NAME}/src/nss-${NSS_VER}.tar.gz
- cacert? (
- https://dev.gentoo.org/~whissi/dist/ca-certificates/nss-cacert-class1-class3-r2.patch
- )"
-fi
-
-LICENSE="MPL-1.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
-IUSE=""
-${PRECOMPILED} || IUSE+=" cacert"
-
-# c_rehash: we run `c_rehash`
-# debianutils: we run `run-parts`
-CDEPEND="app-misc/c_rehash
- sys-apps/debianutils"
-
-BDEPEND="${CDEPEND}"
-if ! ${PRECOMPILED} ; then
- BDEPEND+=" ${PYTHON_DEPS}"
-fi
-
-DEPEND=""
-if ${PRECOMPILED} ; then
- DEPEND+=" !<sys-apps/portage-2.1.10.41"
-fi
-
-RDEPEND="${CDEPEND}
- ${DEPEND}"
-
-S=${WORKDIR}
-
-pkg_setup() {
- # For the conversion to having it in CONFIG_PROTECT_MASK,
- # we need to tell users about it once manually first.
- [[ -f "${EPREFIX}"/etc/env.d/98ca-certificates ]] \
- || ewarn "You should run update-ca-certificates manually after etc-update"
-
- if ! ${PRECOMPILED} ; then
- python-any-r1_pkg_setup
- fi
-}
-
-src_unpack() {
- if ! ${PRECOMPILED} ; then
- default
- # Initial 20200601 deb release had bad naming inside the debian source tarball.
- DEB_S="${WORKDIR}/${PN}-${DEB_VER}"
- DEB_BAD_S="${WORKDIR}/work"
- if [[ -d "${DEB_BAD_S}" ]] && [[ ! -d "${DEB_S}" ]] ; then
- mv "${DEB_BAD_S}" "${DEB_S}"
- fi
- fi
-
- # Do all the work in the image subdir to avoid conflicting with source
- # dirs in ${WORKDIR}. Need to perform everything in the offset #381937
- mkdir -p "image/${EPREFIX}" || die
- cd "image/${EPREFIX}" || die
-
- ${PRECOMPILED} && unpacker_src_unpack
-}
-
-src_prepare() {
- cd "image/${EPREFIX}" || die
- if ! ${PRECOMPILED} ; then
- mkdir -p usr/sbin || die
- cp -p "${S}"/${PN}-${DEB_VER}/sbin/update-ca-certificates \
- usr/sbin/ || die
-
- pushd "${S}"/${PN}-${DEB_VER} >/dev/null || die
- eapply "${FILESDIR}"/${PN}-no-cryptography.patch
- popd >/dev/null || die
-
- if use cacert ; then
- pushd "${S}"/nss-${NSS_VER} >/dev/null || die
- eapply "${DISTDIR}"/nss-cacert-class1-class3-r2.patch
- popd >/dev/null || die
- fi
- fi
-
- default
- eapply -p2 "${FILESDIR}"/${PN}-20150426-root.patch
- local relp=$(echo "${EPREFIX}" | sed -e 's:[^/]\+:..:g')
- sed -i \
- -e '/="$ROOT/s:ROOT:ROOT'"${EPREFIX}"':' \
- -e '/RELPATH="\.\./s:"$:'"${relp}"'":' \
- -e 's/openssl rehash/c_rehash/' \
- usr/sbin/update-ca-certificates || die
-}
-
-src_compile() {
- cd "image/${EPREFIX}" || die
- if ! ${PRECOMPILED} ; then
- local d="${S}/${PN}-${DEB_VER}/mozilla" c="usr/share/${PN}"
-
- # Grab the database from the nss sources.
- cp "${S}"/nss-${NSS_VER}/nss/lib/ckfw/builtins/{certdata.txt,nssckbi.h} "${d}" || die
- emake -C "${d}"
-
- # Now move the files to the same places that the precompiled would.
- mkdir -p etc/ssl/certs \
- etc/ca-certificates/update.d \
- "${c}"/mozilla \
- || die
- if use cacert ; then
- mkdir -p "${c}"/cacert.org || die
- mv "${d}"/CA_Cert_Signing_Authority.crt \
- "${c}"/cacert.org/cacert.org_class1.crt || die
- mv "${d}"/CAcert_Class_3_Root.crt \
- "${c}"/cacert.org/cacert.org_class3.crt || die
- fi
- mv "${d}"/*.crt "${c}"/mozilla/ || die
- else
- mv usr/share/doc/{ca-certificates,${PF}} || die
- fi
-
- (
- echo "# Automatically generated by ${CATEGORY}/${PF}"
- echo "# $(date -u)"
- echo "# Do not edit."
- cd "${c}" || die
- find * -name '*.crt' | LC_ALL=C sort
- ) > etc/ca-certificates.conf
-
- sh usr/sbin/update-ca-certificates --root "${S}/image" || die
-}
-
-src_install() {
- cp -pPR image/* "${D}"/ || die
- if ! ${PRECOMPILED} ; then
- cd ${PN}-${DEB_VER} || die
- doman sbin/*.8
- dodoc debian/README.* examples/ca-certificates-local/README
- fi
-
- echo 'CONFIG_PROTECT_MASK="/etc/ca-certificates.conf"' > 98ca-certificates
- doenvd 98ca-certificates
-}
-
-pkg_postinst() {
- if [[ -d "${EROOT}/usr/local/share/ca-certificates" ]] ; then
- # if the user has local certs, we need to rebuild again
- # to include their stuff in the db.
- # However it's too overzealous when the user has custom certs in place.
- # --fresh is to clean up dangling symlinks
- "${EROOT}"/usr/sbin/update-ca-certificates --root "${ROOT}"
- fi
-
- if [[ -n "$(find -L "${EROOT}"/etc/ssl/certs/ -type l)" ]] ; then
- ewarn "Removing the following broken symlinks:"
- ewarn "$(find -L "${EROOT}"/etc/ssl/certs/ -type l -printf '%p -> %l\n' -delete)"
- fi
-}
diff --git a/app-misc/ca-certificates/files/ca-certificates-20150426-root.patch b/app-misc/ca-certificates/files/ca-certificates-20150426-root.patch
deleted file mode 100644
index 6e41ac3..0000000
--- a/app-misc/ca-certificates/files/ca-certificates-20150426-root.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-add a --root option so we can generate with DESTDIR installs
-
---- a/image/usr/sbin/update-ca-certificates
-+++ b/image/usr/sbin/update-ca-certificates
-@@ -30,6 +30,8 @@ LOCALCERTSDIR=/usr/local/share/ca-certificates
- CERTBUNDLE=ca-certificates.crt
- ETCCERTSDIR=/etc/ssl/certs
- HOOKSDIR=/etc/ca-certificates/update.d
-+ROOT=""
-+RELPATH=""
-
- while [ $# -gt 0 ];
- do
-@@ -59,13 +61,25 @@ do
- --hooksdir)
- shift
- HOOKSDIR="$1";;
-+ --root|-r)
-+ shift
-+ # Needed as c_rehash wants to read the files directly.
-+ # This gets us from $CERTSCONF to $CERTSDIR.
-+ RELPATH="../../.."
-+ ROOT=$(readlink -f "$1");;
- --help|-h|*)
-- echo "$0: [--verbose] [--fresh]"
-+ echo "$0: [--verbose] [--fresh] [--root <dir>]"
- exit;;
- esac
- shift
- done
-
-+CERTSCONF="$ROOT$CERTSCONF"
-+CERTSDIR="$ROOT$CERTSDIR"
-+LOCALCERTSDIR="$ROOT$LOCALCERTSDIR"
-+ETCCERTSDIR="$ROOT$ETCCERTSDIR"
-+HOOKSDIR="$ROOT$HOOKSDIR"
-+
- if [ ! -s "$CERTSCONF" ]
- then
- fresh=1
-@@ -94,7 +107,7 @@ add() {
- -e 's/,/_/g').pem"
- if ! test -e "$PEM" || [ "$(readlink "$PEM")" != "$CERT" ]
- then
-- ln -sf "$CERT" "$PEM"
-+ ln -sf "${RELPATH}${CERT#$ROOT}" "$PEM"
- echo "+$PEM" >> "$ADDED"
- fi
- # Add trailing newline to certificate, if it is missing (#635570)
diff --git a/app-misc/ca-certificates/files/ca-certificates-no-cryptography.patch b/app-misc/ca-certificates/files/ca-certificates-no-cryptography.patch
deleted file mode 100644
index 83cfb92..0000000
--- a/app-misc/ca-certificates/files/ca-certificates-no-cryptography.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- a/mozilla/certdata2pem.py
-+++ b/mozilla/certdata2pem.py
-@@ -28,8 +28,6 @@
- import textwrap
- import io
-
--from cryptography import x509
--
-
- objects = []
-
-@@ -122,12 +120,6 @@
- if not obj['CKA_LABEL'] in trust or not trust[obj['CKA_LABEL']]:
- continue
-
-- cert = x509.load_der_x509_certificate(obj['CKA_VALUE'])
-- if cert.not_valid_after < datetime.datetime.now():
-- print('!'*74)
-- print('Trusted but expired certificate found: %s' % obj['CKA_LABEL'])
-- print('!'*74)
--
- bname = obj['CKA_LABEL'][1:-1].replace('/', '_')\
- .replace(' ', '_')\
- .replace('(', '=')\
diff --git a/app-misc/ca-certificates/metadata.xml b/app-misc/ca-certificates/metadata.xml
deleted file mode 100644
index 250e307..0000000
--- a/app-misc/ca-certificates/metadata.xml
+++ /dev/null
@@ -1,13 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>base-system@gentoo.org</email>
- <name>Gentoo Base System</name>
- </maintainer>
- <use>
- <flag name="cacert">
- Include root/class3 certs from CAcert (https://www.cacert.org/)
- </flag>
- </use>
-</pkgmetadata>