summaryrefslogtreecommitdiff
path: root/app-text/pdfsizeopt/pdfsizeopt-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/pdfsizeopt/pdfsizeopt-9999.ebuild')
-rw-r--r--app-text/pdfsizeopt/pdfsizeopt-9999.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-text/pdfsizeopt/pdfsizeopt-9999.ebuild b/app-text/pdfsizeopt/pdfsizeopt-9999.ebuild
new file mode 100644
index 0000000..0d77669
--- /dev/null
+++ b/app-text/pdfsizeopt/pdfsizeopt-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+inherit git-r3 python-single-r1
+
+DESCRIPTION="PDF file size optimizer"
+HOMEPAGE="https://github.com/pts/pdfsizeopt"
+EGIT_REPO_URI="https://github.com/pts/pdfsizeopt.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ app-text/ghostscript-gpl
+ media-gfx/tif22pnm
+ media-gfx/sam2p
+"
+BDEPEND="${PYTHON_DEPS}"
+
+src_prepare() {
+ default
+ python_fix_shebang mksingle.py
+}
+
+src_compile() {
+ ./mksingle.py
+}
+
+src_install() {
+ newbin pdfsizeopt.single pdfsizeopt
+}