summaryrefslogtreecommitdiff
path: root/app-text/zathura/files/zathura-disable-seccomp-tests.patch
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/zathura/files/zathura-disable-seccomp-tests.patch')
-rw-r--r--app-text/zathura/files/zathura-disable-seccomp-tests.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-text/zathura/files/zathura-disable-seccomp-tests.patch b/app-text/zathura/files/zathura-disable-seccomp-tests.patch
new file mode 100644
index 0000000..f3d88a2
--- /dev/null
+++ b/app-text/zathura/files/zathura-disable-seccomp-tests.patch
@@ -0,0 +1,22 @@
+diff --git a/tests/meson.build b/tests/meson.build
+index ac7edb8..68216f3 100644
+--- a/tests/meson.build
++++ b/tests/meson.build
+@@ -25,17 +25,6 @@ if check.found()
+ timeout: 60*60
+ )
+
+- if seccomp.found()
+- sandbox = executable('test_sandbox', ['test_sandbox.c', 'tests.c'],
+- dependencies: build_dependencies + test_dependencies,
+- include_directories: include_directories,
+- c_args: defines + flags
+- )
+- test('sandbox', sandbox,
+- timeout: 60*60
+- )
+- endif
+-
+ utils = executable('test_utils', ['test_utils.c', 'tests.c'],
+ dependencies: build_dependencies + test_dependencies,
+ include_directories: include_directories,