summaryrefslogtreecommitdiff
path: root/app-text/zathura
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/zathura')
-rw-r--r--app-text/zathura/Manifest2
-rw-r--r--app-text/zathura/files/zathura-disable-seccomp-tests.patch22
-rw-r--r--app-text/zathura/zathura-0.5.2-r3.ebuild (renamed from app-text/zathura/zathura-0.4.8.ebuild)16
-rw-r--r--app-text/zathura/zathura-9999.ebuild61
4 files changed, 31 insertions, 70 deletions
diff --git a/app-text/zathura/Manifest b/app-text/zathura/Manifest
index f36dc8f..10f9a96 100644
--- a/app-text/zathura/Manifest
+++ b/app-text/zathura/Manifest
@@ -1 +1 @@
-DIST zathura-0.4.8.tar.gz 202264 BLAKE2B 70916ac23624b8e55b39bc2b9329fc5d992d3e2e3989b17bebf0f8b1bcb26ed943c15866c0b37e0a4a29fee7c264d6309bf1d036d770817e13a14a13af7499d7 SHA512 00d7b735154ff0e857f8a0a21c24b3fbbff8c166d93a34bee725072ee00f2870adecb956e9445334be2a84827778bd874cc1d4bda7f8b32e4468ea3784834b86
+DIST zathura-0.5.2.tar.gz 208606 BLAKE2B fc7e8042a373a3fd66973fd5d6c7c3e7d6da884fb40269545e4074b42fdbc9b6f286089769a435394812e24a8b24de328521a2fd797bbb13c16115b112dd9a48 SHA512 17f2a6535b2b3c6f61986cd8a6ccdef2c1a129d8ebf8c86cbe3c8eac868c2780801f3fe2fdc17c429ca0c63a71a328bbb6c7f814f82714dd7f1a5a4728663b1f
diff --git a/app-text/zathura/files/zathura-disable-seccomp-tests.patch b/app-text/zathura/files/zathura-disable-seccomp-tests.patch
new file mode 100644
index 0000000..f3d88a2
--- /dev/null
+++ b/app-text/zathura/files/zathura-disable-seccomp-tests.patch
@@ -0,0 +1,22 @@
+diff --git a/tests/meson.build b/tests/meson.build
+index ac7edb8..68216f3 100644
+--- a/tests/meson.build
++++ b/tests/meson.build
+@@ -25,17 +25,6 @@ if check.found()
+ timeout: 60*60
+ )
+
+- if seccomp.found()
+- sandbox = executable('test_sandbox', ['test_sandbox.c', 'tests.c'],
+- dependencies: build_dependencies + test_dependencies,
+- include_directories: include_directories,
+- c_args: defines + flags
+- )
+- test('sandbox', sandbox,
+- timeout: 60*60
+- )
+- endif
+-
+ utils = executable('test_utils', ['test_utils.c', 'tests.c'],
+ dependencies: build_dependencies + test_dependencies,
+ include_directories: include_directories,
diff --git a/app-text/zathura/zathura-0.4.8.ebuild b/app-text/zathura/zathura-0.5.2-r3.ebuild
index c1bd16f..da82595 100644
--- a/app-text/zathura/zathura-0.4.8.ebuild
+++ b/app-text/zathura/zathura-0.5.2-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -18,37 +18,37 @@ else
fi
LICENSE="ZLIB"
-SLOT="0"
-IUSE="doc +magic seccomp sqlite synctex test"
+SLOT="0/$(ver_cut 1-2)"
+IUSE="seccomp sqlite synctex test"
RESTRICT="!test? ( test )"
-DEPEND=">=dev-libs/girara-0.3.3
+DEPEND=">=dev-libs/girara-0.3.7
>=dev-libs/glib-2.50:2
>=sys-devel/gettext-0.19.8
x11-libs/cairo
>=x11-libs/gtk+-3.22:3
- magic? ( sys-apps/file )
+ sys-apps/file
seccomp? ( sys-libs/libseccomp )
sqlite? ( >=dev-db/sqlite-3.5.9:3 )
synctex? ( app-text/texlive-core )"
RDEPEND="${DEPEND}"
-BDEPEND="doc? ( dev-python/docutils )
+BDEPEND="dev-python/docutils
test? ( dev-libs/appstream-glib
dev-libs/check )
virtual/pkgconfig"
PATCHES=(
+ "${FILESDIR}"/zathura-disable-seccomp-tests.patch
"${FILESDIR}/zathura-docutils.patch"
)
src_configure() {
local emesonargs=(
-Dconvert-icon=disabled
- -Dmagic=$(usex magic enabled disabled)
- -Dmanpages=$(usex doc enabled disabled)
+ -Dmanpages=enabled
-Dseccomp=$(usex seccomp enabled disabled)
-Dsqlite=$(usex sqlite enabled disabled)
-Dsynctex=$(usex synctex enabled disabled)
diff --git a/app-text/zathura/zathura-9999.ebuild b/app-text/zathura/zathura-9999.ebuild
deleted file mode 100644
index 00aa622..0000000
--- a/app-text/zathura/zathura-9999.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit meson virtualx
-
-DESCRIPTION="A highly customizable and functional document viewer"
-HOMEPAGE="https://pwmt.org/projects/zathura/"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://git.pwmt.org/pwmt/${PN}.git"
- EGIT_BRANCH="develop"
-else
- SRC_URI="https://github.com/pwmt/zathura/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~riscv ~x86 ~amd64-linux ~x86-linux"
-fi
-
-LICENSE="ZLIB"
-SLOT="0"
-IUSE="doc +magic seccomp sqlite synctex test"
-
-RESTRICT="!test? ( test )"
-
-DEPEND=">=dev-libs/girara-0.3.3
- >=dev-libs/glib-2.50:2
- >=sys-devel/gettext-0.19.8
- x11-libs/cairo
- >=x11-libs/gtk+-3.22:3
- magic? ( sys-apps/file )
- seccomp? ( sys-libs/libseccomp )
- sqlite? ( >=dev-db/sqlite-3.5.9:3 )
- synctex? ( app-text/texlive-core )"
-
-RDEPEND="${DEPEND}"
-
-BDEPEND="doc? ( dev-python/docutils )
- test? ( dev-libs/appstream-glib
- dev-libs/check )
- virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}/zathura-docutils.patch"
-)
-
-src_configure() {
- local emesonargs=(
- -Dconvert-icon=disabled
- -Dmagic=$(usex magic enabled disabled)
- -Dmanpages=$(usex doc enabled disabled)
- -Dseccomp=$(usex seccomp enabled disabled)
- -Dsqlite=$(usex sqlite enabled disabled)
- -Dsynctex=$(usex synctex enabled disabled)
- )
- meson_src_configure
-}
-
-src_test() {
- virtx meson_src_test
-}