summaryrefslogtreecommitdiff
path: root/dev-cpp/pangomm/pangomm-2.42.2-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/pangomm/pangomm-2.42.2-r2.ebuild')
-rw-r--r--dev-cpp/pangomm/pangomm-2.42.2-r2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-cpp/pangomm/pangomm-2.42.2-r2.ebuild b/dev-cpp/pangomm/pangomm-2.42.2-r2.ebuild
new file mode 100644
index 0000000..45d4050
--- /dev/null
+++ b/dev-cpp/pangomm/pangomm-2.42.2-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+inherit gnome.org meson-multilib python-any-r1
+
+DESCRIPTION="C++ interface for pango"
+HOMEPAGE="https://www.gtkmm.org"
+
+LICENSE="LGPL-2.1+"
+SLOT="1.4"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE="doc"
+
+DEPEND="
+ >=dev-cpp/cairomm-1.2.2:0[doc?,${MULTILIB_USEDEP}]
+ >=dev-cpp/glibmm-2.48.0:2[doc?,${MULTILIB_USEDEP}]
+ dev-libs/libsigc++:2[doc?,${MULTILIB_USEDEP}]
+ x11-libs/pango[${MULTILIB_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen[dot]
+ dev-lang/perl
+ dev-libs/libxslt
+ )
+ ${PYTHON_DEPS}
+"
+
+PATCHES=(
+ "${FILESDIR}/pangomm-pango-1.50.patch"
+)
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_native_use_bool doc build-documentation)
+ )
+ meson_src_configure
+}