summaryrefslogtreecommitdiff
path: root/dev-libs/libdwarf/libdwarf-0.3.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libdwarf/libdwarf-0.3.4.ebuild')
-rw-r--r--dev-libs/libdwarf/libdwarf-0.3.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/libdwarf/libdwarf-0.3.4.ebuild b/dev-libs/libdwarf/libdwarf-0.3.4.ebuild
new file mode 100644
index 0000000..ee99812
--- /dev/null
+++ b/dev-libs/libdwarf/libdwarf-0.3.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="The DWARF Debugging Information Format"
+HOMEPAGE="https://github.com/davea42/libdwarf-code"
+SRC_URI="https://github.com/davea42/libdwarf-code/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dwarfexample dwarfgen static-libs"
+
+DEPEND="
+ sys-libs/zlib
+ dwarfgen? ( virtual/libelf )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myeconfargs=(
+ --includedir="${EPREFIX}/usr/include/${PN}"
+ --enable-shared
+ $(use_enable dwarfexample)
+ $(use_enable dwarfgen)
+ $(use_enable dwarfgen libelf)
+ $(use_enable static-libs static)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}