summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtgui/Manifest1
-rw-r--r--dev-qt/qtgui/files/qt-5.12-gcc-avx2.patch29
-rw-r--r--dev-qt/qtgui/files/qtgui-5.14.1-cmake-macro-backward-compat.patch50
-rw-r--r--dev-qt/qtgui/files/qtgui-5.15.2-bogus-xcb-util-dep.patch72
-rw-r--r--dev-qt/qtgui/metadata.xml29
-rw-r--r--dev-qt/qtgui/qtgui-5.15.2-r12.ebuild183
6 files changed, 0 insertions, 364 deletions
diff --git a/dev-qt/qtgui/Manifest b/dev-qt/qtgui/Manifest
deleted file mode 100644
index a3b2a04..0000000
--- a/dev-qt/qtgui/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST qtbase-5.15.2-c2ea67ec.tar.gz 67964503 BLAKE2B 2f55d1913d840a9150912074e81b7ebc38d86dbe259a51f65924868d97ed0cd5852fd6387e85933e956b0bd80404284b9e0f01506080f154751c0e1cf27ba398 SHA512 40eeaca1698613ab0c756053b58737cbef9fceed7cf7007aec5b558f992675a25d304ec83afdc7eab34bb854149d4e0ce61f2cc03003b553b4fc8a786f258e17
diff --git a/dev-qt/qtgui/files/qt-5.12-gcc-avx2.patch b/dev-qt/qtgui/files/qt-5.12-gcc-avx2.patch
deleted file mode 100644
index 41814c0..0000000
--- a/dev-qt/qtgui/files/qt-5.12-gcc-avx2.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 3f302cb16ebfefade17b3ea90c5ed258c9150f3a Mon Sep 17 00:00:00 2001
-From: Mike Gilbert <floppym@gentoo.org>
-Date: Fri, 1 Mar 2019 21:37:52 -0500
-Subject: [PATCH] gcc: pass -mavx2 instead of -march=core-avx2
-
-Resolves a build failure when QMAKE_CXXFLAGS contains -march=native
-and the compiler is running on a CPU which does not support AVX2.
-
-Bug: https://bugs.gentoo.org/672946
----
- mkspecs/common/gcc-base.conf | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/mkspecs/common/gcc-base.conf b/mkspecs/common/gcc-base.conf
-index c2669e4833..44aa96af38 100644
---- a/mkspecs/common/gcc-base.conf
-+++ b/mkspecs/common/gcc-base.conf
-@@ -109,7 +109,7 @@ QMAKE_CFLAGS_MIPS_DSP += -mdsp
- QMAKE_CFLAGS_MIPS_DSPR2 += -mdspr2
-
- # -march=haswell is supported as of GCC 4.9 and Clang 3.6
--QMAKE_CFLAGS_ARCH_HASWELL = -march=core-avx2
-+QMAKE_CFLAGS_ARCH_HASWELL = -mavx2
-
- # Wrapper tools that understand .o/.a files with GIMPLE instead of machine code
- QMAKE_AR_LTCG = gcc-ar cqs
---
-2.21.0.rc1
-
diff --git a/dev-qt/qtgui/files/qtgui-5.14.1-cmake-macro-backward-compat.patch b/dev-qt/qtgui/files/qtgui-5.14.1-cmake-macro-backward-compat.patch
deleted file mode 100644
index 30b5abc..0000000
--- a/dev-qt/qtgui/files/qtgui-5.14.1-cmake-macro-backward-compat.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-From: Andreas Sturmlechner <asturm@gentoo.org>
-Date: Sun, 9 Feb 2020 11:45:00 +0100
-Subject: [PATCH] qtcore: Fix cmake macro compat. for upgrade from <Qt-5.14
-
-In upstream commit:
-
-https://code.qt.io/cgit/qt/qtbase.git/commit/?h=5.14&id=63d9cd17
-
-_populate_$${CMAKE_MODULE_NAME}_plugin_properties in 5.14.0 gained an additional argument
-IsDebugAndRelease without providing backward compatibility. This macro is used (at least) for
-QtGui and QtDesigner plugins added by qtimageformats, qtsvg, qtvirtualkeyboard and qtwayland.
-During upgrade from <Qt-5.14 to >=Qt-5.14, as a consequence of slot upgrade rebuilds, some
-reverse dependencies are slated for rebuild before these Qt consumers have been rebuilt and their
-cmake files regenerated, leading to cmake errors like:
-
-https://bugs.gentoo.org/703306
-https://bugs.gentoo.org/705198
-
-From mkspecs/features/create_cmake.prf:
-
-# CMAKE_DEBUG_AND_RELEASE is used to tell the _populate_$${CMAKE_MODULE_NAME}_target_properties
-# functions whether a Configuration specific generator expression needs to be added to the values
-# of INTERFACE_LINK_LIBRARIES and INTERFACE_LINK_OPTIONS. For debug_and_release builds, we do need
-# configuration specific values. For singular builds (only release or only debug), we want the
-# values to be applied regardless of the configuration.
-# This would allow on Linux and macOS (and with a recent enough version of CMake on Windows) to
-# build a Debug configuration of an application, even if Qt was built in a Release configuration.
-
-qt5-build.eclass is configuring either as 'release' or as 'debug', so we make IsDebugAndRelease
-optional and default to FALSE.
-
---- a/mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in 2020-01-23 13:37:32.000000000 +0100
-+++ b/mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in 2020-02-09 15:15:21.156219814 +0100
-@@ -538,8 +538,14 @@
-
- file(GLOB pluginTargets \"${CMAKE_CURRENT_LIST_DIR}/Qt5$${CMAKE_MODULE_NAME}_*Plugin.cmake\")
-
-- macro(_populate_$${CMAKE_MODULE_NAME}_plugin_properties Plugin Configuration PLUGIN_LOCATION
-- IsDebugAndRelease)
-+ macro(_populate_$${CMAKE_MODULE_NAME}_plugin_properties Plugin Configuration PLUGIN_LOCATION)
-+ set(IsDebugAndRelease FALSE)
-+ set (list_var ${ARGN})
-+ list(LENGTH list_var num_extra_arg)
-+ if (${num_extra_arg} GREATER 0)
-+ list(GET list_var 0 IsDebugAndRelease)
-+ endif()
-+
- set_property(TARGET Qt5::${Plugin} APPEND PROPERTY IMPORTED_CONFIGURATIONS ${Configuration})
-
- !!IF isEmpty(CMAKE_PLUGIN_DIR_IS_ABSOLUTE)
diff --git a/dev-qt/qtgui/files/qtgui-5.15.2-bogus-xcb-util-dep.patch b/dev-qt/qtgui/files/qtgui-5.15.2-bogus-xcb-util-dep.patch
deleted file mode 100644
index b7f6548..0000000
--- a/dev-qt/qtgui/files/qtgui-5.15.2-bogus-xcb-util-dep.patch
+++ /dev/null
@@ -1,72 +0,0 @@
-From 61b07d75f96d4dfb07b485b2a9bd7aed099df987 Mon Sep 17 00:00:00 2001
-From: Liang Qi <liang.qi@qt.io>
-Date: Tue, 1 Dec 2020 08:43:28 +0100
-Subject: [PATCH] Revert "xcb: add xcb-util dependency for xcb-image"
-MIME-Version: 1.0
-Content-Type: text/plain; charset=utf8
-Content-Transfer-Encoding: 8bit
-
-This reverts commit adc42bebcac764ca8de78578e3a4ac39b621bd09.
-
-adc42beb is wrong, the bug is for static build of qt with static
-xcb. It adds the explicit dependency of xcb-util 0.3.9, which is
-not available on Debian yet.
-
-Task-number: QTBUG-86287
-Fixes: QTBUG-88688
-Change-Id: Iffc821f49bdfcad3f2556951d3677c35a7682266
-Reviewed-by: Thiago Macieira <thiago.macieira@intel.com>
-Reviewed-by: Tor Arne Vestbø <tor.arne.vestbo@qt.io>
-(adapted from commit 92a57e0b016f811876ec1d62328ca8edfe452a3a)
----
- src/gui/configure.json | 14 ++------------
- 1 file changed, 2 insertions(+), 12 deletions(-)
-
-diff --git a/src/gui/configure.json b/src/gui/configure.json
-index c8c4864eca6..1f08795c57b 100644
---- a/src/gui/configure.json
-+++ b/src/gui/configure.json
-@@ -601,15 +601,6 @@
- ],
- "use": "xcb"
- },
-- "xcb_util": {
-- "label": "XCB Util >= 0.3.9",
-- "headers": "xcb/xcb_util.h",
-- "sources": [
-- { "type": "pkgConfig", "args": "xcb-util >= 0.3.9" },
-- "-lxcb-util"
-- ],
-- "use": "xcb"
-- },
- "xcb_image": {
- "label": "XCB Image >= 0.3.9",
- "headers": "xcb/xcb_image.h",
-@@ -617,7 +608,7 @@
- { "type": "pkgConfig", "args": "xcb-image >= 0.3.9" },
- "-lxcb-image"
- ],
-- "use": "xcb_shm xcb_util xcb"
-+ "use": "xcb_shm xcb"
- },
- "xcb_keysyms": {
- "label": "XCB Keysyms >= 0.3.9",
-@@ -1065,7 +1056,6 @@
- "tail": "#undef explicit",
- "include": [
- "xcb/xcb.h",
-- "xcb/xcb_util.h",
- "xcb/xcb_image.h",
- "xcb/xcb_keysyms.h",
- "xcb/randr.h",
-@@ -1097,7 +1087,7 @@
- "xcb_xkb_get_kbd_by_name_replies_key_names_value_list_sizeof(nullptr, 0, 0, 0, 0, 0, 0, 0, 0);"
- ]
- },
-- "use": "xcb_icccm xcb_util xcb_image xcb_keysyms xcb_randr xcb_render xcb_renderutil xcb_shape xcb_shm xcb_sync xcb_xfixes xcb_xinerama xcb_xkb xcb"
-+ "use": "xcb_icccm xcb_image xcb_keysyms xcb_randr xcb_render xcb_renderutil xcb_shape xcb_shm xcb_sync xcb_xfixes xcb_xinerama xcb_xkb xcb"
- },
- "x11prefix": {
- "label": "X11 prefix",
---
-2.16.3
diff --git a/dev-qt/qtgui/metadata.xml b/dev-qt/qtgui/metadata.xml
deleted file mode 100644
index cfa040f..0000000
--- a/dev-qt/qtgui/metadata.xml
+++ /dev/null
@@ -1,29 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>qt@gentoo.org</email>
- <name>Gentoo Qt Project</name>
- </maintainer>
- <use>
- <flag name="egl">Enable EGL integration</flag>
- <flag name="eglfs">Build the EGL Full Screen/Single Surface platform plugin</flag>
- <flag name="evdev">Enable support for input devices via evdev</flag>
- <flag name="ibus">Build the IBus input method plugin</flag>
- <flag name="libinput">Enable support for input devices via <pkg>dev-libs/libinput</pkg></flag>
- <flag name="tslib">Enable support for touchscreen devices via <pkg>x11-libs/tslib</pkg></flag>
- <flag name="tuio">Build plugin to receive touch events over the TUIO protocol</flag>
- <flag name="vulkan">Enable support for Vulkan</flag>
- <flag name="wayland">Provide <pkg>dev-qt/qtwayland</pkg> to ensure Qt applications can be run as Wayland clients</flag>
- <flag name="X">Build the XCB platform plugin and enable X11 integration</flag>
- </use>
- <upstream>
- <bugs-to>https://bugreports.qt.io/</bugs-to>
- <doc>https://doc.qt.io/</doc>
- </upstream>
- <slots>
- <subslots>
- Must only be used by packages that are known to use private parts of the Qt API.
- </subslots>
- </slots>
-</pkgmetadata>
diff --git a/dev-qt/qtgui/qtgui-5.15.2-r12.ebuild b/dev-qt/qtgui/qtgui-5.15.2-r12.ebuild
deleted file mode 100644
index 161da7c..0000000
--- a/dev-qt/qtgui/qtgui-5.15.2-r12.ebuild
+++ /dev/null
@@ -1,183 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-KDE_ORG_COMMIT=c2ea67ecefe049f6e9bb8f910d7f9c60319d8619
-QT5_MODULE="qtbase"
-inherit qt5-build
-
-DESCRIPTION="The GUI module and platform plugins for the Qt5 framework"
-SLOT=5/$(ver_cut 1-3) # bug 707658
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
-fi
-
-IUSE="accessibility dbus egl eglfs evdev +gif gles2-only ibus jpeg
- +libinput linuxfb +png tslib tuio +udev vnc vulkan wayland +X"
-REQUIRED_USE="
- accessibility? ( dbus X )
- eglfs? ( egl )
- ibus? ( dbus )
- libinput? ( udev )
- X? ( gles2-only? ( egl ) )
-"
-
-RDEPEND="
- dev-libs/glib:2
- ~dev-qt/qtcore-${PV}:5=
- dev-util/gtk-update-icon-cache
- media-libs/fontconfig
- >=media-libs/freetype-2.6.1:2
- >=media-libs/harfbuzz-1.6.0:=
- sys-libs/zlib:=
- dbus? ( ~dev-qt/qtdbus-${PV} )
- egl? ( media-libs/mesa[egl] )
- eglfs? (
- media-libs/mesa[gbm]
- x11-libs/libdrm
- )
- evdev? ( sys-libs/mtdev )
- gles2-only? ( media-libs/mesa[gles2] )
- !gles2-only? ( virtual/opengl )
- jpeg? ( virtual/jpeg:0 )
- libinput? (
- dev-libs/libinput:=
- >=x11-libs/libxkbcommon-0.5.0
- )
- png? ( media-libs/libpng:0= )
- tslib? ( >=x11-libs/tslib-1.21 )
- tuio? ( ~dev-qt/qtnetwork-${PV} )
- udev? ( virtual/libudev:= )
- vnc? ( ~dev-qt/qtnetwork-${PV} )
- vulkan? ( dev-util/vulkan-headers )
- X? (
- x11-libs/libICE
- x11-libs/libSM
- x11-libs/libX11
- >=x11-libs/libxcb-1.12:=[xkb]
- >=x11-libs/libxkbcommon-0.5.0[X]
- x11-libs/xcb-util-image
- x11-libs/xcb-util-keysyms
- x11-libs/xcb-util-renderutil
- x11-libs/xcb-util-wm
- )
-"
-DEPEND="${RDEPEND}
- evdev? ( sys-kernel/linux-headers )
- udev? ( sys-kernel/linux-headers )
-"
-PDEPEND="
- ibus? ( app-i18n/ibus )
- wayland? ( ~dev-qt/qtwayland-${PV} )
-"
-
-QT5_TARGET_SUBDIRS=(
- src/tools/qvkgen
- src/gui
- src/openglextensions
- src/platformheaders
- src/platformsupport
- src/plugins/generic
- src/plugins/imageformats
- src/plugins/platforms
- src/plugins/platforminputcontexts
-)
-
-QT5_GENTOO_CONFIG=(
- accessibility:accessibility-atspi-bridge
- egl:egl:
- eglfs:eglfs:
- eglfs:eglfs_egldevice:
- eglfs:eglfs_gbm:
- evdev:evdev:
- evdev:mtdev:
- :fontconfig:
- :system-freetype:FREETYPE
- !:no-freetype:
- !gif:no-gif:
- gles2-only::OPENGL_ES
- gles2-only:opengles2:OPENGL_ES_2
- !:no-gui:
- :system-harfbuzz:
- !:no-harfbuzz:
- jpeg:system-jpeg:IMAGEFORMAT_JPEG
- !jpeg:no-jpeg:
- libinput
- libinput:xkbcommon:
- :opengl
- png:png:
- png:system-png:IMAGEFORMAT_PNG
- !png:no-png:
- tslib:tslib:
- udev:libudev:
- vulkan:vulkan:
- X:xcb:
- X:xcb-glx:
- X:xcb-plugin:
- X:xcb-render:
- X:xcb-sm:
- X:xcb-xlib:
- X:xcb-xinput:
-)
-
-QT5_GENTOO_PRIVATE_CONFIG=(
- :gui
-)
-
-PATCHES=(
- "${FILESDIR}/qt-5.12-gcc-avx2.patch" # bug 672946
- "${FILESDIR}/${PN}-5.14.1-cmake-macro-backward-compat.patch" # bug 703306
-)
-
-src_prepare() {
- # don't add -O3 to CXXFLAGS, bug 549140
- sed -i -e '/CONFIG\s*+=/s/optimize_full//' src/gui/gui.pro || die
-
- # egl_x11 is activated when both egl and X are enabled
- use egl && QT5_GENTOO_CONFIG+=(X:egl_x11:) || QT5_GENTOO_CONFIG+=(egl:egl_x11:)
-
- qt_use_disable_config dbus dbus \
- src/platformsupport/themes/genericunix/genericunix.pri
-
- qt_use_disable_config tuio tuiotouch src/plugins/generic/generic.pro
-
- qt_use_disable_mod ibus dbus \
- src/plugins/platforminputcontexts/platforminputcontexts.pro
-
- use vnc || sed -i -e '/SUBDIRS += vnc/d' \
- src/plugins/platforms/platforms.pro || die
-
- qt5-build_src_prepare
-}
-
-src_configure() {
- local myconf=(
- $(usex dbus -dbus-linked '')
- $(qt_use egl)
- $(qt_use eglfs)
- $(usex eglfs '-gbm -kms' '')
- $(qt_use evdev)
- $(qt_use evdev mtdev)
- -fontconfig
- -system-freetype
- $(usex gif '' -no-gif)
- -gui
- -system-harfbuzz
- $(qt_use jpeg libjpeg system)
- $(qt_use libinput)
- $(qt_use linuxfb)
- -opengl $(usex gles2-only es2 desktop)
- $(qt_use png libpng system)
- $(qt_use tslib)
- $(qt_use udev libudev)
- $(qt_use vulkan)
- $(qt_use X xcb)
- $(usex X '-xcb-xlib -DUSE_X11' '')
- )
- if use libinput || use X; then
- myconf+=( -xkbcommon )
- fi
- qt5-build_src_configure
-}