summaryrefslogtreecommitdiff
path: root/dev-util/rr/rr-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/rr/rr-9999.ebuild')
-rw-r--r--dev-util/rr/rr-9999.ebuild73
1 files changed, 0 insertions, 73 deletions
diff --git a/dev-util/rr/rr-9999.ebuild b/dev-util/rr/rr-9999.ebuild
deleted file mode 100644
index 0f4434f..0000000
--- a/dev-util/rr/rr-9999.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8,9} )
-CMAKE_BUILD_TYPE=Release
-
-inherit cmake linux-info python-single-r1
-
-DESCRIPTION="Record and Replay Framework"
-HOMEPAGE="https://rr-project.org/"
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/mozilla/${PN}.git"
-else
- SRC_URI="https://github.com/mozilla/${PN}/archive/${PV}.tar.gz -> mozilla-${P}.tar.gz"
-fi
-
-LICENSE="MIT BSD-2"
-SLOT="0"
-KEYWORDS=""
-IUSE="multilib test"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="
- sys-libs/zlib:=
- dev-libs/capnproto:=
- ${PYTHON_DEPS}"
-RDEPEND="${DEPEND}
- sys-devel/gdb[xml]"
-# Add all the deps needed only at build/test time.
-DEPEND+="
- test? (
- $(python_gen_cond_dep '
- dev-python/pexpect[${PYTHON_MULTI_USEDEP}]
- ')
- sys-devel/gdb[xml]
- )"
-
-RESTRICT="test" # toolchain and kernel version dependent
-
-pkg_setup() {
- if use kernel_linux; then
- CONFIG_CHECK="SECCOMP"
- linux-info_pkg_setup
- fi
- python-single-r1_pkg_setup
-}
-
-src_prepare() {
- cmake_src_prepare
-
- sed -i 's:-Werror::' CMakeLists.txt || die #609192
-}
-
-src_test() {
- if has usersandbox ${FEATURES} ; then
- ewarn "Test suite fails under FEATURES=usersandbox (bug #632394). Skipping."
- return 0
- fi
-
- cmake_src_test
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_TESTS=$(usex test)
- -Ddisable32bit=$(usex !multilib) #636786
- )
-
- cmake_src_configure
-}