summaryrefslogtreecommitdiff
path: root/gui-apps/wshowkeys
diff options
context:
space:
mode:
Diffstat (limited to 'gui-apps/wshowkeys')
-rw-r--r--gui-apps/wshowkeys/metadata.xml8
-rw-r--r--gui-apps/wshowkeys/wshowkeys-9999.ebuild32
2 files changed, 40 insertions, 0 deletions
diff --git a/gui-apps/wshowkeys/metadata.xml b/gui-apps/wshowkeys/metadata.xml
new file mode 100644
index 0000000..004555a
--- /dev/null
+++ b/gui-apps/wshowkeys/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alex_y_xu@yahoo.ca</email>
+ <name>Alex Xu (Hello71)</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/gui-apps/wshowkeys/wshowkeys-9999.ebuild b/gui-apps/wshowkeys/wshowkeys-9999.ebuild
new file mode 100644
index 0000000..2d5faf6
--- /dev/null
+++ b/gui-apps/wshowkeys/wshowkeys-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit git-r3 meson
+
+DESCRIPTION="Displays keys being pressed on a Wayland session"
+HOMEPAGE="https://git.sr.ht/~sircmpwn/wshowkeys"
+EGIT_REPO_URI="https://git.sr.ht/~sircmpwn/wshowkeys"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="
+ dev-libs/libinput
+ dev-libs/wayland
+ virtual/libudev
+ x11-libs/cairo
+ x11-libs/libxkbcommon
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}
+ dev-libs/wayland-protocols
+"
+
+src_install() {
+ meson_src_install
+ fperms u+s /usr/bin/wshowkeys
+}