summaryrefslogtreecommitdiff
path: root/media-video/mpv
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/mpv')
-rw-r--r--media-video/mpv/Manifest2
-rw-r--r--media-video/mpv/files/mpv-libplacebo-3.patch84
-rw-r--r--media-video/mpv/metadata.xml31
-rw-r--r--media-video/mpv/mpv-0.33.1-r2.ebuild360
4 files changed, 0 insertions, 477 deletions
diff --git a/media-video/mpv/Manifest b/media-video/mpv/Manifest
deleted file mode 100644
index 761ee91..0000000
--- a/media-video/mpv/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST mpv-0.33.1.tar.gz 3259882 BLAKE2B 97ab101c2013ffb219d36a788020fb9fc4382d09971ac0beee42701a54667a6c766521be7b052193de4505b2117c2d47b3682ebafab46632fc40b637e0d19c04 SHA512 99d6c40d18c5cf83814b44ec6d8eade229800c5b51a734c9bbe831c3aeb95f8931124c94f6ae2360ffff62053c163bc3c55b254df021e005b350ebc3df7e952b
-DIST waf-2.0.9 103104 BLAKE2B c7e996aa49662da3ff941d076fc7e2dd23e867ade92a3b2ae07560b76d63a69e495184a1f9c76be5c51977ddb1713f9247f62e672033ecb988ac559e3a47e546 SHA512 0755170ded115b03e78a2096f197cd9fff62b5036db764153d26ce426f182ea7d7b8231cfa1a10b4a564a8480428502f3691851df66e7b83c7bca8e5fe26de7d
diff --git a/media-video/mpv/files/mpv-libplacebo-3.patch b/media-video/mpv/files/mpv-libplacebo-3.patch
deleted file mode 100644
index b684df8..0000000
--- a/media-video/mpv/files/mpv-libplacebo-3.patch
+++ /dev/null
@@ -1,84 +0,0 @@
-From 7c4465cefb27d4e0d07535d368febdf77b579566 Mon Sep 17 00:00:00 2001
-From: Niklas Haas <git@haasn.xyz>
-Date: Thu, 3 Dec 2020 08:25:23 +0100
-Subject: [PATCH] vo_gpu: placebo: update for upstream API changes
-
-The concept of sample/address modes was moved from `pl_tex` to
-`pl_desc_binding`.
-
-The `pl_tex_blit()` function also underwent an API change.
----
- video/out/placebo/ra_pl.c | 31 +++++++++++++++++++++++++++++--
- 1 file changed, 29 insertions(+), 2 deletions(-)
-
-diff --git a/video/out/placebo/ra_pl.c b/video/out/placebo/ra_pl.c
-index f8df590511d..8244acff261 100644
---- a/video/out/placebo/ra_pl.c
-+++ b/video/out/placebo/ra_pl.c
-@@ -144,8 +144,14 @@ bool mppl_wrap_tex(struct ra *ra, const struct pl_tex *pltex,
- .blit_dst = pltex->params.blit_dst,
- .host_mutable = pltex->params.host_writable,
- .downloadable = pltex->params.host_readable,
-+#if PL_API_VER >= 103
-+ // These don't exist upstream, so just pick something reasonable
-+ .src_linear = pltex->params.format->caps & PL_FMT_CAP_LINEAR,
-+ .src_repeat = false,
-+#else
- .src_linear = pltex->params.sample_mode == PL_TEX_SAMPLE_LINEAR,
- .src_repeat = pltex->params.address_mode == PL_TEX_ADDRESS_REPEAT,
-+#endif
- },
- .priv = (void *) pltex,
- };
-@@ -195,10 +201,12 @@ static struct ra_tex *tex_create_pl(struct ra *ra,
- .blit_dst = params->blit_dst || params->render_dst,
- .host_writable = params->host_mutable,
- .host_readable = params->downloadable,
-+#if PL_API_VER < 103
- .sample_mode = params->src_linear ? PL_TEX_SAMPLE_LINEAR
- : PL_TEX_SAMPLE_NEAREST,
- .address_mode = params->src_repeat ? PL_TEX_ADDRESS_REPEAT
- : PL_TEX_ADDRESS_CLAMP,
-+#endif
- .initial_data = params->initial_data,
- });
-
-@@ -399,7 +407,18 @@ static void blit_pl(struct ra *ra, struct ra_tex *dst, struct ra_tex *src,
- pldst.y1 = MPMIN(MPMAX(dst_rc->y1, 0), dst->params.h);
- }
-
-+#if PL_API_VER >= 103
-+ pl_tex_blit(get_gpu(ra), &(struct pl_tex_blit_params) {
-+ .src = src->priv,
-+ .dst = dst->priv,
-+ .src_rc = plsrc,
-+ .dst_rc = pldst,
-+ .sample_mode = src->params.src_linear ? PL_TEX_SAMPLE_LINEAR
-+ : PL_TEX_SAMPLE_NEAREST,
-+ });
-+#else
- pl_tex_blit(get_gpu(ra), dst->priv, src->priv, pldst, plsrc);
-+#endif
- }
-
- static const enum pl_var_type var_type[RA_VARTYPE_COUNT] = {
-@@ -627,9 +646,17 @@ static void renderpass_run_pl(struct ra *ra,
- struct pl_desc_binding bind;
- switch (inp->type) {
- case RA_VARTYPE_TEX:
-- case RA_VARTYPE_IMG_W:
-- bind.object = (* (struct ra_tex **) val->data)->priv;
-+ case RA_VARTYPE_IMG_W: {
-+ struct ra_tex *tex = *((struct ra_tex **) val->data);
-+ bind.object = tex->priv;
-+#if PL_API_VER >= 103
-+ bind.sample_mode = tex->params.src_linear ? PL_TEX_SAMPLE_LINEAR
-+ : PL_TEX_SAMPLE_NEAREST;
-+ bind.address_mode = tex->params.src_repeat ? PL_TEX_ADDRESS_REPEAT
-+ : PL_TEX_ADDRESS_CLAMP;
-+#endif
- break;
-+ }
- case RA_VARTYPE_BUF_RO:
- case RA_VARTYPE_BUF_RW:
- bind.object = (* (struct ra_buf **) val->data)->priv;
diff --git a/media-video/mpv/metadata.xml b/media-video/mpv/metadata.xml
deleted file mode 100644
index 4039477..0000000
--- a/media-video/mpv/metadata.xml
+++ /dev/null
@@ -1,31 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <use>
- <flag name="archive">Enable support for various archive formats via <pkg>app-arch/libarchive</pkg></flag>
- <flag name="bluray">Enable playback of Blu-ray filesystems</flag>
- <flag name="cli">Build mpv CLI player</flag>
- <flag name="cplugins">Enable C plugins support</flag>
- <flag name="cuda">Enable hardware video decoding via Nvidia CUDA</flag>
- <flag name="drm">Enable Kernel Mode Setting / Direct Rendering Manager based video output</flag>
- <flag name="egl">Enable support for various EGL-based video outputs / backends</flag>
- <flag name="gamepad">Enable gamepad input support</flag>
- <flag name="gbm">Enable Graphics Buffer Manager based EGL video backend</flag>
- <flag name="jpeg">Enable support for saving screenshots in JPEG format</flag>
- <flag name="libmpv">Build mpv shared library</flag>
- <flag name="lua">Enable Lua scripting, OSC (On Screen Controller) GUI and <pkg>net-misc/youtube-dl</pkg> hook-script</flag>
- <flag name="opengl" restrict="&lt;media-video/mpv-0.28.0">Enable the recommended 'opengl' video output</flag>
- <flag name="opengl" restrict="&gt;=media-video/mpv-0.28.0">Enable support for various OpenGL-based video backends</flag>
- <flag name="raspberry-pi">Enable support for the Raspberry Pi</flag>
- <flag name="rubberband">Enable high quality pitch correction via <pkg>media-libs/rubberband</pkg></flag>
- <flag name="sdl">Enable <pkg>media-libs/libsdl2</pkg> based video and audio outputs
- (Note: these outputs exist for compatibility reasons only, avoid if possible)</flag>
- <flag name="tools">Install extra tools: mpv_identify.sh, mpv_idet.sh, and umpv</flag>
- <flag name="uchardet">Enable subtitles charset discovery via <pkg>app-i18n/uchardet</pkg></flag>
- <flag name="vulkan">Enable support for various Vulkan-based video backends</flag>
- <flag name="zimg">Enable libzimg support (for vf_fingerprint)</flag>
- </use>
- <upstream>
- <remote-id type="github">mpv-player/mpv</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/media-video/mpv/mpv-0.33.1-r2.ebuild b/media-video/mpv/mpv-0.33.1-r2.ebuild
deleted file mode 100644
index 941c9e6..0000000
--- a/media-video/mpv/mpv-0.33.1-r2.ebuild
+++ /dev/null
@@ -1,360 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-LUA_COMPAT=( lua5-{1..2} luajit )
-PYTHON_COMPAT=( python3_{7..10} )
-PYTHON_REQ_USE='threads(+)'
-
-WAF_PV=2.0.9
-
-inherit bash-completion-r1 flag-o-matic lua-single optfeature pax-utils python-r1 toolchain-funcs waf-utils xdg-utils
-
-DESCRIPTION="Media player based on MPlayer and mplayer2"
-HOMEPAGE="https://mpv.io/ https://github.com/mpv-player/mpv"
-
-if [[ ${PV} != *9999* ]]; then
- SRC_URI="https://github.com/mpv-player/mpv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ppc ppc64 x86 ~amd64-linux"
- DOCS=( RELEASE_NOTES )
-else
- EGIT_REPO_URI="https://github.com/mpv-player/mpv.git"
- inherit git-r3
- DOCS=(); SRC_URI=""
-fi
-SRC_URI+=" https://waf.io/waf-${WAF_PV}"
-DOCS+=( README.md DOCS/{client-api,interface}-changes.rst )
-
-# See Copyright in sources and Gentoo bug 506946. Waf is BSD, libmpv is ISC.
-LICENSE="LGPL-2.1+ GPL-2+ BSD ISC"
-SLOT="0"
-IUSE="+alsa aqua archive bluray cdda +cli coreaudio cplugins cuda debug doc drm dvb
- dvd +egl gamepad gbm +iconv jack javascript jpeg lcms libcaca libmpv +lua
- openal +opengl pulseaudio raspberry-pi rubberband sdl
- selinux test tools +uchardet vaapi vdpau vulkan wayland +X +xv zlib zimg"
-
-REQUIRED_USE="
- || ( cli libmpv )
- aqua? ( opengl )
- cuda? ( opengl )
- egl? ( || ( gbm X wayland ) )
- gamepad? ( sdl )
- gbm? ( drm egl opengl )
- lcms? ( opengl )
- lua? ( ${LUA_REQUIRED_USE} )
- opengl? ( || ( aqua egl X raspberry-pi !cli ) )
- raspberry-pi? ( opengl )
- test? ( opengl )
- tools? ( cli )
- uchardet? ( iconv )
- vaapi? ( || ( gbm X wayland ) )
- vdpau? ( X )
- vulkan? ( || ( X wayland ) )
- wayland? ( egl )
- X? ( egl? ( opengl ) )
- xv? ( X )
- ${PYTHON_REQUIRED_USE}
-"
-
-RESTRICT="!test? ( test )"
-
-COMMON_DEPEND="
- >=media-video/ffmpeg-4.0:0=[encode,threads,vaapi?,vdpau?]
- alsa? ( >=media-libs/alsa-lib-1.0.18 )
- archive? ( >=app-arch/libarchive-3.4.0:= )
- bluray? ( >=media-libs/libbluray-0.3.0:= )
- cdda? ( dev-libs/libcdio-paranoia
- dev-libs/libcdio:= )
- drm? ( x11-libs/libdrm )
- dvd? (
- >=media-libs/libdvdnav-4.2.0:=
- >=media-libs/libdvdread-4.1.0:=
- )
- egl? ( media-libs/mesa[egl,gbm(-)?,wayland(-)?] )
- gamepad? ( media-libs/libsdl2 )
- iconv? (
- virtual/libiconv
- uchardet? ( app-i18n/uchardet )
- )
- jack? ( virtual/jack )
- javascript? ( >=dev-lang/mujs-1.0.0 )
- jpeg? ( virtual/jpeg:0 )
- lcms? ( >=media-libs/lcms-2.6:2 )
- >=media-libs/libass-0.12.1:=[fontconfig,harfbuzz(+)]
- virtual/ttf-fonts
- libcaca? ( >=media-libs/libcaca-0.99_beta18 )
- lua? ( ${LUA_DEPS} )
- openal? ( >=media-libs/openal-1.13 )
- pulseaudio? ( media-sound/pulseaudio )
- raspberry-pi? ( >=media-libs/raspberrypi-userland-0_pre20160305-r1 )
- rubberband? ( >=media-libs/rubberband-1.8.0 )
- sdl? ( media-libs/libsdl2[sound,threads,video] )
- vaapi? ( x11-libs/libva:=[drm?,X?,wayland?] )
- vdpau? ( x11-libs/libvdpau )
- vulkan? (
- >=media-libs/libplacebo-2.72.2:=[vulkan]
- media-libs/shaderc
- )
- wayland? (
- >=dev-libs/wayland-1.6.0
- >=dev-libs/wayland-protocols-1.14
- >=x11-libs/libxkbcommon-0.3.0
- )
- X? (
- x11-libs/libX11
- x11-libs/libXScrnSaver
- x11-libs/libXext
- x11-libs/libXinerama
- x11-libs/libXrandr
- opengl? (
- x11-libs/libXdamage
- virtual/opengl
- )
- xv? ( x11-libs/libXv )
- )
- zlib? ( sys-libs/zlib )
- zimg? ( >=media-libs/zimg-2.9.2 )
-"
-DEPEND="${COMMON_DEPEND}
- ${PYTHON_DEPS}
- cuda? ( >=media-libs/nv-codec-headers-8.2.15.7 )
- dvb? ( virtual/linuxtv-dvb-headers )
-"
-RDEPEND="${COMMON_DEPEND}
- cuda? ( x11-drivers/nvidia-drivers[X] )
- selinux? ( sec-policy/selinux-mplayer )
- tools? ( ${PYTHON_DEPS} )
-"
-BDEPEND="dev-python/docutils
- virtual/pkgconfig
- test? ( >=dev-util/cmocka-1.0.0 )
-"
-
-PATCHES=( "${FILESDIR}/mpv-libplacebo-3.patch" )
-
-pkg_setup() {
- use lua && lua-single_pkg_setup
-}
-
-src_prepare() {
- cp "${DISTDIR}/waf-${WAF_PV}" "${S}"/waf || die
- chmod +x "${S}"/waf || die
- default
-}
-
-src_configure() {
- python_setup
- tc-export CC PKG_CONFIG AR
-
- if use raspberry-pi; then
- append-cflags -I"${SYSROOT%/}${EPREFIX}/opt/vc/include"
- append-ldflags -L"${SYSROOT%/}${EPREFIX}/opt/vc/lib"
- fi
-
- local mywafargs=(
- --confdir="${EPREFIX}/etc/${PN}"
-
- $(usex cli '' '--disable-cplayer')
- $(use_enable libmpv libmpv-shared)
-
- --disable-libmpv-static
- --disable-static-build
- # See deep down below for build-date.
- --disable-optimize # Don't add '-O2' to CFLAGS.
- $(usex debug '' '--disable-debug-build')
-
- $(use_enable doc html-build)
- --disable-pdf-build
- --enable-manpage-build
- $(use_enable cplugins)
- $(use_enable test)
-
- $(use_enable iconv)
- $(use_enable lua)
- $(use_enable javascript)
- $(use_enable zlib)
- $(use_enable bluray libbluray)
- $(use_enable dvd dvdnav)
- $(use_enable cdda)
- $(use_enable uchardet)
- $(use_enable rubberband)
- $(use_enable lcms lcms2)
- --disable-vapoursynth # Only available in overlays.
- $(use_enable archive libarchive)
-
- --enable-libavdevice
-
- # Audio outputs:
- $(use_enable sdl sdl2) # Listed under audio, but also includes video.
- $(use_enable pulseaudio pulse)
- $(use_enable jack)
- $(use_enable openal)
- --disable-opensles
- $(use_enable alsa)
- $(use_enable coreaudio)
-
- # Video outputs:
- $(use_enable aqua cocoa)
- $(use_enable drm)
- $(use_enable gbm)
- $(use_enable wayland wayland-scanner)
- $(use_enable wayland wayland-protocols)
- $(use_enable wayland)
- $(use_enable X x11)
- $(use_enable xv)
- $(usex opengl "$(use_enable aqua gl-cocoa)" '--disable-gl-cocoa')
- $(usex opengl "$(use_enable X gl-x11)" '--disable-gl-x11')
- $(usex egl "$(use_enable X egl-x11)" '--disable-egl-x11')
- $(usex egl "$(use_enable gbm egl-drm)" '--disable-egl-drm')
- $(usex opengl "$(use_enable wayland gl-wayland)" '--disable-gl-wayland')
- $(use_enable vdpau)
- $(usex vdpau "$(use_enable opengl vdpau-gl-x11)" '--disable-vdpau-gl-x11')
- $(use_enable vaapi) # See below for vaapi-glx, vaapi-x-egl.
- $(usex vaapi "$(use_enable X vaapi-x11)" '--disable-vaapi-x11')
- $(usex vaapi "$(use_enable wayland vaapi-wayland)" '--disable-vaapi-wayland')
- $(usex vaapi "$(use_enable gbm vaapi-drm)" '--disable-vaapi-drm')
- $(use_enable libcaca caca)
- $(use_enable jpeg)
- $(use_enable vulkan shaderc)
- $(use_enable vulkan libplacebo)
- $(use_enable raspberry-pi rpi)
- $(usex libmpv "$(use_enable opengl plain-gl)" '--disable-plain-gl')
- $(usex opengl '' '--disable-gl')
- $(use_enable vulkan)
- $(use_enable gamepad sdl2-gamepad)
-
- # HWaccels:
- # Automagic Video Toolbox HW acceleration. See Gentoo bug 577332.
- $(use_enable cuda cuda-hwaccel)
- $(use_enable cuda cuda-interop)
-
- # TV features:
- $(use_enable dvb dvbin)
-
- # Miscellaneous features:
- $(use_enable zimg)
- )
- if use lua; then
- if use lua_single_target_luajit; then
- mywafargs+=( --lua="luajit" )
- else
- # Because it would be too simple to just let the user directly
- # specify the package name to check, wouldn't it.
- mywafargs+=( --lua="$(ver_rs 1 '' $(ver_cut 1-2 $(lua_get_version)))" )
- fi
- fi
-
- if use vaapi && use X; then
- mywafargs+=(
- $(use_enable egl vaapi-x-egl)
- )
- fi
-
- # Not for us
- mywafargs+=(
- --disable-android
- --disable-egl-android
- --disable-uwp
- --disable-audiounit
- --disable-macos-media-player
- --disable-wasapi
- --disable-ios-gl
- --disable-macos-touchbar
- --disable-macos-cocoa-cb
- --disable-tvos
- --disable-egl-angle-win32
- )
-
- mywafargs+=(
- --bashdir="$(get_bashcompdir)"
- --zshdir="${EPREFIX}"/usr/share/zsh/site-functions
-)
-
- # Create reproducible non-live builds.
- [[ ${PV} != *9999* ]] && mywafargs+=(--disable-build-date)
-
- waf-utils_src_configure "${mywafargs[@]}"
-}
-
-src_install() {
- waf-utils_src_install
-
- if use lua; then
- insinto /usr/share/${PN}
- doins -r TOOLS/lua
- fi
-
- if use cli && use lua_single_target_luajit; then
- pax-mark -m "${ED}"/usr/bin/${PN}
- fi
-
- if use tools; then
- dobin TOOLS/{mpv_identify.sh,umpv}
- newbin TOOLS/idet.sh mpv_idet.sh
- python_replicate_script "${ED}"/usr/bin/umpv
- fi
-}
-
-pkg_postinst() {
- local rv softvol_0_18_1=0 osc_0_21_0=0 txtsubs_0_24_0=0 opengl_0_25_0=0
-
- for rv in ${REPLACING_VERSIONS}; do
- ver_test ${rv} -lt 0.18.1 && softvol_0_18_1=1
- ver_test ${rv} -lt 0.21.0 && osc_0_21_0=1
- ver_test ${rv} -lt 0.24.0 && txtsubs_0_24_0=1
- ver_test ${rv} -lt 0.25.0 && ! use opengl && opengl_0_25_0=1
- done
-
- if [[ ${softvol_0_18_1} -eq 1 ]]; then
- elog "Since version 0.18.1 the software volume control is always enabled."
- elog "This means that volume controls don't change the system volume,"
- elog "e.g. per-application volume with PulseAudio."
- elog "If you want to restore the previous behaviour, please refer to"
- elog
- elog "https://wiki.gentoo.org/wiki/Mpv#Volume_in_0.18.1"
- elog
- fi
-
- if [[ ${osc_0_21_0} -eq 1 ]]; then
- elog "In version 0.21.0 the default OSC layout was changed."
- elog "If you want to restore the previous layout, please refer to"
- elog
- elog "https://wiki.gentoo.org/wiki/Mpv#OSC_in_0.21.0"
- elog
- fi
-
- if [[ ${txtsubs_0_24_0} -eq 1 ]]; then
- elog "Since version 0.24.0 subtitles with .txt extension aren't autoloaded."
- elog "If you want to restore the previous behaviour, please refer to"
- elog
- elog "https://wiki.gentoo.org/wiki/Mpv#Subtitles_with_.txt_extension_in_0.24.0"
- elog
- fi
-
- if [[ ${opengl_0_25_0} -eq 1 ]]; then
- elog "Since version 0.25.0 the 'opengl' USE flag is mapped to"
- elog "the 'opengl' video output and no longer explicitly requires"
- elog "X11 or Mac OS Aqua. Consider enabling the 'opengl' USE flag."
- fi
-
- optfeature "URL support" net-misc/youtube-dl
-
- xdg_icon_cache_update
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
- xdg_desktop_database_update
-}
-
-src_test() {
- cd "${S}"/build/test || die
- local test
- for test in *; do
- if [[ -x ${test} ]]; then
- ./"${test}" || die "Test suite failed"
- fi
- done
-}