summaryrefslogtreecommitdiff
path: root/net-misc/wayvnc
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/wayvnc')
-rw-r--r--net-misc/wayvnc/metadata.xml8
-rw-r--r--net-misc/wayvnc/wayvnc-9999.ebuild31
2 files changed, 39 insertions, 0 deletions
diff --git a/net-misc/wayvnc/metadata.xml b/net-misc/wayvnc/metadata.xml
new file mode 100644
index 0000000..004555a
--- /dev/null
+++ b/net-misc/wayvnc/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alex_y_xu@yahoo.ca</email>
+ <name>Alex Xu (Hello71)</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-misc/wayvnc/wayvnc-9999.ebuild b/net-misc/wayvnc/wayvnc-9999.ebuild
new file mode 100644
index 0000000..a09e5dc
--- /dev/null
+++ b/net-misc/wayvnc/wayvnc-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="A VNC server for wlroots based Wayland compositors"
+HOMEPAGE="https://github.com/any1/wayvnc"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/any1/wayvnc.git"
+else
+ SRC_URI="https://github.com/any1/wayvnc/archive/v${PV}.tar.gz"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS=""
+IUSE="examples"
+
+DEPEND="
+ dev-libs/aml
+ dev-libs/wayland
+ net-libs/neatvnc
+ virtual/opengl
+ x11-libs/libxkbcommon
+ x11-libs/pixman
+"
+RDEPEND="${DEPEND}"
+BDEPEND="dev-libs/wayland"