summaryrefslogtreecommitdiff
path: root/sys-boot/limine
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/limine')
-rw-r--r--sys-boot/limine/Manifest1
-rw-r--r--sys-boot/limine/limine-8.0.13.ebuild47
-rw-r--r--sys-boot/limine/metadata.xml27
3 files changed, 75 insertions, 0 deletions
diff --git a/sys-boot/limine/Manifest b/sys-boot/limine/Manifest
new file mode 100644
index 0000000..515aa98
--- /dev/null
+++ b/sys-boot/limine/Manifest
@@ -0,0 +1 @@
+DIST limine-8.0.13.tar.xz 407784 BLAKE2B 2722b6a644766b181bb456605a16fb957eecfa2808303443fc890b28074bfe11961f8f3ffa904c890b867ad7c4eca105bb6d727a98d405c075ad603ecea2e011 SHA512 116082e74e15a1f2cc0e13a14b215929902589da08ff2dc8617de1a87e9ae9ba9fe81f6e40f56f00860841034feac93609601fc2557df25ee602d71933784be3
diff --git a/sys-boot/limine/limine-8.0.13.ebuild b/sys-boot/limine/limine-8.0.13.ebuild
new file mode 100644
index 0000000..5d41343
--- /dev/null
+++ b/sys-boot/limine/limine-8.0.13.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Limine is a modern, advanced, and portable BIOS/UEFI multiprotocol bootloader"
+HOMEPAGE="https://limine-bootloader.org/"
+SRC_URI="https://github.com/limine-bootloader/limine/releases/download/v${PV}/limine-${PV}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="abi_x86_32 abi_x86_64 bios bios-pxe bios-cd uefi uefi-cd"
+
+BDEPEND="
+ app-alternatives/gzip
+ dev-lang/nasm
+ sys-apps/findutils
+ uefi-cd? ( sys-fs/mtools )
+"
+
+REQUIRED_USE="
+ bios? ( || ( amd64 x86 ) )
+ bios-cd? ( || ( amd64 x86 ) )
+ bios-pxe? ( || ( amd64 x86 ) )
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable bios)
+ $(use_enable bios-cd)
+ $(use_enable bios-pxe)
+
+ $(use_enable uefi-cd)
+ )
+
+ if use uefi; then
+ myconf+=(
+ $(use_enable abi_x86_32 uefi-ia32)
+ $(use_enable abi_x86_64 uefi-x86-64)
+ $(use_enable arm64 uefi-aarch64)
+ $(use_enable riscv uefi-riscv64)
+ )
+ fi
+
+ econf "${myconf[@]}"
+}
diff --git a/sys-boot/limine/metadata.xml b/sys-boot/limine/metadata.xml
new file mode 100644
index 0000000..6b13f02
--- /dev/null
+++ b/sys-boot/limine/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>arsen@gentoo.org</email>
+ <name>Arsen Arsenović</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">limine-bootloader/limine</remote-id>
+ </upstream>
+ <use>
+ <flag name="uefi-cd">
+ Enable building cd-efi.bin using <pkg>sys-fs/mtools</pkg>.
+ This flag was previously known as eltorito-efi.
+ </flag>
+
+ <flag name="bios">
+ Enable BIOS/MBR boot support.
+ </flag>
+ <flag name="bios-pxe">
+ Enables BIOS PXE boot support.
+ </flag>
+ <flag name="bios-cd">
+ Enables BIOS boot support for CDs.
+ </flag>
+ </use>
+</pkgmetadata>