summaryrefslogtreecommitdiff
path: root/x11-base/xorg-server/xorg-server-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-base/xorg-server/xorg-server-9999.ebuild')
-rw-r--r--x11-base/xorg-server/xorg-server-9999.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/x11-base/xorg-server/xorg-server-9999.ebuild b/x11-base/xorg-server/xorg-server-9999.ebuild
index 99a8c50..f3daeac 100644
--- a/x11-base/xorg-server/xorg-server-9999.ebuild
+++ b/x11-base/xorg-server/xorg-server-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -11,7 +11,7 @@ EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/xserver.git"
DESCRIPTION="X.Org X servers"
SLOT="0/${PV}"
if [[ ${PV} != 9999* ]]; then
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
fi
IUSE_SERVERS="dmx kdrive wayland xephyr xnest xorg xvfb"
@@ -74,6 +74,7 @@ CDEPEND="
>=media-libs/libepoxy-1.5.4[egl(+)]
>=dev-libs/wayland-protocols-1.18
)
+ >=x11-apps/xinit-1.3.3-r1
systemd? (
sys-apps/dbus
sys-apps/systemd
@@ -83,7 +84,7 @@ CDEPEND="
sys-auth/elogind[pam]
sys-auth/pambase[elogind]
)
- !!x11-drivers/nvidia-drivers[-libglvnd(-)]
+ !!x11-drivers/nvidia-drivers[-libglvnd(+)]
"
DEPEND="${CDEPEND}
@@ -100,6 +101,7 @@ DEPEND="${CDEPEND}
)"
RDEPEND="${CDEPEND}
+ !systemd? ( gui-libs/display-manager-init )
selinux? ( sec-policy/selinux-xserver )
"
@@ -197,10 +199,6 @@ src_install() {
dodoc "${S}"/hw/xfree86/xorg.conf.example
fi
- newinitd "${FILESDIR}"/xdm-setup.initd-1 xdm-setup
- newinitd "${FILESDIR}"/xdm.initd-11 xdm
- newconfd "${FILESDIR}"/xdm.confd-4 xdm
-
# install the @x11-module-rebuild set for Portage
insinto /usr/share/portage/config/sets
newins "${FILESDIR}"/xorg-sets.conf xorg.conf