summaryrefslogtreecommitdiff
path: root/x11-base/xorg-server/xorg-server-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-base/xorg-server/xorg-server-9999.ebuild')
-rw-r--r--x11-base/xorg-server/xorg-server-9999.ebuild58
1 files changed, 31 insertions, 27 deletions
diff --git a/x11-base/xorg-server/xorg-server-9999.ebuild b/x11-base/xorg-server/xorg-server-9999.ebuild
index f3daeac..8b95982 100644
--- a/x11-base/xorg-server/xorg-server-9999.ebuild
+++ b/x11-base/xorg-server/xorg-server-9999.ebuild
@@ -15,15 +15,14 @@ if [[ ${PV} != 9999* ]]; then
fi
IUSE_SERVERS="dmx kdrive wayland xephyr xnest xorg xvfb"
-IUSE="${IUSE_SERVERS} debug +elogind ipv6 libressl minimal selinux suid systemd +udev unwind xcsecurity"
+IUSE="${IUSE_SERVERS} debug +elogind ipv6 minimal selinux suid systemd test +udev unwind xcsecurity"
+RESTRICT="!test? ( test )"
CDEPEND="
media-libs/libglvnd[X]
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
+ dev-libs/openssl:0=
>=x11-apps/iceauth-1.0.2
>=x11-apps/rgb-1.0.3
- >=x11-apps/xauth-1.0.3
x11-apps/xkbcomp
>=x11-libs/libdrm-2.4.89
>=x11-libs/libpciaccess-0.12.901
@@ -33,7 +32,6 @@ CDEPEND="
>=x11-libs/libxkbfile-1.0.4
>=x11-libs/libxshmfence-1.1
>=x11-libs/pixman-0.27.2
- >=x11-libs/xtrans-1.3.5
>=x11-misc/xbitmaps-1.0.1
>=x11-misc/xkeyboard-config-2.4.1-r3
dmx? (
@@ -74,7 +72,6 @@ CDEPEND="
>=media-libs/libepoxy-1.5.4[egl(+)]
>=dev-libs/wayland-protocols-1.18
)
- >=x11-apps/xinit-1.3.3-r1
systemd? (
sys-apps/dbus
sys-apps/systemd
@@ -86,10 +83,9 @@ CDEPEND="
)
!!x11-drivers/nvidia-drivers[-libglvnd(+)]
"
-
DEPEND="${CDEPEND}
- sys-devel/flex
>=x11-base/xorg-proto-2018.4
+ >=x11-libs/xtrans-1.3.5
dmx? (
doc? (
|| (
@@ -98,13 +94,16 @@ DEPEND="${CDEPEND}
www-client/w3m
)
)
- )"
-
+ )
+"
RDEPEND="${CDEPEND}
!systemd? ( gui-libs/display-manager-init )
selinux? ( sec-policy/selinux-xserver )
"
-
+BDEPEND="
+ sys-devel/flex
+ wayland? ( dev-util/wayland-scanner )
+"
PDEPEND="
xorg? ( >=x11-base/xorg-drivers-$(ver_cut 1-2) )"
@@ -132,17 +131,20 @@ pkg_setup() {
ewarn "Performance may be unacceptable without it."
ewarn "Build with USE=-minimal to enable glamor."
fi
+}
+src_configure() {
# localstatedir is used for the log location; we need to override the default
# from ebuild.sh
# sysconfdir is used for the xorg.conf location; same applies
# NOTE: fop is used for doc generating; and I have no idea if Gentoo
# package it somewhere
- XORG_CONFIGURE_OPTIONS=(
+ local XORG_CONFIGURE_OPTIONS=(
$(use_enable ipv6)
$(use_enable debug)
$(use_enable dmx)
$(use_enable kdrive)
+ $(use_enable test unit-tests)
$(use_enable unwind libunwind)
$(use_enable wayland xwayland)
$(use_enable !minimal record)
@@ -176,17 +178,28 @@ pkg_setup() {
if use systemd || use elogind; then
XORG_CONFIGURE_OPTIONS+=(
- "--enable-systemd-logind"
- "--disable-install-setuid"
- "$(use_enable suid suid-wrapper)"
+ --enable-systemd-logind
+ --disable-install-setuid
+ $(use_enable suid suid-wrapper)
)
else
XORG_CONFIGURE_OPTIONS+=(
- "--disable-systemd-logind"
- "--disable-suid-wrapper"
- "$(use_enable suid install-setuid)"
+ --disable-systemd-logind
+ --disable-suid-wrapper
+ $(use_enable suid install-setuid)
)
fi
+
+ xorg-3_src_configure
+}
+
+server_based_install() {
+ if ! use xorg; then
+ rm -f "${ED}"/usr/share/man/man1/Xserver.1x \
+ "${ED}"/usr/$(get_libdir)/xserver/SecurityPolicy \
+ "${ED}"/usr/$(get_libdir)/pkgconfig/xorg-server.pc \
+ "${ED}"/usr/share/man/man1/Xserver.1x || die
+ fi
}
src_install() {
@@ -212,12 +225,3 @@ pkg_postrm() {
rm -rf "${EROOT}"/usr/$(get_libdir)/xorg/modules
fi
}
-
-server_based_install() {
- if ! use xorg; then
- rm "${ED}"/usr/share/man/man1/Xserver.1x \
- "${ED}"/usr/$(get_libdir)/xserver/SecurityPolicy \
- "${ED}"/usr/$(get_libdir)/pkgconfig/xorg-server.pc \
- "${ED}"/usr/share/man/man1/Xserver.1x
- fi
-}