summaryrefslogtreecommitdiff
path: root/x11-libs/cairo/files
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/cairo/files')
-rw-r--r--x11-libs/cairo/files/cairo-1.12.18-disable-test-suite.patch15
-rw-r--r--x11-libs/cairo/files/cairo-1.16.0-binutils-2.34.patch20
-rw-r--r--x11-libs/cairo/files/cairo-1.16.0-ft-Use-FT_Done_MM_Var-instead-of-free-when-available.patch30
-rw-r--r--x11-libs/cairo/files/cairo-1.16.0-pdf-add-missing-flush.patch29
-rw-r--r--x11-libs/cairo/files/cairo-1.16.0-strings.patch19
-rw-r--r--x11-libs/cairo/files/cairo-respect-fontconfig.patch13
6 files changed, 126 insertions, 0 deletions
diff --git a/x11-libs/cairo/files/cairo-1.12.18-disable-test-suite.patch b/x11-libs/cairo/files/cairo-1.12.18-disable-test-suite.patch
new file mode 100644
index 0000000..6822121
--- /dev/null
+++ b/x11-libs/cairo/files/cairo-1.12.18-disable-test-suite.patch
@@ -0,0 +1,15 @@
+diff --git a/Makefile.am b/Makefile.am
+index 03fa352..7e11d24 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -18,10 +18,6 @@ ACLOCAL_AMFLAGS = -I build ${ACLOCAL_FLAGS}
+
+ DIST_SUBDIRS = src doc util boilerplate test perf
+ SUBDIRS = src doc util
+-# libpng is required for our test programs
+-if CAIRO_HAS_PNG_FUNCTIONS
+-SUBDIRS += boilerplate test perf
+-endif
+
+ configure: cairo-version.h
+
diff --git a/x11-libs/cairo/files/cairo-1.16.0-binutils-2.34.patch b/x11-libs/cairo/files/cairo-1.16.0-binutils-2.34.patch
new file mode 100644
index 0000000..03daac0
--- /dev/null
+++ b/x11-libs/cairo/files/cairo-1.16.0-binutils-2.34.patch
@@ -0,0 +1,20 @@
+--- a/util/cairo-trace/lookup-symbol.c
++++ b/util/cairo-trace/lookup-symbol.c
+@@ -145,14 +145,14 @@ find_address_in_section (bfd *abfd,
+ if (symbol->found)
+ return;
+
+- if ((bfd_get_section_flags (symtab->bfd, section) & SEC_ALLOC) == 0)
++ if ((bfd_section_flags (section) & SEC_ALLOC) == 0)
+ return;
+
+- vma = bfd_get_section_vma (symtab->bfd, section);
++ vma = bfd_section_vma (section);
+ if (symbol->pc < vma)
+ return;
+
+- size = bfd_section_size (symtab->bfd, section);
++ size = bfd_section_size (section);
+ if (symbol->pc >= vma + size)
+ return;
+
diff --git a/x11-libs/cairo/files/cairo-1.16.0-ft-Use-FT_Done_MM_Var-instead-of-free-when-available.patch b/x11-libs/cairo/files/cairo-1.16.0-ft-Use-FT_Done_MM_Var-instead-of-free-when-available.patch
new file mode 100644
index 0000000..3709c5a
--- /dev/null
+++ b/x11-libs/cairo/files/cairo-1.16.0-ft-Use-FT_Done_MM_Var-instead-of-free-when-available.patch
@@ -0,0 +1,30 @@
+From 90e85c2493fdfa3551f202ff10282463f1e36645 Mon Sep 17 00:00:00 2001
+From: Carlos Garcia Campos <cgarcia@igalia.com>
+Date: Mon, 19 Nov 2018 12:33:07 +0100
+Subject: [PATCH] ft: Use FT_Done_MM_Var instead of free when available in
+ cairo_ft_apply_variations
+
+Fixes a crash when using freetype >= 2.9
+---
+ src/cairo-ft-font.c | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/src/cairo-ft-font.c b/src/cairo-ft-font.c
+index 325dd61b4..981973f78 100644
+--- a/src/cairo-ft-font.c
++++ b/src/cairo-ft-font.c
+@@ -2393,7 +2393,11 @@ skip:
+ done:
+ free (coords);
+ free (current_coords);
++#if HAVE_FT_DONE_MM_VAR
++ FT_Done_MM_Var (face->glyph->library, ft_mm_var);
++#else
+ free (ft_mm_var);
++#endif
+ }
+ }
+
+--
+2.19.2
+
diff --git a/x11-libs/cairo/files/cairo-1.16.0-pdf-add-missing-flush.patch b/x11-libs/cairo/files/cairo-1.16.0-pdf-add-missing-flush.patch
new file mode 100644
index 0000000..19345f1
--- /dev/null
+++ b/x11-libs/cairo/files/cairo-1.16.0-pdf-add-missing-flush.patch
@@ -0,0 +1,29 @@
+From 4c8813f0eaacc32c27126ad2296951a626300b89 Mon Sep 17 00:00:00 2001
+From: Adrian Johnson <ajohnson@redneon.com>
+Date: Thu, 25 Oct 2018 18:46:17 +1030
+Subject: [PATCH] pdf: add missing flush
+
+Issue #342
+---
+ src/cairo-pdf-surface.c | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/src/cairo-pdf-surface.c b/src/cairo-pdf-surface.c
+index 7eb61aa1e..939b2d2d7 100644
+--- a/src/cairo-pdf-surface.c
++++ b/src/cairo-pdf-surface.c
+@@ -7711,6 +7711,11 @@ _cairo_pdf_surface_mask (void *abstract_surface,
+ * and most common, case to handle. */
+ if (_cairo_pattern_is_constant_alpha (mask, &extents.bounded, &alpha) &&
+ _can_paint_pattern (source)) {
++
++ status = _cairo_pdf_operators_flush (&surface->pdf_operators);
++ if (unlikely (status))
++ goto cleanup;
++
+ _cairo_output_stream_printf (surface->output, "q\n");
+ status = _cairo_pdf_surface_paint_pattern (surface,
+ op,
+--
+2.19.2
+
diff --git a/x11-libs/cairo/files/cairo-1.16.0-strings.patch b/x11-libs/cairo/files/cairo-1.16.0-strings.patch
new file mode 100644
index 0000000..ee72f9d
--- /dev/null
+++ b/x11-libs/cairo/files/cairo-1.16.0-strings.patch
@@ -0,0 +1,19 @@
+https://bugs.gentoo.org/726200
+--- a/build/aclocal.float.m4
++++ b/build/aclocal.float.m4
+@@ -31,10 +31,13 @@ int main() { return 0; }
+
+ ]])], [
+
+-if strings -a conftest$ac_exeext | grep noonsees >/dev/null ; then
++# allow users to override default 'strings' with 'llvm-strings'
++# or ${CHOST}-strings.
++AC_CHECK_TOOL(STRINGS, strings)
++if $STRINGS -a conftest$ac_exeext | grep noonsees >/dev/null ; then
+ ax_cv_c_float_words_bigendian=yes
+ fi
+-if strings -a conftest$ac_exeext | grep seesnoon >/dev/null ; then
++if $STRINGS -a conftest$ac_exeext | grep seesnoon >/dev/null ; then
+ if test "$ax_cv_c_float_words_bigendian" = unknown; then
+ ax_cv_c_float_words_bigendian=no
+ else
diff --git a/x11-libs/cairo/files/cairo-respect-fontconfig.patch b/x11-libs/cairo/files/cairo-respect-fontconfig.patch
new file mode 100644
index 0000000..b0a1b29
--- /dev/null
+++ b/x11-libs/cairo/files/cairo-respect-fontconfig.patch
@@ -0,0 +1,13 @@
+--- cairo-1.7.6-orig/src/cairo-ft-font.c 2008-09-29 21:43:13.000000000 +0100
++++ cairo-1.7.6/src/cairo-ft-font.c 2008-09-29 21:52:19.000000000 +0100
+@@ -1705,7 +1705,9 @@
+ options->base.subpixel_order = other->base.subpixel_order;
+ }
+
+- if (options->base.hint_style == CAIRO_HINT_STYLE_DEFAULT)
++ options->base.hint_style = CAIRO_HINT_STYLE_DEFAULT;
++
++ if (other->base.hint_style != CAIRO_HINT_STYLE_DEFAULT)
+ options->base.hint_style = other->base.hint_style;
+
+ if (other->base.hint_style == CAIRO_HINT_STYLE_NONE)