summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2018-08-08 22:53:03 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2018-08-08 22:53:03 -0400
commit75b4f9e76ed827bbe10a12f87eb34c744bf829b4 (patch)
tree813f4715d540d381f4fc1e050e29bb5575a4a8c4 /configure.ac
parentc076dcdfcf8e69b26e44c8a71297769743eb0f4e (diff)
downloadrandom-seed-75b4f9e76ed827bbe10a12f87eb34c744bf829b4.tar.xz
random-seed-75b4f9e76ed827bbe10a12f87eb34c744bf829b4.zip
random-seed.c cleanups, add default seed path
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a624294..51397a3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -37,4 +37,13 @@ AS_IF([test -n "$machine_id"],
]
)
+AC_ARG_WITH([default-seed-path],
+ AC_HELP_STRING(--with-default-seed-path, [default seed path if no command line argument [/var/lib/random-seed]]),
+ [default_seed_path=$withval],
+ [default_seed_path=/var/lib/random-seed])
+AC_DEFINE_UNQUOTED(DEFAULT_SEED_PATH, "$default_seed_path", [default seed path])
+# assume people will not specify default_seed_path=/
+default_seed_path_dir=${default_seed_path%/*}
+AC_SUBST(default_seed_path_dir)
+
AC_OUTPUT(Makefile)