summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2018-08-15 19:39:45 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2018-08-15 19:39:45 -0400
commitd0eb997ee9f9889f184d0d52397b49a7f0dee009 (patch)
tree1d0d9ed7d2cf865e9bab5960e5ee1ac194ae8eb8 /configure.ac
parent39e07e62f471cbf40503cdc1926da6fef0cc0a3e (diff)
downloadrandom-seed-d0eb997ee9f9889f184d0d52397b49a7f0dee009.tar.xz
random-seed-d0eb997ee9f9889f184d0d52397b49a7f0dee009.zip
Stuff.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index e157917..5db95ac 100644
--- a/configure.ac
+++ b/configure.ac
@@ -14,8 +14,6 @@ AS_IF([test "$ac_cv_prog_cc_c99" = no],
CPPFLAGS="${CPPFLAGS+$CPPFLAGS }-D_GNU_SOURCE -D_DEFAULT_SOURCE -D_POSIX_C_SOURCE=200809L"
-PKG_CHECK_VAR(systemdsystemunitdir, systemd, systemdsystemunitdir)
-
AC_ARG_ENABLE(debug,
AC_HELP_STRING(--enable-debug, [enable debug output [no]]),
[enable_debug=$enableval],
@@ -49,8 +47,10 @@ AC_DEFINE_UNQUOTED(DEFAULT_SEED_PATH, "$default_seed_path", [default seed path])
default_seed_path_dir=${default_seed_path%/*}
AC_SUBST(default_seed_path_dir)
-AX_CHECK_COMPILE_FLAG(-Wall, [CFLAGS="-Wall${CFLAGS+ $CFLAGS}"])
-AX_CHECK_COMPILE_FLAG(-Wextra, [CFLAGS="-Wextra${CFLAGS+ $CFLAGS}"])
-AX_CHECK_COMPILE_FLAG(-pedantic, [CFLAGS="-pedantic${CFLAGS+ $CFLAGS}"])
+EXTRA_CFLAGS=
+AX_CHECK_COMPILE_FLAG(-Wall, [EXTRA_CFLAGS="-Wall${EXTRA_CFLAGS+ $EXTRA_CFLAGS}"])
+AX_CHECK_COMPILE_FLAG(-Wextra, [EXTRA_CFLAGS="-Wextra${EXTRA_CFLAGS+ $EXTRA_CFLAGS}"])
+AX_CHECK_COMPILE_FLAG(-pedantic, [EXTRA_CFLAGS="-pedantic${EXTRA_CFLAGS+ $EXTRA_CFLAGS}"])
+AC_SUBST(EXTRA_CFLAGS)
AC_OUTPUT(Makefile)