summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2022-01-09 18:34:04 -0500
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2022-01-09 18:34:04 -0500
commit1901353665975c6c65f845149fcea453fbc4e0b7 (patch)
tree2d084c336cda0f161d5ff00ae9604d2f9b0b8ecd
parent33c0c860c82ff08c949222f43554f2c0405f587d (diff)
downloadgentoo-overlay-1901353665975c6c65f845149fcea453fbc4e0b7.tar.xz
gentoo-overlay-1901353665975c6c65f845149fcea453fbc4e0b7.zip
dev-cpp/pangomm: import+fixes
-rw-r--r--dev-cpp/pangomm/Manifest1
-rw-r--r--dev-cpp/pangomm/files/pangomm-pango-1.50.patch10
-rw-r--r--dev-cpp/pangomm/metadata.xml4
-rw-r--r--dev-cpp/pangomm/pangomm-2.42.2-r2.ebuild43
4 files changed, 58 insertions, 0 deletions
diff --git a/dev-cpp/pangomm/Manifest b/dev-cpp/pangomm/Manifest
new file mode 100644
index 0000000..1a4cc83
--- /dev/null
+++ b/dev-cpp/pangomm/Manifest
@@ -0,0 +1 @@
+DIST pangomm-2.42.2.tar.xz 656760 BLAKE2B 8fae779aa78b2337b83759adc7aadec1f61c08c54d892e3cdd05180e2ab032a61faa72c39281fab649bcd08591c5d7ace9ea65b25f76ce17d6f4d96f38900b6a SHA512 5e4826d64c0178527b4df73e901d2fdf5661d41777e189f5e2d4b26577e42689efaccf5a28502246c6b3926571ccd5876cb23d33267b44ace7ee164322c14667
diff --git a/dev-cpp/pangomm/files/pangomm-pango-1.50.patch b/dev-cpp/pangomm/files/pangomm-pango-1.50.patch
new file mode 100644
index 0000000..9f2d14e
--- /dev/null
+++ b/dev-cpp/pangomm/files/pangomm-pango-1.50.patch
@@ -0,0 +1,10 @@
+--- a/pango/pangomm/attributes.h
++++ b/pango/pangomm/attributes.h
+@@ -30,6 +30,9 @@
+ #include <pangomm/color.h>
+ #include <pangomm/fontdescription.h>
+ #include <pango/pango-attributes.h>
++#if __has_include(<pango/pango-markup.h>)
++#include <pango/pango-markup.h>
++#endif
+ #include <glibmm/slisthandle.h>
diff --git a/dev-cpp/pangomm/metadata.xml b/dev-cpp/pangomm/metadata.xml
new file mode 100644
index 0000000..7c900b1
--- /dev/null
+++ b/dev-cpp/pangomm/metadata.xml
@@ -0,0 +1,4 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+</pkgmetadata>
diff --git a/dev-cpp/pangomm/pangomm-2.42.2-r2.ebuild b/dev-cpp/pangomm/pangomm-2.42.2-r2.ebuild
new file mode 100644
index 0000000..45d4050
--- /dev/null
+++ b/dev-cpp/pangomm/pangomm-2.42.2-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+inherit gnome.org meson-multilib python-any-r1
+
+DESCRIPTION="C++ interface for pango"
+HOMEPAGE="https://www.gtkmm.org"
+
+LICENSE="LGPL-2.1+"
+SLOT="1.4"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE="doc"
+
+DEPEND="
+ >=dev-cpp/cairomm-1.2.2:0[doc?,${MULTILIB_USEDEP}]
+ >=dev-cpp/glibmm-2.48.0:2[doc?,${MULTILIB_USEDEP}]
+ dev-libs/libsigc++:2[doc?,${MULTILIB_USEDEP}]
+ x11-libs/pango[${MULTILIB_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen[dot]
+ dev-lang/perl
+ dev-libs/libxslt
+ )
+ ${PYTHON_DEPS}
+"
+
+PATCHES=(
+ "${FILESDIR}/pangomm-pango-1.50.patch"
+)
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_native_use_bool doc build-documentation)
+ )
+ meson_src_configure
+}