summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-04-28 10:38:39 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-04-28 10:39:49 -0400
commite050e57bc73b42f73ead76ea1517c77eea17ab45 (patch)
tree11c06baf764b616d3091b6a5a7a159782e2c7952
parent8c919cbaa0a6511c8b8c333142a309ffd4995624 (diff)
downloadgentoo-overlay-e050e57bc73b42f73ead76ea1517c77eea17ab45.tar.xz
gentoo-overlay-e050e57bc73b42f73ead76ea1517c77eea17ab45.zip
dev-java/*openjdk*: various fixes
- merge SLOT envs into one, less work when bumping (we don't support 8 anyways) - sync ::gentoo
-rw-r--r--dev-java/openj9-openjdk-bin/files/openj9-openjdk-bin-16.env.sh16
-rw-r--r--dev-java/openj9-openjdk-bin/files/openj9-openjdk-bin.env.sh (renamed from dev-java/openj9-openjdk-bin/files/openj9-openjdk-bin-11.env.sh)0
-rw-r--r--dev-java/openj9-openjdk-bin/openj9-openjdk-bin-11.0.11.9.0.26.0.ebuild2
-rw-r--r--dev-java/openj9-openjdk-bin/openj9-openjdk-bin-16.0.1.9.0.26.0.ebuild7
-rw-r--r--dev-java/openj9-openjdk-jre-bin/files/openj9-openjdk-jre-bin-16.env.sh16
-rw-r--r--dev-java/openj9-openjdk-jre-bin/files/openj9-openjdk-jre-bin.env.sh (renamed from dev-java/openj9-openjdk-jre-bin/files/openj9-openjdk-jre-bin-11.env.sh)0
-rw-r--r--dev-java/openj9-openjdk-jre-bin/openj9-openjdk-jre-bin-11.0.11.9.0.26.0.ebuild2
-rw-r--r--dev-java/openj9-openjdk-jre-bin/openj9-openjdk-jre-bin-16.0.1.9.0.26.0.ebuild7
-rw-r--r--dev-java/openj9-openjdk/openj9-openjdk-11.0.26.0.ebuild7
-rw-r--r--dev-java/openj9-openjdk/openj9-openjdk-11.9999.ebuild7
-rw-r--r--dev-java/openj9-openjdk/openj9-openjdk-16.0.26.0.ebuild7
-rw-r--r--dev-java/openj9-openjdk/openj9-openjdk-16.9999.ebuild7
-rw-r--r--dev-java/openjdk-bin/files/openjdk-bin.env.sh (renamed from dev-java/openjdk-bin/files/openjdk-bin-16.env.sh)0
-rw-r--r--dev-java/openjdk-bin/openjdk-bin-16.0.1_p9.ebuild7
-rw-r--r--dev-java/openjdk-jre-bin/files/openjdk-jre-bin.env.sh (renamed from dev-java/openjdk-jre-bin/files/openjdk-jre-bin-16.env.sh)0
-rw-r--r--dev-java/openjdk-jre-bin/openjdk-jre-bin-16.0.1_p9.ebuild7
-rw-r--r--dev-java/openjdk/files/openjdk.env.sh (renamed from dev-java/openjdk/files/openjdk-16.env.sh)0
-rw-r--r--dev-java/openjdk/openjdk-16.0.1_p9.ebuild11
18 files changed, 33 insertions, 70 deletions
diff --git a/dev-java/openj9-openjdk-bin/files/openj9-openjdk-bin-16.env.sh b/dev-java/openj9-openjdk-bin/files/openj9-openjdk-bin-16.env.sh
deleted file mode 100644
index 2e200d9..0000000
--- a/dev-java/openj9-openjdk-bin/files/openj9-openjdk-bin-16.env.sh
+++ /dev/null
@@ -1,16 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-VERSION="AdoptOpenJDK ${DL_PV}"
-JAVA_HOME="${EPREFIX}/opt/${P}"
-JDK_HOME="${EPREFIX}/opt/${P}"
-JAVAC="\${JAVA_HOME}/bin/javac"
-PATH="\${JAVA_HOME}/bin"
-ROOTPATH="\${JAVA_HOME}/bin"
-LDPATH="\${JAVA_HOME}/lib/:\${JAVA_HOME}/lib/server/"
-MANPATH=""
-PROVIDES_TYPE="JDK JRE"
-PROVIDES_VERSION="${SLOT}"
-BOOTCLASSPATH=""
-GENERATION="2"
-ENV_VARS="JAVA_HOME JDK_HOME JAVAC PATH ROOTPATH LDPATH MANPATH"
diff --git a/dev-java/openj9-openjdk-bin/files/openj9-openjdk-bin-11.env.sh b/dev-java/openj9-openjdk-bin/files/openj9-openjdk-bin.env.sh
index 2e200d9..2e200d9 100644
--- a/dev-java/openj9-openjdk-bin/files/openj9-openjdk-bin-11.env.sh
+++ b/dev-java/openj9-openjdk-bin/files/openj9-openjdk-bin.env.sh
diff --git a/dev-java/openj9-openjdk-bin/openj9-openjdk-bin-11.0.11.9.0.26.0.ebuild b/dev-java/openj9-openjdk-bin/openj9-openjdk-bin-11.0.11.9.0.26.0.ebuild
index bd6296d..a1ef619 100644
--- a/dev-java/openj9-openjdk-bin/openj9-openjdk-bin-11.0.11.9.0.26.0.ebuild
+++ b/dev-java/openj9-openjdk-bin/openj9-openjdk-bin-11.0.11.9.0.26.0.ebuild
@@ -98,7 +98,7 @@ src_install() {
# provide stable symlink
dosym "${P}" "/opt/${PN}-${SLOT}"
- use gentoo-vm && java-vm_install-env "${FILESDIR}"/${PN}-${SLOT}.env.sh
+ use gentoo-vm && java-vm_install-env "${FILESDIR}"/${PN}.env.sh
java-vm_set-pax-markings "${ddest}"
java-vm_revdep-mask
java-vm_sandbox-predict /dev/random /proc/self/coredump_filter
diff --git a/dev-java/openj9-openjdk-bin/openj9-openjdk-bin-16.0.1.9.0.26.0.ebuild b/dev-java/openj9-openjdk-bin/openj9-openjdk-bin-16.0.1.9.0.26.0.ebuild
index b75020d..d5df217 100644
--- a/dev-java/openj9-openjdk-bin/openj9-openjdk-bin-16.0.1.9.0.26.0.ebuild
+++ b/dev-java/openj9-openjdk-bin/openj9-openjdk-bin-16.0.1.9.0.26.0.ebuild
@@ -69,11 +69,6 @@ src_install() {
local dest="/opt/${P}"
local ddest="${ED%/}/${dest#/}"
- # Not sure why they bundle this as it's commonly available and they
- # only do so on x86_64. It's needed by libfontmanager.so. IcedTea
- # also has an explicit dependency while Oracle seemingly dlopens it.
- do_rm 'lib/libfreetype.*'
-
# Oracle and IcedTea have libjsoundalsa.so depending on
# libasound.so.2 but AdoptOpenJDK only has libjsound.so. Weird.
if ! use alsa ; then
@@ -98,7 +93,7 @@ src_install() {
# provide stable symlink
dosym "${P}" "/opt/${PN}-${SLOT}"
- use gentoo-vm && java-vm_install-env "${FILESDIR}"/${PN}-${SLOT}.env.sh
+ use gentoo-vm && java-vm_install-env "${FILESDIR}"/${PN}.env.sh
java-vm_set-pax-markings "${ddest}"
java-vm_revdep-mask
java-vm_sandbox-predict /dev/random /proc/self/coredump_filter
diff --git a/dev-java/openj9-openjdk-jre-bin/files/openj9-openjdk-jre-bin-16.env.sh b/dev-java/openj9-openjdk-jre-bin/files/openj9-openjdk-jre-bin-16.env.sh
deleted file mode 100644
index 1ad9132..0000000
--- a/dev-java/openj9-openjdk-jre-bin/files/openj9-openjdk-jre-bin-16.env.sh
+++ /dev/null
@@ -1,16 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-VERSION="AdoptOpenJDK JRE ${DL_PV}"
-JAVA_HOME="${EPREFIX}/opt/${P}"
-JDK_HOME="${EPREFIX}/opt/${P}"
-JAVAC="\${JAVA_HOME}/bin/javac"
-PATH="\${JAVA_HOME}/bin"
-ROOTPATH="\${JAVA_HOME}/bin"
-LDPATH="\${JAVA_HOME}/lib/:\${JAVA_HOME}/lib/server/"
-MANPATH="\${JAVA_HOME}/man"
-PROVIDES_TYPE="JRE"
-PROVIDES_VERSION="${SLOT}"
-BOOTCLASSPATH=""
-GENERATION="2"
-ENV_VARS="JAVA_HOME JDK_HOME JAVAC PATH ROOTPATH LDPATH MANPATH"
diff --git a/dev-java/openj9-openjdk-jre-bin/files/openj9-openjdk-jre-bin-11.env.sh b/dev-java/openj9-openjdk-jre-bin/files/openj9-openjdk-jre-bin.env.sh
index 1ad9132..1ad9132 100644
--- a/dev-java/openj9-openjdk-jre-bin/files/openj9-openjdk-jre-bin-11.env.sh
+++ b/dev-java/openj9-openjdk-jre-bin/files/openj9-openjdk-jre-bin.env.sh
diff --git a/dev-java/openj9-openjdk-jre-bin/openj9-openjdk-jre-bin-11.0.11.9.0.26.0.ebuild b/dev-java/openj9-openjdk-jre-bin/openj9-openjdk-jre-bin-11.0.11.9.0.26.0.ebuild
index 7dac1e1..aec0d85 100644
--- a/dev-java/openj9-openjdk-jre-bin/openj9-openjdk-jre-bin-11.0.11.9.0.26.0.ebuild
+++ b/dev-java/openj9-openjdk-jre-bin/openj9-openjdk-jre-bin-11.0.11.9.0.26.0.ebuild
@@ -78,7 +78,7 @@ src_install() {
# provide stable symlink
dosym "${P}" "/opt/${PN}-${SLOT}"
- use gentoo-vm && java-vm_install-env "${FILESDIR}"/${PN}-${SLOT}.env.sh
+ use gentoo-vm && java-vm_install-env "${FILESDIR}"/${PN}.env.sh
java-vm_set-pax-markings "${ddest}"
java-vm_revdep-mask
java-vm_sandbox-predict /dev/random /proc/self/coredump_filter
diff --git a/dev-java/openj9-openjdk-jre-bin/openj9-openjdk-jre-bin-16.0.1.9.0.26.0.ebuild b/dev-java/openj9-openjdk-jre-bin/openj9-openjdk-jre-bin-16.0.1.9.0.26.0.ebuild
index 7dac1e1..36c7ab7 100644
--- a/dev-java/openj9-openjdk-jre-bin/openj9-openjdk-jre-bin-16.0.1.9.0.26.0.ebuild
+++ b/dev-java/openj9-openjdk-jre-bin/openj9-openjdk-jre-bin-16.0.1.9.0.26.0.ebuild
@@ -54,11 +54,6 @@ src_install() {
local dest="/opt/${P}"
local ddest="${ED%/}/${dest#/}"
- # Not sure why they bundle this as it's commonly available and they
- # only do so on x86_64. It's needed by libfontmanager.so. IcedTea
- # also has an explicit dependency while Oracle seemingly dlopens it.
- rm -vf lib/libfreetype.so || die
-
# Oracle and IcedTea have libjsoundalsa.so depending on
# libasound.so.2 but AdoptOpenJDK only has libjsound.so. Weird.
if ! use alsa ; then
@@ -78,7 +73,7 @@ src_install() {
# provide stable symlink
dosym "${P}" "/opt/${PN}-${SLOT}"
- use gentoo-vm && java-vm_install-env "${FILESDIR}"/${PN}-${SLOT}.env.sh
+ use gentoo-vm && java-vm_install-env "${FILESDIR}"/${PN}.env.sh
java-vm_set-pax-markings "${ddest}"
java-vm_revdep-mask
java-vm_sandbox-predict /dev/random /proc/self/coredump_filter
diff --git a/dev-java/openj9-openjdk/openj9-openjdk-11.0.26.0.ebuild b/dev-java/openj9-openjdk/openj9-openjdk-11.0.26.0.ebuild
index 63b091f..98aa764 100644
--- a/dev-java/openj9-openjdk/openj9-openjdk-11.0.26.0.ebuild
+++ b/dev-java/openj9-openjdk/openj9-openjdk-11.0.26.0.ebuild
@@ -33,6 +33,7 @@ IUSE="alsa cups ddr debug doc examples gentoo-vm headless-awt javafx +jbootstrap
COMMON_DEPEND="
media-libs/freetype:2=
media-libs/giflib:0/7
+ media-libs/harfbuzz:=
media-libs/libpng:0=
media-libs/lcms:2=
sys-libs/zlib
@@ -115,7 +116,7 @@ openjdk_check_requirements() {
pkg_pretend() {
openjdk_check_requirements
if [[ ${MERGE_TYPE} != binary ]]; then
- has ccache ${FEATURES} && die "FEATURES=ccache doesn't work with ${PN}"
+ has ccache ${FEATURES} && die "FEATURES=ccache doesn't work with ${PN}, bug #677876"
fi
}
@@ -221,7 +222,9 @@ src_configure() {
--with-extra-cxxflags="${CXXFLAGS}"
--with-extra-ldflags="${LDFLAGS}"
--with-stdc++lib=dynamic
+ --with-freetype=system
--with-giflib=system
+ --with-harfbuzz=system
--with-lcms=system
--with-libjpeg=system
--with-libpng=system
@@ -244,7 +247,7 @@ src_configure() {
)
if use javafx; then
- local zip="${EROOT%/}/usr/$(get_libdir)/openjfx-${SLOT}/javafx-exports.zip"
+ local zip="${EPREFIX%/}/usr/$(get_libdir)/openjfx-${SLOT}/javafx-exports.zip"
if [[ -r ${zip} ]]; then
myconf+=( --with-import-modules="${zip}" )
else
diff --git a/dev-java/openj9-openjdk/openj9-openjdk-11.9999.ebuild b/dev-java/openj9-openjdk/openj9-openjdk-11.9999.ebuild
index 3d7eacb..61efb07 100644
--- a/dev-java/openj9-openjdk/openj9-openjdk-11.9999.ebuild
+++ b/dev-java/openj9-openjdk/openj9-openjdk-11.9999.ebuild
@@ -33,6 +33,7 @@ IUSE="alsa cups ddr debug doc examples gentoo-vm headless-awt javafx +jbootstrap
COMMON_DEPEND="
media-libs/freetype:2=
media-libs/giflib:0/7
+ media-libs/harfbuzz:=
media-libs/libpng:0=
media-libs/lcms:2=
sys-libs/zlib
@@ -115,7 +116,7 @@ openjdk_check_requirements() {
pkg_pretend() {
openjdk_check_requirements
if [[ ${MERGE_TYPE} != binary ]]; then
- has ccache ${FEATURES} && die "FEATURES=ccache doesn't work with ${PN}"
+ has ccache ${FEATURES} && die "FEATURES=ccache doesn't work with ${PN}, bug #677876"
fi
}
@@ -221,7 +222,9 @@ src_configure() {
--with-extra-cxxflags="${CXXFLAGS}"
--with-extra-ldflags="${LDFLAGS}"
--with-stdc++lib=dynamic
+ --with-freetype=system
--with-giflib=system
+ --with-harfbuzz=system
--with-lcms=system
--with-libjpeg=system
--with-libpng=system
@@ -244,7 +247,7 @@ src_configure() {
)
if use javafx; then
- local zip="${EROOT%/}/usr/$(get_libdir)/openjfx-${SLOT}/javafx-exports.zip"
+ local zip="${EPREFIX%/}/usr/$(get_libdir)/openjfx-${SLOT}/javafx-exports.zip"
if [[ -r ${zip} ]]; then
myconf+=( --with-import-modules="${zip}" )
else
diff --git a/dev-java/openj9-openjdk/openj9-openjdk-16.0.26.0.ebuild b/dev-java/openj9-openjdk/openj9-openjdk-16.0.26.0.ebuild
index b7b09be..c92e490 100644
--- a/dev-java/openj9-openjdk/openj9-openjdk-16.0.26.0.ebuild
+++ b/dev-java/openj9-openjdk/openj9-openjdk-16.0.26.0.ebuild
@@ -33,6 +33,7 @@ IUSE="alsa cups ddr debug doc examples gentoo-vm headless-awt javafx +jbootstrap
COMMON_DEPEND="
media-libs/freetype:2=
media-libs/giflib:0/7
+ media-libs/harfbuzz:=
media-libs/libpng:0=
media-libs/lcms:2=
sys-libs/zlib
@@ -112,7 +113,7 @@ openjdk_check_requirements() {
pkg_pretend() {
openjdk_check_requirements
if [[ ${MERGE_TYPE} != binary ]]; then
- has ccache ${FEATURES} && die "FEATURES=ccache doesn't work with ${PN}"
+ has ccache ${FEATURES} && die "FEATURES=ccache doesn't work with ${PN}, bug #677876"
fi
}
@@ -179,7 +180,9 @@ src_configure() {
--with-extra-cxxflags="${CXXFLAGS}"
--with-extra-ldflags="${LDFLAGS}"
--with-stdc++lib=dynamic
+ --with-freetype=system
--with-giflib=system
+ --with-harfbuzz=system
--with-lcms=system
--with-libjpeg=system
--with-libpng=system
@@ -202,7 +205,7 @@ src_configure() {
)
if use javafx; then
- local zip="${EROOT%/}/usr/$(get_libdir)/openjfx-${SLOT}/javafx-exports.zip"
+ local zip="${EPREFIX%/}/usr/$(get_libdir)/openjfx-${SLOT}/javafx-exports.zip"
if [[ -r ${zip} ]]; then
myconf+=( --with-import-modules="${zip}" )
else
diff --git a/dev-java/openj9-openjdk/openj9-openjdk-16.9999.ebuild b/dev-java/openj9-openjdk/openj9-openjdk-16.9999.ebuild
index 05f21ae..f7ee71c 100644
--- a/dev-java/openj9-openjdk/openj9-openjdk-16.9999.ebuild
+++ b/dev-java/openj9-openjdk/openj9-openjdk-16.9999.ebuild
@@ -33,6 +33,7 @@ IUSE="alsa cups ddr debug doc examples gentoo-vm headless-awt javafx +jbootstrap
COMMON_DEPEND="
media-libs/freetype:2=
media-libs/giflib:0/7
+ media-libs/harfbuzz:=
media-libs/libpng:0=
media-libs/lcms:2=
sys-libs/zlib
@@ -112,7 +113,7 @@ openjdk_check_requirements() {
pkg_pretend() {
openjdk_check_requirements
if [[ ${MERGE_TYPE} != binary ]]; then
- has ccache ${FEATURES} && die "FEATURES=ccache doesn't work with ${PN}"
+ has ccache ${FEATURES} && die "FEATURES=ccache doesn't work with ${PN}, bug #677876"
fi
}
@@ -179,7 +180,9 @@ src_configure() {
--with-extra-cxxflags="${CXXFLAGS}"
--with-extra-ldflags="${LDFLAGS}"
--with-stdc++lib=dynamic
+ --with-freetype=system
--with-giflib=system
+ --with-harfbuzz=system
--with-lcms=system
--with-libjpeg=system
--with-libpng=system
@@ -202,7 +205,7 @@ src_configure() {
)
if use javafx; then
- local zip="${EROOT%/}/usr/$(get_libdir)/openjfx-${SLOT}/javafx-exports.zip"
+ local zip="${EPREFIX%/}/usr/$(get_libdir)/openjfx-${SLOT}/javafx-exports.zip"
if [[ -r ${zip} ]]; then
myconf+=( --with-import-modules="${zip}" )
else
diff --git a/dev-java/openjdk-bin/files/openjdk-bin-16.env.sh b/dev-java/openjdk-bin/files/openjdk-bin.env.sh
index 9e9c5ec..9e9c5ec 100644
--- a/dev-java/openjdk-bin/files/openjdk-bin-16.env.sh
+++ b/dev-java/openjdk-bin/files/openjdk-bin.env.sh
diff --git a/dev-java/openjdk-bin/openjdk-bin-16.0.1_p9.ebuild b/dev-java/openjdk-bin/openjdk-bin-16.0.1_p9.ebuild
index 6a82f20..8682e0f 100644
--- a/dev-java/openjdk-bin/openjdk-bin-16.0.1_p9.ebuild
+++ b/dev-java/openjdk-bin/openjdk-bin-16.0.1_p9.ebuild
@@ -60,11 +60,6 @@ src_install() {
local dest="/opt/${P}"
local ddest="${ED%/}/${dest#/}"
- # Not sure why they bundle this as it's commonly available and they
- # only do so on x86_64. It's needed by libfontmanager.so. IcedTea
- # also has an explicit dependency while Oracle seemingly dlopens it.
- rm -vf lib/libfreetype.so || die
-
# Oracle and IcedTea have libjsoundalsa.so depending on
# libasound.so.2 but AdoptOpenJDK only has libjsound.so. Weird.
if ! use alsa ; then
@@ -89,7 +84,7 @@ src_install() {
# provide stable symlink
dosym "${P}" "/opt/${PN}-${SLOT}"
- use gentoo-vm && java-vm_install-env "${FILESDIR}"/${PN}-${SLOT}.env.sh
+ use gentoo-vm && java-vm_install-env "${FILESDIR}"/${PN}.env.sh
java-vm_set-pax-markings "${ddest}"
java-vm_revdep-mask
java-vm_sandbox-predict /dev/random /proc/self/coredump_filter
diff --git a/dev-java/openjdk-jre-bin/files/openjdk-jre-bin-16.env.sh b/dev-java/openjdk-jre-bin/files/openjdk-jre-bin.env.sh
index ec0dca4..ec0dca4 100644
--- a/dev-java/openjdk-jre-bin/files/openjdk-jre-bin-16.env.sh
+++ b/dev-java/openjdk-jre-bin/files/openjdk-jre-bin.env.sh
diff --git a/dev-java/openjdk-jre-bin/openjdk-jre-bin-16.0.1_p9.ebuild b/dev-java/openjdk-jre-bin/openjdk-jre-bin-16.0.1_p9.ebuild
index b157010..8e41243 100644
--- a/dev-java/openjdk-jre-bin/openjdk-jre-bin-16.0.1_p9.ebuild
+++ b/dev-java/openjdk-jre-bin/openjdk-jre-bin-16.0.1_p9.ebuild
@@ -54,11 +54,6 @@ src_install() {
local dest="/opt/${P}"
local ddest="${ED%/}/${dest#/}"
- # Not sure why they bundle this as it's commonly available and they
- # only do so on x86_64. It's needed by libfontmanager.so. IcedTea
- # also has an explicit dependency while Oracle seemingly dlopens it.
- rm -vf lib/libfreetype.so || die
-
# Oracle and IcedTea have libjsoundalsa.so depending on
# libasound.so.2 but AdoptOpenJDK only has libjsound.so. Weird.
if ! use alsa ; then
@@ -78,7 +73,7 @@ src_install() {
# provide stable symlink
dosym "${P}" "/opt/${PN}-${SLOT}"
- use gentoo-vm && java-vm_install-env "${FILESDIR}"/${PN}-${SLOT}.env.sh
+ use gentoo-vm && java-vm_install-env "${FILESDIR}"/${PN}.env.sh
java-vm_set-pax-markings "${ddest}"
java-vm_revdep-mask
java-vm_sandbox-predict /dev/random /proc/self/coredump_filter
diff --git a/dev-java/openjdk/files/openjdk-16.env.sh b/dev-java/openjdk/files/openjdk.env.sh
index 96c4be7..96c4be7 100644
--- a/dev-java/openjdk/files/openjdk-16.env.sh
+++ b/dev-java/openjdk/files/openjdk.env.sh
diff --git a/dev-java/openjdk/openjdk-16.0.1_p9.ebuild b/dev-java/openjdk/openjdk-16.0.1_p9.ebuild
index 0a506f5..7a5b20f 100644
--- a/dev-java/openjdk/openjdk-16.0.1_p9.ebuild
+++ b/dev-java/openjdk/openjdk-16.0.1_p9.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -22,6 +22,7 @@ IUSE="alsa cups debug doc examples gentoo-vm headless-awt javafx +jbootstrap +pc
COMMON_DEPEND="
media-libs/freetype:2=
media-libs/giflib:0/7
+ media-libs/harfbuzz:=
media-libs/libpng:0=
media-libs/lcms:2=
sys-libs/zlib
@@ -85,7 +86,7 @@ openjdk_check_requirements() {
pkg_pretend() {
openjdk_check_requirements
if [[ ${MERGE_TYPE} != binary ]]; then
- has ccache ${FEATURES} && die "FEATURES=ccache doesn't work with ${PN}"
+ has ccache ${FEATURES} && die "FEATURES=ccache doesn't work with ${PN}, bug #677876"
fi
}
@@ -123,7 +124,9 @@ src_configure() {
--with-extra-cflags="${CFLAGS}"
--with-extra-cxxflags="${CXXFLAGS}"
--with-extra-ldflags="${LDFLAGS}"
+ --with-freetype=system
--with-giflib=system
+ --with-harfbuzz=system
--with-lcms=system
--with-libjpeg=system
--with-libpng=system
@@ -143,7 +146,7 @@ src_configure() {
)
if use javafx; then
- local zip="${EROOT%/}/usr/$(get_libdir)/openjfx-${SLOT}/javafx-exports.zip"
+ local zip="${EPREFIX%/}/usr/$(get_libdir)/openjfx-${SLOT}/javafx-exports.zip"
if [[ -r ${zip} ]]; then
myconf+=( --with-import-modules="${zip}" )
else
@@ -215,7 +218,7 @@ src_install() {
einfo "Creating the Class Data Sharing archives and disabling usage tracking"
"${ddest}/bin/java" -server -Xshare:dump -Djdk.disableLastUsageTracking || die
- use gentoo-vm && java-vm_install-env "${FILESDIR}"/${PN}-${SLOT}.env.sh
+ use gentoo-vm && java-vm_install-env "${FILESDIR}"/${PN}.env.sh
java-vm_revdep-mask
java-vm_sandbox-predict /dev/random /proc/self/coredump_filter