summaryrefslogtreecommitdiff
path: root/app-text
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-07-28 09:41:37 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-07-28 09:41:37 -0400
commitd241ee7943383a8ad8aacd70d5e301a6acf22c38 (patch)
tree5aaddca6d5744a9e3565da0846cbda2e1a34be3b /app-text
downloadgentoo-overlay-d241ee7943383a8ad8aacd70d5e301a6acf22c38.tar.xz
gentoo-overlay-d241ee7943383a8ad8aacd70d5e301a6acf22c38.zip
Initial commit
Diffstat (limited to 'app-text')
-rw-r--r--app-text/pdfsizeopt/metadata.xml8
-rw-r--r--app-text/pdfsizeopt/pdfsizeopt-9999.ebuild36
2 files changed, 44 insertions, 0 deletions
diff --git a/app-text/pdfsizeopt/metadata.xml b/app-text/pdfsizeopt/metadata.xml
new file mode 100644
index 0000000..004555a
--- /dev/null
+++ b/app-text/pdfsizeopt/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alex_y_xu@yahoo.ca</email>
+ <name>Alex Xu (Hello71)</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-text/pdfsizeopt/pdfsizeopt-9999.ebuild b/app-text/pdfsizeopt/pdfsizeopt-9999.ebuild
new file mode 100644
index 0000000..0d77669
--- /dev/null
+++ b/app-text/pdfsizeopt/pdfsizeopt-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+inherit git-r3 python-single-r1
+
+DESCRIPTION="PDF file size optimizer"
+HOMEPAGE="https://github.com/pts/pdfsizeopt"
+EGIT_REPO_URI="https://github.com/pts/pdfsizeopt.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ app-text/ghostscript-gpl
+ media-gfx/tif22pnm
+ media-gfx/sam2p
+"
+BDEPEND="${PYTHON_DEPS}"
+
+src_prepare() {
+ default
+ python_fix_shebang mksingle.py
+}
+
+src_compile() {
+ ./mksingle.py
+}
+
+src_install() {
+ newbin pdfsizeopt.single pdfsizeopt
+}